summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-06-10 08:57:00 +0000
committerEray Aslan <eras@gentoo.org>2011-06-10 08:57:00 +0000
commiteb4d44525ac9cedca2e229bf55a632e07227da29 (patch)
treeebe2621f3b44b8511ead9e501f5633af3df44272 /mail-filter/mapson
parentFix sys-fs/udev USE depend wrt #370383 by William Hubbs. (diff)
downloadgentoo-2-eb4d44525ac9cedca2e229bf55a632e07227da29.tar.gz
gentoo-2-eb4d44525ac9cedca2e229bf55a632e07227da29.tar.bz2
gentoo-2-eb4d44525ac9cedca2e229bf55a632e07227da29.zip
Version and EAPI bump.
(Portage version: 2.1.10/cvs/Linux x86_64)
Diffstat (limited to 'mail-filter/mapson')
-rw-r--r--mail-filter/mapson/ChangeLog9
-rw-r--r--mail-filter/mapson/mapson-3.3.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/mail-filter/mapson/ChangeLog b/mail-filter/mapson/ChangeLog
index fe7fcac8dc92..a549c69467de 100644
--- a/mail-filter/mapson/ChangeLog
+++ b/mail-filter/mapson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/mapson
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/mapson/ChangeLog,v 1.7 2009/08/10 08:25:04 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/mapson/ChangeLog,v 1.8 2011/06/10 08:57:00 eras Exp $
+
+*mapson-3.3 (10 Jun 2011)
+
+ 10 Jun 2011; Eray Aslan <eras@gentoo.org> +mapson-3.3.ebuild:
+ Version and EAPI bump.
10 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> mapson-3.0.ebuild,
+files/mapson-3.0-gcc43-tests.patch:
diff --git a/mail-filter/mapson/mapson-3.3.ebuild b/mail-filter/mapson/mapson-3.3.ebuild
new file mode 100644
index 000000000000..fe0792d26558
--- /dev/null
+++ b/mail-filter/mapson/mapson-3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/mapson/mapson-3.3.ebuild,v 1.1 2011/06/10 08:57:00 eras Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A challenge/response-based white-list spam filter"
+HOMEPAGE="http://mapson.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mapson/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+RDEPEND="virtual/mta"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_with debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS INSTALL NEWS README
+ doman doc/mapson.1
+ dohtml doc/mapson.html
+ dodir /etc/mapson
+ insinto /etc/mapson
+ newins sample-config mapson.config
+ dodir /usr/share/mapson
+ insinto /usr/share/mapson
+ newins sample-challenge-template challenge-template
+ rm -f "${D}"/etc/sample-config
+ rm -f "${D}"/usr/share/{mapson.html,sample-challenge-template}
+}