summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-08 17:34:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-08 17:34:40 +0000
commit17fe59ef7f18e70261539702ba6aa4d05b7a8ee5 (patch)
tree9d83d9436d9e7888ff64fd81d372cdc73044ee82 /mail-filter/spamprobe
parentStable on amd64 wrt bug #305183 (diff)
downloadgentoo-2-17fe59ef7f18e70261539702ba6aa4d05b7a8ee5.tar.gz
gentoo-2-17fe59ef7f18e70261539702ba6aa4d05b7a8ee5.tar.bz2
gentoo-2-17fe59ef7f18e70261539702ba6aa4d05b7a8ee5.zip
Fix building with libpng14.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'mail-filter/spamprobe')
-rw-r--r--mail-filter/spamprobe/ChangeLog8
-rw-r--r--mail-filter/spamprobe/files/spamprobe-1.4d-libpng14.patch24
-rw-r--r--mail-filter/spamprobe/spamprobe-1.4d.ebuild32
3 files changed, 45 insertions, 19 deletions
diff --git a/mail-filter/spamprobe/ChangeLog b/mail-filter/spamprobe/ChangeLog
index e7485d615f96..e673ad0bf25b 100644
--- a/mail-filter/spamprobe/ChangeLog
+++ b/mail-filter/spamprobe/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-filter/spamprobe
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamprobe/ChangeLog,v 1.25 2009/02/14 23:41:46 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamprobe/ChangeLog,v 1.26 2010/03/08 17:34:40 ssuominen Exp $
+
+ 08 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> spamprobe-1.4d.ebuild,
+ +files/spamprobe-1.4d-libpng14.patch:
+ Fix building with libpng14.
14 Feb 2009; Markus Meier <maekke@gentoo.org> spamprobe-1.4d.ebuild:
amd64/x86 stable, bug #245859
diff --git a/mail-filter/spamprobe/files/spamprobe-1.4d-libpng14.patch b/mail-filter/spamprobe/files/spamprobe-1.4d-libpng14.patch
new file mode 100644
index 000000000000..c053e899bba1
--- /dev/null
+++ b/mail-filter/spamprobe/files/spamprobe-1.4d-libpng14.patch
@@ -0,0 +1,24 @@
+diff -ur spamprobe-1.4d.orig/src/parser/PngParser.cc spamprobe-1.4d/src/parser/PngParser.cc
+--- spamprobe-1.4d.orig/src/parser/PngParser.cc 2006-11-17 09:11:10.000000000 +0200
++++ spamprobe-1.4d/src/parser/PngParser.cc 2010-03-08 19:37:56.000000000 +0200
+@@ -53,9 +53,9 @@
+ {
+ if (m_initialized) {
+ if (m_infoPtr) {
+- png_destroy_read_struct(&m_pngPtr, &m_infoPtr, png_infopp_NULL);
++ png_destroy_read_struct(&m_pngPtr, &m_infoPtr, NULL);
+ } else {
+- png_destroy_read_struct(&m_pngPtr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct(&m_pngPtr, NULL, NULL);
+ }
+ }
+ }
+@@ -104,7 +104,7 @@
+ int bit_depth, color_type, interlace_type;
+
+ png_get_IHDR(m_pngPtr, m_infoPtr, &width, &height, &bit_depth, &color_type,
+- &interlace_type, int_p_NULL, int_p_NULL);
++ &interlace_type, (int *) NULL, (int *) NULL);
+
+ string base_token("image_0");
+ sendToken(base_token + "_height_" + num_to_string((int)width));
diff --git a/mail-filter/spamprobe/spamprobe-1.4d.ebuild b/mail-filter/spamprobe/spamprobe-1.4d.ebuild
index 1be3742d332f..cbeb98c17d81 100644
--- a/mail-filter/spamprobe/spamprobe-1.4d.ebuild
+++ b/mail-filter/spamprobe/spamprobe-1.4d.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamprobe/spamprobe-1.4d.ebuild,v 1.4 2009/02/14 23:41:46 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamprobe/spamprobe-1.4d.ebuild,v 1.5 2010/03/08 17:34:40 ssuominen Exp $
+EAPI=2
inherit eutils
DESCRIPTION="Fast, intelligent, automatic spam detector using Bayesian analysis."
@@ -11,32 +12,29 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="QPL"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
-
IUSE="berkdb gif jpeg png"
+
DEPEND="berkdb? ( >=sys-libs/db-3.2 )
- gif? ( media-libs/giflib )
- jpeg? ( media-libs/jpeg )
- png? ( media-libs/libpng )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.4b-gcc43.patch
+ gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg:0 )
+ png? ( media-libs/libpng )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4b-gcc43.patch \
+ "${FILESDIR}"/${P}-libpng14.patch
}
-src_compile() {
+src_configure() {
econf \
$(use_with gif) \
$(use_with jpeg) \
- $(use_with png) \
- || die "econf failed"
- emake || die "emake failed"
+ $(use_with png)
}
src_install() {
- dodoc README.txt ChangeLog LICENSE.txt
emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README.txt
insinto /usr/share/${PN}/contrib
- doins contrib/*
+ doins contrib/* || die
}