summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott W Taylor <swtaylor@gentoo.org>2004-12-07 01:16:58 +0000
committerScott W Taylor <swtaylor@gentoo.org>2004-12-07 01:16:58 +0000
commit347053dd024d3c3afdcbfbf46feb407a417f88b6 (patch)
tree05aafc0b533c5465a59371db645557f1ff01021c /mail-mta/courier
parentRemoved stray digests. (Manifest recommit) (diff)
downloadgentoo-2-347053dd024d3c3afdcbfbf46feb407a417f88b6.tar.gz
gentoo-2-347053dd024d3c3afdcbfbf46feb407a417f88b6.tar.bz2
gentoo-2-347053dd024d3c3afdcbfbf46feb407a417f88b6.zip
mime.types dependancy
Diffstat (limited to 'mail-mta/courier')
-rw-r--r--mail-mta/courier/ChangeLog6
-rw-r--r--mail-mta/courier/courier-0.47-r1.ebuild11
-rw-r--r--mail-mta/courier/courier-0.47.20041129.ebuild5
3 files changed, 18 insertions, 4 deletions
diff --git a/mail-mta/courier/ChangeLog b/mail-mta/courier/ChangeLog
index 2e192eabf70f..4c06053524a9 100644
--- a/mail-mta/courier/ChangeLog
+++ b/mail-mta/courier/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-mta/courier
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/ChangeLog,v 1.35 2004/12/06 04:11:03 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/ChangeLog,v 1.36 2004/12/07 01:16:58 swtaylor Exp $
+
+ 06 Dec 2004; Scott W Taylor <swtaylor@gentoo.org> courier-0.47-r1.ebuild,
+ courier-0.47.20041129.ebuild:
+ add mime.types dep
05 Dec 2004; Scott W Taylor <swtaylor@gentoo.org> courier-0.47-r1.ebuild,
courier-0.47.20041129.ebuild:
diff --git a/mail-mta/courier/courier-0.47-r1.ebuild b/mail-mta/courier/courier-0.47-r1.ebuild
index 1e8fc92e21a2..1db8c21dc986 100644
--- a/mail-mta/courier/courier-0.47-r1.ebuild
+++ b/mail-mta/courier/courier-0.47-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.47-r1.ebuild,v 1.2 2004/12/06 04:11:03 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.47-r1.ebuild,v 1.3 2004/12/07 01:16:58 swtaylor Exp $
inherit eutils
@@ -20,6 +20,7 @@ PROVIDE="virtual/mta
DEPEND="virtual/libc
>=dev-libs/openssl-0.9.6
>=sys-libs/gdbm-1.8.0
+ || ( app-misc/mime-types net-www/apache )
crypt? ( >=app-crypt/gnupg-1.0.4 )
fax? ( >=media-libs/netpbm-9.12
virtual/ghostscript
@@ -78,6 +79,13 @@ src_compile() {
myconf="${myconf} --disable-unicode"
fi
+ [ -e /etc/apache/conf/mime.types ] && \
+ myconf="${myconf} --enable-mimetypes=/etc/apache/conf/mime.types"
+ [ -e /etc/apache2/conf/mime.types ] && \
+ myconf="${myconf} --enable-mimetypes=/etc/apache2/conf/mime.types"
+ [ -e /etc/mime.types ] && \
+ myconf="${myconf} --enable-mimetypes=/etc/mime.types"
+
myconf="${myconf} debug=true"
./configure \
@@ -96,7 +104,6 @@ src_compile() {
--with-paranoid-smtpext \
--disable-autorenamesent \
--with-db=gdbm \
- --enable-mimetypes=/etc/apache/conf/mime.types \
--enable-workarounds-for-imap-client-bugs \
--host=${CHOST} ${myconf} || die "bad ./configure"
diff --git a/mail-mta/courier/courier-0.47.20041129.ebuild b/mail-mta/courier/courier-0.47.20041129.ebuild
index 1cafec55e3df..4b618cb31b68 100644
--- a/mail-mta/courier/courier-0.47.20041129.ebuild
+++ b/mail-mta/courier/courier-0.47.20041129.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.47.20041129.ebuild,v 1.5 2004/12/06 04:11:03 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.47.20041129.ebuild,v 1.6 2004/12/07 01:16:58 swtaylor Exp $
inherit eutils
@@ -21,6 +21,7 @@ DEPEND="virtual/libc
net-libs/courier-authlib
>=dev-libs/openssl-0.9.6
>=sys-libs/gdbm-1.8.0
+ || ( app-misc/mime-types net-www/apache )
crypt? ( >=app-crypt/gnupg-1.0.4 )
fax? ( >=media-libs/netpbm-9.12 virtual/ghostscript >=net-dialup/mgetty-1.1.28 )
pam? ( >=sys-libs/pam-0.75 )
@@ -57,6 +58,8 @@ src_compile() {
myconf="${myconf} --enable-mimetypes=/etc/apache/conf/mime.types"
[ -e /etc/apache2/conf/mime.types ] && \
myconf="${myconf} --enable-mimetypes=/etc/apache2/conf/mime.types"
+ [ -e /etc/mime.types ] && \
+ myconf="${myconf} --enable-mimetypes=/etc/mime.types"
einfo "Configuring courier: `echo ${myconf} | xargs echo`"
./configure \