summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-07-27 08:04:09 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-07-27 08:04:09 +0000
commit526d3ed9ce5c3e8e711479cd107e91974fdad0e2 (patch)
treee6c74f262178bf513b7f06d285991f0f89c838a8 /mail-mta/ssmtp/ssmtp-2.61-r30.ebuild
parentStable on ppc wrt bug 232704 (diff)
downloadgentoo-2-526d3ed9ce5c3e8e711479cd107e91974fdad0e2.tar.gz
gentoo-2-526d3ed9ce5c3e8e711479cd107e91974fdad0e2.tar.bz2
gentoo-2-526d3ed9ce5c3e8e711479cd107e91974fdad0e2.zip
Clean up, rev-bump to fix perms on ssmtp binary (#233027)
(Portage version: 2.2_rc3/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'mail-mta/ssmtp/ssmtp-2.61-r30.ebuild')
-rw-r--r--mail-mta/ssmtp/ssmtp-2.61-r30.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/mail-mta/ssmtp/ssmtp-2.61-r30.ebuild b/mail-mta/ssmtp/ssmtp-2.61-r30.ebuild
deleted file mode 100644
index de6b1d2e4790..000000000000
--- a/mail-mta/ssmtp/ssmtp-2.61-r30.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/ssmtp/ssmtp-2.61-r30.ebuild,v 1.3 2006/10/22 00:37:52 ticho Exp $
-
-inherit eutils mailer
-
-DESCRIPTION="Extremely simple MTA to get mail off the system to a Mailhub"
-HOMEPAGE="ftp://ftp.debian.org/debian/pool/main/s/ssmtp/"
-SRC_URI="mirror://debian/pool/main/s/ssmtp/${P/-/_}.orig.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="ssl ipv6 md5sum"
-
-DEPEND="virtual/libc
- ssl? ( dev-libs/openssl )"
-
-src_compile() {
- # Respect LDFLAGS (bug #152197)
- sed -i -e 's:$(CC) -o:$(CC) @LDFLAGS@ -o:' Makefile.in
-
- econf \
- --sysconfdir=/etc/ssmtp \
- $(use_enable ssl) \
- $(use_enable ipv6 inet6) \
- $(use_enable md5sum md5auth) \
- || die
- make clean || die
- make etcdir=/etc || die
-}
-
-src_install() {
- dodir /usr/bin /usr/sbin /usr/lib
- dosbin ssmtp || die
- fperms 755 /usr/sbin/ssmtp
-
- doman ssmtp.8
- dodoc INSTALL README TLS CHANGELOG_OLD
- newdoc ssmtp.lsm DESC
-
- insinto /etc/ssmtp
- doins ssmtp.conf revaliases
-
- local conffile="${D}/etc/ssmtp/ssmtp.conf"
- mv "${conffile}" "${conffile}.orig"
-
- # Sorry about the weird indentation, I couldn't figure out a cleverer way
- # to do this without having horribly >80 char lines.
- sed -e "s:^hostname=:\n# Gentoo bug #47562\\
-# Commenting the following line will force ssmtp to figure\\
-# out the hostname itself.\n\\
-# hostname=:" "${conffile}.orig" \
- > "${conffile}" \
- || die "sed failed"
-
- if use mailwrapper ; then
- dosym /usr/sbin/ssmtp /usr/bin/sendmail.ssmtp
- mailer_install_conf
- else
- dosym /usr/sbin/ssmtp /usr/lib/sendmail
- dosym /usr/sbin/ssmtp /usr/bin/sendmail
- dosym /usr/sbin/ssmtp /usr/bin/mailq
- dosym /usr/sbin/ssmtp /usr/bin/newaliases
- fi
-}