summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-01-01 02:06:41 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-01-01 02:06:41 +0000
commit96cd09d078aa773a9d9fb0e5e549898687a0ee1e (patch)
tree1325e1ce5a9202a83b51842ef286480cdf8d5af5 /media-fonts
parentMark firmware API-2 stable on AMD64 for 2.6.27 as requested by Thomas Pani <t... (diff)
downloadgentoo-2-96cd09d078aa773a9d9fb0e5e549898687a0ee1e.tar.gz
gentoo-2-96cd09d078aa773a9d9fb0e5e549898687a0ee1e.tar.bz2
gentoo-2-96cd09d078aa773a9d9fb0e5e549898687a0ee1e.zip
Fixed parallel make issue, bug #247719. Clean up.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/zh-kcfonts/ChangeLog10
-rw-r--r--media-fonts/zh-kcfonts/files/kcfonts-1.05-parallel-make.patch11
-rw-r--r--media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild38
3 files changed, 57 insertions, 2 deletions
diff --git a/media-fonts/zh-kcfonts/ChangeLog b/media-fonts/zh-kcfonts/ChangeLog
index 866704ca88c5..5ad1f9112c04 100644
--- a/media-fonts/zh-kcfonts/ChangeLog
+++ b/media-fonts/zh-kcfonts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-fonts/zh-kcfonts
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-fonts/zh-kcfonts/ChangeLog,v 1.21 2007/07/22 07:11:28 dirtyepic Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/zh-kcfonts/ChangeLog,v 1.22 2009/01/01 02:06:41 matsuu Exp $
+
+*zh-kcfonts-1.05-r3 (01 Jan 2009)
+
+ 01 Jan 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +files/kcfonts-1.05-parallel-make.patch, +zh-kcfonts-1.05-r3.ebuild:
+ Fixed parallel make issue, bug #247719. Clean up.
22 Jul 2007; Ryan Hill <dirtyepic@gentoo.org> -zh-kcfonts-1.05-r1.ebuild,
zh-kcfonts-1.05-r2.ebuild:
diff --git a/media-fonts/zh-kcfonts/files/kcfonts-1.05-parallel-make.patch b/media-fonts/zh-kcfonts/files/kcfonts-1.05-parallel-make.patch
new file mode 100644
index 000000000000..93fc8ed9608e
--- /dev/null
+++ b/media-fonts/zh-kcfonts/files/kcfonts-1.05-parallel-make.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2009-01-01 10:45:14.000000000 +0900
++++ Makefile 2009-01-01 10:45:32.000000000 +0900
+@@ -31,7 +31,7 @@
+ $(CC) $(CFLAGS) tran.o kc24f.o -o $@
+ kc15f: tran.o kc15f.o
+ $(CC) $(CFLAGS) tran.o kc15f.o -o $@
+-kc8x15: kc8x15.o
++kc8x15: tran.o kc8x15.o
+ $(CC) $(CFLAGS) tran.o kc8x15.o -o $@
+ kc12x24: kc12x24.o
+ $(CC) $(CFLAGS) kc12x24.o -o $@
diff --git a/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild b/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild
new file mode 100644
index 000000000000..ccd2e4fb5d4d
--- /dev/null
+++ b/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild,v 1.1 2009/01/01 02:06:41 matsuu Exp $
+
+S="${WORKDIR}"
+inherit eutils font toolchain-funcs
+
+MY_P="kcfonts-${PV}"
+DESCRIPTION="Kuo Chauo Chinese Fonts collection in BIG5 encoding"
+SRC_URI="ftp://freebsd.sinica.edu.tw/pub/distfiles/${MY_P}.tar.gz
+ ftp://wm28.csie.ncu.edu.tw/pub/distfiles/${MY_P}.tar.gz
+ mirror://gentoo/${MY_P}-freebsd-aa_ad.patch.gz"
+HOMEPAGE="http://freebsd.sinica.edu.tw/"
+# no real homepage exists, but this was written by Taiwanese FreeBSD devs
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# Only installs fonts
+RESTRICT="strip binchecks"
+
+FONT_SUFFIX="pcf.gz"
+DOCS="00README Xdefaults.*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${WORKDIR}/${MY_P}-freebsd-aa_ad.patch"
+ epatch "${FILESDIR}/${MY_P}-code-fixups.patch"
+ epatch "${FILESDIR}/${MY_P}-parallel-make.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}