summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-12-14 11:57:32 +0000
committerJustin Lecher <jlec@gentoo.org>2012-12-14 11:57:32 +0000
commit52cd1c5968aadb3e10c8eaafafe737dcd105510b (patch)
treeb7fdc20bf5a60706c9ecd9cc5b675bccbe89d735 /media-gfx/dispcalgui
parentAdd Ispell license to MISC-FREE license group, bug 445304. (diff)
downloadgentoo-2-52cd1c5968aadb3e10c8eaafafe737dcd105510b.tar.gz
gentoo-2-52cd1c5968aadb3e10c8eaafafe737dcd105510b.tar.bz2
gentoo-2-52cd1c5968aadb3e10c8eaafafe737dcd105510b.zip
media-gfx/dispcalgui: Version Bump
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'media-gfx/dispcalgui')
-rw-r--r--media-gfx/dispcalgui/ChangeLog8
-rw-r--r--media-gfx/dispcalgui/dispcalgui-1.1.2.9.ebuild76
-rw-r--r--media-gfx/dispcalgui/metadata.xml25
3 files changed, 95 insertions, 14 deletions
diff --git a/media-gfx/dispcalgui/ChangeLog b/media-gfx/dispcalgui/ChangeLog
index 316ccceb4897..5832ba7b7cf3 100644
--- a/media-gfx/dispcalgui/ChangeLog
+++ b/media-gfx/dispcalgui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/dispcalgui
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/dispcalgui/ChangeLog,v 1.17 2012/11/02 22:15:41 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dispcalgui/ChangeLog,v 1.18 2012/12/14 11:57:32 jlec Exp $
+
+*dispcalgui-1.1.2.9 (14 Dec 2012)
+
+ 14 Dec 2012; Justin Lecher <jlec@gentoo.org> +dispcalgui-1.1.2.9.ebuild,
+ metadata.xml:
+ Version Bump
*dispcalgui-1.1.2.1 (02 Nov 2012)
diff --git a/media-gfx/dispcalgui/dispcalgui-1.1.2.9.ebuild b/media-gfx/dispcalgui/dispcalgui-1.1.2.9.ebuild
new file mode 100644
index 000000000000..dcee7bcd6eb5
--- /dev/null
+++ b/media-gfx/dispcalgui/dispcalgui-1.1.2.9.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dispcalgui/dispcalgui-1.1.2.9.ebuild,v 1.1 2012/12/14 11:57:32 jlec Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
+
+inherit distutils fdo-mime
+
+MY_PN="dispcalGUI"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display Calibration and Characterization powered by Argyll CMS"
+HOMEPAGE="http://dispcalgui.hoech.net/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-gfx/argyllcms-1.1.0
+ >=dev-python/wxpython-2.8.10.1
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-proto/xineramaproto-1.2
+ >=x11-libs/libXinerama-1.1"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1"
+
+# Just in case someone renames the ebuild
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ README.html
+)
+
+src_prepare() {
+# Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ cd "${S}/dispcalGUI" || die "Cannot cd to source directory."
+ sed -e 's/if which(\"xdg-icon-resource\"):/if which(\"xdg-icon-resource-non-existant\"):/' \
+ -e 's/if which(\"xdg-desktop-menu\"):/if which(\"xdg-desktop-menu-non-existant\"):/' \
+ -i postinstall.py || die "sed'ing out the xdg-* setup functions failed"
+
+# Remove deprecated Encoding key from .desktop file
+ cd "${S}" || die "Cannot cd to work directory."
+ for offendingFile in $(grep -r -l "Encoding=UTF-8" .); do
+ sed -e '/Encoding=UTF-8/d' -i "${offendingFile}" || \
+ die "removing deprecated Encoding key from .desktop files failed"
+ done
+
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+ #remove udev files
+ rm "${D}"/etc/udev/rules.d/55-Argyll.rules || die
+}
+
+pkg_postinst() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postinst
+}
+
+pkg_postrm() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postrm
+}
diff --git a/media-gfx/dispcalgui/metadata.xml b/media-gfx/dispcalgui/metadata.xml
index 37c471e3b3cc..7e7422e80efc 100644
--- a/media-gfx/dispcalgui/metadata.xml
+++ b/media-gfx/dispcalgui/metadata.xml
@@ -1,18 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>proxy-maintainers</herd>
-<maintainer>
-<email>opensource@andmarios.com</email>
-<name>Marios Andreopoulos</name>
-<description>Maintainer.</description>
-</maintainer>
-<maintainer>
-<email>hwoarang@gentoo.org</email>
-<name>Markos Chandras</name>
-<description>Proxy maintainer.</description>
-</maintainer>
-<longdescription lang="en">
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>opensource@andmarios.com</email>
+ <name>Marios Andreopoulos</name>
+ <description>Maintainer.</description>
+ </maintainer>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ <description>Proxy maintainer.</description>
+ </maintainer>
+ <longdescription lang="en">
</longdescription>
</pkgmetadata>
-