summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-04-12 21:57:18 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2015-04-12 21:57:18 +0000
commit2868b30990db02a050cd35ab763f0e29077b8a73 (patch)
tree8d422241a81ac21316288fa659c91cd7fd7237ed /media-gfx/eog
parentUse blkid -t to look up devices via tag values (like UUID/PARTUUID) #525524 b... (diff)
downloadgentoo-2-2868b30990db02a050cd35ab763f0e29077b8a73.tar.gz
gentoo-2-2868b30990db02a050cd35ab763f0e29077b8a73.tar.bz2
gentoo-2-2868b30990db02a050cd35ab763f0e29077b8a73.zip
Version bump. Fix two-finger zoom gesture crash.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-gfx/eog')
-rw-r--r--media-gfx/eog/ChangeLog7
-rw-r--r--media-gfx/eog/eog-3.14.4.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/media-gfx/eog/ChangeLog b/media-gfx/eog/ChangeLog
index 90c81a718b6c..8bf44981e092 100644
--- a/media-gfx/eog/ChangeLog
+++ b/media-gfx/eog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/eog
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.320 2015/03/15 13:27:51 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.321 2015/04/12 21:57:18 eva Exp $
+
+*eog-3.14.4 (12 Apr 2015)
+
+ 12 Apr 2015; Gilles Dartiguelongue <eva@gentoo.org> +eog-3.14.4.ebuild:
+ Version bump. Fix two-finger zoom gesture crash.
15 Mar 2015; Pacho Ramos <pacho@gentoo.org> eog-3.14.3.ebuild:
x86 stable, bug 534012
diff --git a/media-gfx/eog/eog-3.14.4.ebuild b/media-gfx/eog/eog-3.14.4.ebuild
new file mode 100644
index 000000000000..259355692f66
--- /dev/null
+++ b/media-gfx/eog/eog-3.14.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-3.14.4.ebuild,v 1.1 2015/04/12 21:57:18 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="The Eye of GNOME image viewer"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome"
+
+LICENSE="GPL-2+"
+SLOT="1"
+IUSE="+exif +introspection +jpeg lcms +svg tiff xmp"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+REQUIRED_USE="exif? ( jpeg )"
+
+RDEPEND="
+ >=x11-libs/gtk+-3.14:3[introspection,X]
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libxml2-2:2
+ >=dev-libs/libpeas-0.7.4:=[gtk]
+ >=gnome-base/gnome-desktop-2.91.2:3=
+ >=gnome-base/gsettings-desktop-schemas-2.91.92
+ >=x11-misc/shared-mime-info-0.20
+
+ x11-libs/gdk-pixbuf:2[jpeg?,tiff?]
+ x11-libs/libX11
+
+ exif? ( >=media-libs/libexif-0.6.14 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ svg? ( >=gnome-base/librsvg-2.36.2:2 )
+ xmp? ( media-libs/exempi:2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.16
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README THANKS TODO"
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_with jpeg libjpeg) \
+ $(use_with exif libexif) \
+ $(use_with lcms cms) \
+ $(use_with xmp) \
+ $(use_with svg librsvg) \
+ ITSTOOL=$(type -P true)
+}