summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-01-07 14:44:48 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-01-07 14:44:48 +0000
commit886b82ac045b590e24800d4bc7c8205f25738b0d (patch)
tree9298bf3dc55fad89407b80fdb61ee478932314f5 /media-gfx/exact-image
parentBump for #198171, thanks to Matt Michalowski (diff)
downloadgentoo-2-886b82ac045b590e24800d4bc7c8205f25738b0d.tar.gz
gentoo-2-886b82ac045b590e24800d4bc7c8205f25738b0d.tar.bz2
gentoo-2-886b82ac045b590e24800d4bc7c8205f25738b0d.zip
Initial commit. Fixes bug #249032
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/exact-image')
-rw-r--r--media-gfx/exact-image/ChangeLog11
-rw-r--r--media-gfx/exact-image/exact-image-0.7.5.ebuild67
-rw-r--r--media-gfx/exact-image/metadata.xml13
3 files changed, 91 insertions, 0 deletions
diff --git a/media-gfx/exact-image/ChangeLog b/media-gfx/exact-image/ChangeLog
new file mode 100644
index 000000000000..8f5d9c74c1a4
--- /dev/null
+++ b/media-gfx/exact-image/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-gfx/exact-image
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exact-image/ChangeLog,v 1.1 2010/01/07 14:44:48 hwoarang Exp $
+
+*exact-image-0.7.5 (07 Jan 2010)
+
+ 07 Jan 2010; <hwoarang@gentoo.org> +exact-image-0.7.5.ebuild,
+ +metadata.xml:
+ Initial commit of exact-image application. Fixes bug #249032. Ebuild taken
+ from sunrise overlay
+
diff --git a/media-gfx/exact-image/exact-image-0.7.5.ebuild b/media-gfx/exact-image/exact-image-0.7.5.ebuild
new file mode 100644
index 000000000000..959ae5b14e15
--- /dev/null
+++ b/media-gfx/exact-image/exact-image-0.7.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exact-image/exact-image-0.7.5.ebuild,v 1.1 2010/01/07 14:44:48 hwoarang Exp $
+
+EAPI="2"
+
+DESCRIPTION="A fast, modern and generic image processing library"
+HOMEPAGE="http://www.exactcode.de/site/open_source/exactimage/"
+SRC_URI="http://dl.exactcode.de/oss/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="agg expat jpeg jpeg2k lcms lua openexr php perl python ruby swig tiff truetype X"
+
+RDEPEND="agg? ( x11-libs/agg[truetype] )
+ expat? ( dev-libs/expat )
+ jpeg2k? ( media-libs/jasper )
+ jpeg? ( media-libs/jpeg )
+ lcms? ( media-libs/lcms )
+ lua? ( dev-lang/lua )
+ openexr? ( media-libs/openexr )
+ php? ( dev-lang/php )
+ perl? ( sys-devel/libperl )
+ python? ( dev-lang/python )
+ ruby? ( dev-lang/ruby )
+ tiff? ( media-libs/tiff )
+ truetype? ( >=media-libs/freetype-2 )
+ X? (
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM
+ )"
+
+DEPEND="${RDEPEND}
+ swig? ( dev-lang/swig )"
+
+src_configure() {
+ # evas support is disabled since evas is not on main tree. You can find it
+ # on enlightenment overlay
+ # bardecode is disabled since it is protected by custom licence
+ # libungif is disabled as it is not supported anymore
+ myconf=" --without-libungif --without-evas \
+ --without-bardecode --prefix=/usr
+ $(use_with jpeg libjpeg)\
+ $(use_with lua) \
+ $(use_with php) \
+ $(use_with ruby) \
+ $(use_with python) \
+ $(use_with swig) \
+ $(use_with agg libagg) \
+ $(use_with lcms) \
+ $(use_with tiff libtiff) \
+ $(use_with truetype freetype) \
+ $(use_with expat) \
+ $(use_with openexr) \
+ $(use_with jpeg2k jasper) \
+ $(use_with X x11)"
+ #econf fails
+ ./configure ${myconf} || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README || die "dodoc failed"
+}
diff --git a/media-gfx/exact-image/metadata.xml b/media-gfx/exact-image/metadata.xml
new file mode 100644
index 000000000000..9489cd499df8
--- /dev/null
+++ b/media-gfx/exact-image/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<use>
+ <flag name='agg'>Adds Anti-Grain Geometry support<pkg>x11-libs/agg</pkg></flag>
+ <flag name='swig'>Adds Swig support <pkg>dev-lang/swig</pkg></flag>
+</use>
+</pkgmetadata>