summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-06 11:47:08 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-06 11:47:08 +0000
commitf7da238a31b5edbc0dee2fcce573b89d0d5f8cd4 (patch)
tree11fcdda482260fd4a49b91cdc59c2c847de0e0e8 /media-gfx/exact-image
parentRenaming sci-geosciences/gpxviewer to sci-geosciences/gpx-viewer to fit upstr... (diff)
downloadgentoo-2-f7da238a31b5edbc0dee2fcce573b89d0d5f8cd4.tar.gz
gentoo-2-f7da238a31b5edbc0dee2fcce573b89d0d5f8cd4.tar.bz2
gentoo-2-f7da238a31b5edbc0dee2fcce573b89d0d5f8cd4.zip
Include various fixes from Kevin Pyle, bug #339248.
(Portage version: 2.1.11.24/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/exact-image')
-rw-r--r--media-gfx/exact-image/ChangeLog8
-rw-r--r--media-gfx/exact-image/exact-image-0.8.1-r1.ebuild106
2 files changed, 112 insertions, 2 deletions
diff --git a/media-gfx/exact-image/ChangeLog b/media-gfx/exact-image/ChangeLog
index b84647397593..3074d4544bed 100644
--- a/media-gfx/exact-image/ChangeLog
+++ b/media-gfx/exact-image/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/exact-image
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exact-image/ChangeLog,v 1.8 2012/05/05 07:00:23 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exact-image/ChangeLog,v 1.9 2012/10/06 11:47:08 pacho Exp $
+
+*exact-image-0.8.1-r1 (06 Oct 2012)
+
+ 06 Oct 2012; Pacho Ramos <pacho@gentoo.org> +exact-image-0.8.1-r1.ebuild:
+ Include various fixes from Kevin Pyle, bug #339248.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> exact-image-0.8.1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -37,4 +42,3 @@
+metadata.xml:
Initial commit of exact-image application. Fixes bug #249032. Ebuild taken
from sunrise overlay
-
diff --git a/media-gfx/exact-image/exact-image-0.8.1-r1.ebuild b/media-gfx/exact-image/exact-image-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..7614e8af0411
--- /dev/null
+++ b/media-gfx/exact-image/exact-image-0.8.1-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exact-image/exact-image-0.8.1-r1.ebuild,v 1.1 2012/10/06 11:47:08 pacho Exp $
+
+EAPI=4
+PYTHON_DEPEND="python? 2:2.5"
+
+inherit eutils multilib python toolchain-funcs
+
+DESCRIPTION="A fast, modern and generic image processing library"
+HOMEPAGE="http://www.exactcode.de/site/open_source/exactimage/"
+SRC_URI="http://dl.exactcode.de/oss/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="expat jpeg jpeg2k lcms lua openexr php perl png python ruby swig tiff truetype X"
+
+RDEPEND="x11-libs/agg[truetype]
+ sys-libs/zlib
+ expat? ( dev-libs/expat )
+ jpeg2k? ( media-libs/jasper )
+ jpeg? ( virtual/jpeg )
+ lcms? ( =media-libs/lcms-1* )
+ lua? ( dev-lang/lua )
+ openexr? ( media-libs/openexr )
+ php? ( dev-lang/php )
+ perl? ( sys-devel/libperl )
+ png? ( >=media-libs/libpng-1.2.43 )
+ ruby? ( dev-lang/ruby )
+ tiff? ( media-libs/tiff )
+ truetype? ( >=media-libs/freetype-2 )
+ X? (
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ swig? ( dev-lang/swig )"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ fi
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.7.5-libpng14.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
+
+ # fix python hardcoded path wrt bug #327171
+ sed -i -e "s:python2.5:python$(python_get_version):" \
+ -e "s:\$(libdir):usr/$(get_libdir):" \
+ "${S}"/api/python/Makefile
+
+ # Respect user CFLAGS/CXXFLAGS.
+ sed -i \
+ -e '/C\(XX\)\?FLAGS =/s/-O2//' \
+ -e "\$aCFLAGS += ${CFLAGS}\nCXXFLAGS += ${CXXFLAGS}" \
+ Makefile || die
+
+ # Show commands. Use qualified CC/CXX.
+ sed -i \
+ -e '/^Q =/d' \
+ -e '/^\t@echo /d' \
+ -e "\$aCC:=$(tc-getCC)\nCXX:=$(tc-getCXX)" \
+ build/bottom.make || die
+
+ # The copied string fits exactly. Use memcpy to reflect that a null
+ # terminator is not needed.
+ sed -i \
+ -e 's/strcpy(\([^,]*\)\(,["a-zA-Z -]*\))/memcpy(\1\2, sizeof(\1))/' \
+ codecs/tga.cc || die
+}
+
+src_configure() {
+ # evas -> enlightenment overlay
+ # bardecode -> protected by custom license
+ # libungif -> not supported anymore
+
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ $(use_with X x11) \
+ $(use_with truetype freetype) \
+ --without-evas \
+ $(use_with jpeg libjpeg) \
+ $(use_with tiff libtiff) \
+ $(use_with png libpng) \
+ --without-libungif \
+ $(use_with jpeg2k jasper) \
+ $(use_with openexr) \
+ $(use_with expat) \
+ $(use_with lcms) \
+ --without-bardecode \
+ $(use_with lua) \
+ $(use_with swig) \
+ $(use_with perl) \
+ $(use_with python) \
+ $(use_with php) \
+ $(use_with ruby) || die
+}