summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-09 15:25:21 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-09 15:25:21 +0000
commitc20de1b6b6ac4b03f074aecdba75950203cd88ec (patch)
treee564ba2e7a70ad45feb759c9a7f70495e16cb13d /media-gfx/exiv2
parentRevbump in order to remove static lib and libtool archive. (diff)
downloadgentoo-2-c20de1b6b6ac4b03f074aecdba75950203cd88ec.tar.gz
gentoo-2-c20de1b6b6ac4b03f074aecdba75950203cd88ec.tar.bz2
gentoo-2-c20de1b6b6ac4b03f074aecdba75950203cd88ec.zip
Revision bump to punt libtool archive and static library. Punt older overshadowed versions.
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/exiv2')
-rw-r--r--media-gfx/exiv2/ChangeLog11
-rw-r--r--media-gfx/exiv2/exiv2-0.20.ebuild114
-rw-r--r--media-gfx/exiv2/exiv2-0.21-r1.ebuild115
-rw-r--r--media-gfx/exiv2/exiv2-0.21.1-r1.ebuild10
-rw-r--r--media-gfx/exiv2/exiv2-0.21.1-r2.ebuild (renamed from media-gfx/exiv2/exiv2-0.21.1.ebuild)13
-rw-r--r--media-gfx/exiv2/exiv2-0.21.ebuild113
-rw-r--r--media-gfx/exiv2/files/exiv2-0.21-xmp-fix.patch15
7 files changed, 27 insertions, 364 deletions
diff --git a/media-gfx/exiv2/ChangeLog b/media-gfx/exiv2/ChangeLog
index aec611bdbfc8..8427ce7623d7 100644
--- a/media-gfx/exiv2/ChangeLog
+++ b/media-gfx/exiv2/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-gfx/exiv2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/ChangeLog,v 1.95 2011/08/15 18:32:13 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/ChangeLog,v 1.96 2011/09/09 15:25:20 scarabeus Exp $
+
+*exiv2-0.21.1-r2 (09 Sep 2011)
+
+ 09 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org> -exiv2-0.20.ebuild,
+ -exiv2-0.21.ebuild, -exiv2-0.21-r1.ebuild, -exiv2-0.21.1.ebuild,
+ exiv2-0.21.1-r1.ebuild, +exiv2-0.21.1-r2.ebuild,
+ -files/exiv2-0.21-xmp-fix.patch:
+ Revision bump to punt libtool archive and static library. Punt older
+ overshadowed versions.
15 Aug 2011; Markus Meier <maekke@gentoo.org> exiv2-0.21.1-r1.ebuild:
x86 stable, bug #377465
diff --git a/media-gfx/exiv2/exiv2-0.20.ebuild b/media-gfx/exiv2/exiv2-0.20.ebuild
deleted file mode 100644
index e89a087b017e..000000000000
--- a/media-gfx/exiv2/exiv2-0.20.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.20.ebuild,v 1.1 2010/07/20 20:43:32 sbriesen Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-
-inherit eutils multilib toolchain-funcs python
-
-DESCRIPTION="EXIF and IPTC metadata C++ library and command line utility"
-HOMEPAGE="http://www.exiv2.org/"
-SRC_URI="http://www.exiv2.org/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="contrib doc examples nls unicode xmp zlib"
-IUSE_LINGUAS="de es fi fr pl ru sk"
-IUSE="${IUSE} $(printf 'linguas_%s ' ${IUSE_LINGUAS})"
-
-RDEPEND="
- virtual/libiconv
- nls? ( virtual/libintl )
- xmp? ( dev-libs/expat )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}
- contrib? ( >=dev-libs/boost-1.37 )
- doc? (
- app-doc/doxygen
- dev-libs/libxslt
- dev-util/pkgconfig
- media-gfx/graphviz
- )
- nls? ( sys-devel/gettext )
-"
-
-src_prepare() {
- if use unicode; then
- for i in doc/cmd.txt; do
- einfo "Converting "${i}" to UTF-8"
- iconv -f LATIN1 -t UTF-8 "${i}" > "${i}~" && mv -f "${i}~" "${i}" || rm -f "${i}~"
- done
- fi
-
- if use doc; then
- einfo "Updating doxygen config"
- doxygen 2>&1 >/dev/null -u config/Doxyfile
- fi
-
- if use contrib; then
- # create build environment for contrib
- ln -snf ../../src contrib/organize/exiv2
- sed -i -e 's:/usr/local/include/.*:/usr/include:g' \
- -e 's:/usr/local/lib/lib:-l:g' -e 's:-gcc..-mt-._..\.a::g' \
- contrib/organize/boost.mk
- fi
-
- # fix python shebang
- python_convert_shebangs -r 2 doc/templates
-}
-
-src_configure() {
- local myconf="$(use_enable nls) $(use_enable xmp)"
- use zlib || myconf="${myconf} --without-zlib" # plain 'use_with' fails
-
- # Bug #78720. amd64/gcc-3.4/-fvisibility* fail.
- if [[ $(gcc-major-version) -lt 4 ]]; then
- use amd64 && myconf="${myconf} --disable-visibility"
- fi
-
- econf ${myconf}
-}
-
-src_compile() {
- emake || die "emake failed"
-
- if use contrib; then
- emake -C contrib/organize \
- LDFLAGS="\$(BOOST_LIBS) -L../../src -lexiv2 ${LDFLAGS}" \
- CPPFLAGS="${CPPFLAGS} -I\$(BOOST_INC_DIR) -I. -DEXV_HAVE_STDINT_H" \
- || die "emake organize failed"
- fi
-
- if use doc; then
- emake doc || die "emake doc failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use contrib; then
- emake DESTDIR="${D}" -C contrib/organize install || die "emake install organize failed"
- fi
-
- dodoc README doc/{ChangeLog,cmd.txt}
- use xmp && dodoc doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt}
- use doc && dohtml -r doc/html/.
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins samples/*.cpp
- fi
-}
-
-pkg_postinst() {
- ewarn
- ewarn "PLEASE PLEASE take note of this:"
- ewarn "Please make *sure* to run revdep-rebuild now"
- ewarn "Certain things on your system may have linked against a"
- ewarn "different version of exiv2 -- those things need to be"
- ewarn "recompiled. Sorry for the inconvenience!"
- ewarn
-}
diff --git a/media-gfx/exiv2/exiv2-0.21-r1.ebuild b/media-gfx/exiv2/exiv2-0.21-r1.ebuild
deleted file mode 100644
index d50fb0e12e44..000000000000
--- a/media-gfx/exiv2/exiv2-0.21-r1.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.21-r1.ebuild,v 1.1 2010/12/21 12:31:54 sbriesen Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-
-inherit eutils multilib toolchain-funcs python
-
-DESCRIPTION="EXIF and IPTC metadata C++ library and command line utility"
-HOMEPAGE="http://www.exiv2.org/"
-SRC_URI="http://www.exiv2.org/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="contrib doc examples nls xmp zlib"
-IUSE_LINGUAS="de es fi fr pl ru sk"
-IUSE="${IUSE} $(printf 'linguas_%s ' ${IUSE_LINGUAS})"
-
-RDEPEND="
- virtual/libiconv
- nls? ( virtual/libintl )
- xmp? ( dev-libs/expat )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}
- contrib? ( >=dev-libs/boost-1.37 )
- doc? (
- app-doc/doxygen
- dev-libs/libxslt
- dev-util/pkgconfig
- media-gfx/graphviz
- )
- nls? ( sys-devel/gettext )
-"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-xmp-fix.patch"
-
- # convert docs to UTF-8
- for i in doc/cmd.txt; do
- einfo "Converting "${i}" to UTF-8"
- iconv -f LATIN1 -t UTF-8 "${i}" > "${i}~" && mv -f "${i}~" "${i}" || rm -f "${i}~"
- done
-
- if use doc; then
- einfo "Updating doxygen config"
- doxygen 2>&1 >/dev/null -u config/Doxyfile
- fi
-
- if use contrib; then
- # create build environment for contrib
- ln -snf ../../src contrib/organize/exiv2
- sed -i -e 's:/usr/local/include/.*:/usr/include:g' \
- -e 's:/usr/local/lib/lib:-l:g' -e 's:-gcc..-mt-._..\.a::g' \
- contrib/organize/boost.mk
- fi
-
- # fix python shebang
- python_convert_shebangs -r 2 doc/templates
-}
-
-src_configure() {
- local myconf="$(use_enable nls) $(use_enable xmp)"
- use zlib || myconf="${myconf} --without-zlib" # plain 'use_with' fails
-
- # Bug #78720. amd64/gcc-3.4/-fvisibility* fail.
- if [[ $(gcc-major-version) -lt 4 ]]; then
- use amd64 && myconf="${myconf} --disable-visibility"
- fi
-
- econf ${myconf}
-}
-
-src_compile() {
- emake || die "emake failed"
-
- if use contrib; then
- emake -C contrib/organize \
- LDFLAGS="\$(BOOST_LIBS) -L../../src -lexiv2 ${LDFLAGS}" \
- CPPFLAGS="${CPPFLAGS} -I\$(BOOST_INC_DIR) -I. -DEXV_HAVE_STDINT_H" \
- || die "emake organize failed"
- fi
-
- if use doc; then
- emake doc || die "emake doc failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use contrib; then
- emake DESTDIR="${D}" -C contrib/organize install || die "emake install organize failed"
- fi
-
- dodoc README doc/{ChangeLog,cmd.txt}
- use xmp && dodoc doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt}
- use doc && dohtml -r doc/html/.
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins samples/*.cpp
- fi
-}
-
-pkg_postinst() {
- ewarn
- ewarn "PLEASE PLEASE take note of this:"
- ewarn "Please make *sure* to run revdep-rebuild now"
- ewarn "Certain things on your system may have linked against a"
- ewarn "different version of exiv2 -- those things need to be"
- ewarn "recompiled. Sorry for the inconvenience!"
- ewarn
-}
diff --git a/media-gfx/exiv2/exiv2-0.21.1-r1.ebuild b/media-gfx/exiv2/exiv2-0.21.1-r1.ebuild
index f6a89f7416a3..c2ea9d8a4e4a 100644
--- a/media-gfx/exiv2/exiv2-0.21.1-r1.ebuild
+++ b/media-gfx/exiv2/exiv2-0.21.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.21.1-r1.ebuild,v 1.3 2011/08/15 18:32:13 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.21.1-r1.ebuild,v 1.4 2011/09/09 15:25:21 scarabeus Exp $
-EAPI="2"
+EAPI=3
PYTHON_DEPEND="2"
inherit eutils multilib toolchain-funcs python
@@ -81,7 +81,9 @@ src_configure() {
use amd64 && myconf="${myconf} --disable-visibility"
fi
- econf ${myconf}
+ econf \
+ --disable-static \
+ ${myconf}
}
src_compile() {
@@ -102,6 +104,8 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
if use contrib; then
emake DESTDIR="${D}" -C contrib/organize install || die "emake install organize failed"
fi
diff --git a/media-gfx/exiv2/exiv2-0.21.1.ebuild b/media-gfx/exiv2/exiv2-0.21.1-r2.ebuild
index ebba2543b62a..fe8a0c72f766 100644
--- a/media-gfx/exiv2/exiv2-0.21.1.ebuild
+++ b/media-gfx/exiv2/exiv2-0.21.1-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.21.1.ebuild,v 1.1 2011/04/02 23:46:37 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.21.1-r2.ebuild,v 1.1 2011/09/09 15:25:21 scarabeus Exp $
-EAPI="2"
+EAPI=3
PYTHON_DEPEND="2"
inherit eutils multilib toolchain-funcs python
@@ -46,6 +46,9 @@ src_prepare() {
's|^\(#include <boost/filesystem.hpp>.*\)|#define BOOST_FILESYSTEM_VERSION 2\n\1|g' \
contrib/organize/helpers.hpp
+ # fix for off by 1 hour date error for -T option (bug #368419)
+ epatch "${FILESDIR}/${P}-time-fix.patch"
+
# convert docs to UTF-8
for i in doc/cmd.txt; do
einfo "Converting "${i}" to UTF-8"
@@ -78,7 +81,9 @@ src_configure() {
use amd64 && myconf="${myconf} --disable-visibility"
fi
- econf ${myconf}
+ econf \
+ --disable-static \
+ ${myconf}
}
src_compile() {
@@ -99,6 +104,8 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
if use contrib; then
emake DESTDIR="${D}" -C contrib/organize install || die "emake install organize failed"
fi
diff --git a/media-gfx/exiv2/exiv2-0.21.ebuild b/media-gfx/exiv2/exiv2-0.21.ebuild
deleted file mode 100644
index 74a6cf935184..000000000000
--- a/media-gfx/exiv2/exiv2-0.21.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.21.ebuild,v 1.1 2010/12/19 13:01:45 sbriesen Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-
-inherit eutils multilib toolchain-funcs python
-
-DESCRIPTION="EXIF and IPTC metadata C++ library and command line utility"
-HOMEPAGE="http://www.exiv2.org/"
-SRC_URI="http://www.exiv2.org/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="contrib doc examples nls xmp zlib"
-IUSE_LINGUAS="de es fi fr pl ru sk"
-IUSE="${IUSE} $(printf 'linguas_%s ' ${IUSE_LINGUAS})"
-
-RDEPEND="
- virtual/libiconv
- nls? ( virtual/libintl )
- xmp? ( dev-libs/expat )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}
- contrib? ( >=dev-libs/boost-1.37 )
- doc? (
- app-doc/doxygen
- dev-libs/libxslt
- dev-util/pkgconfig
- media-gfx/graphviz
- )
- nls? ( sys-devel/gettext )
-"
-
-src_prepare() {
- # convert docs to UTF-8
- for i in doc/cmd.txt; do
- einfo "Converting "${i}" to UTF-8"
- iconv -f LATIN1 -t UTF-8 "${i}" > "${i}~" && mv -f "${i}~" "${i}" || rm -f "${i}~"
- done
-
- if use doc; then
- einfo "Updating doxygen config"
- doxygen 2>&1 >/dev/null -u config/Doxyfile
- fi
-
- if use contrib; then
- # create build environment for contrib
- ln -snf ../../src contrib/organize/exiv2
- sed -i -e 's:/usr/local/include/.*:/usr/include:g' \
- -e 's:/usr/local/lib/lib:-l:g' -e 's:-gcc..-mt-._..\.a::g' \
- contrib/organize/boost.mk
- fi
-
- # fix python shebang
- python_convert_shebangs -r 2 doc/templates
-}
-
-src_configure() {
- local myconf="$(use_enable nls) $(use_enable xmp)"
- use zlib || myconf="${myconf} --without-zlib" # plain 'use_with' fails
-
- # Bug #78720. amd64/gcc-3.4/-fvisibility* fail.
- if [[ $(gcc-major-version) -lt 4 ]]; then
- use amd64 && myconf="${myconf} --disable-visibility"
- fi
-
- econf ${myconf}
-}
-
-src_compile() {
- emake || die "emake failed"
-
- if use contrib; then
- emake -C contrib/organize \
- LDFLAGS="\$(BOOST_LIBS) -L../../src -lexiv2 ${LDFLAGS}" \
- CPPFLAGS="${CPPFLAGS} -I\$(BOOST_INC_DIR) -I. -DEXV_HAVE_STDINT_H" \
- || die "emake organize failed"
- fi
-
- if use doc; then
- emake doc || die "emake doc failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use contrib; then
- emake DESTDIR="${D}" -C contrib/organize install || die "emake install organize failed"
- fi
-
- dodoc README doc/{ChangeLog,cmd.txt}
- use xmp && dodoc doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt}
- use doc && dohtml -r doc/html/.
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins samples/*.cpp
- fi
-}
-
-pkg_postinst() {
- ewarn
- ewarn "PLEASE PLEASE take note of this:"
- ewarn "Please make *sure* to run revdep-rebuild now"
- ewarn "Certain things on your system may have linked against a"
- ewarn "different version of exiv2 -- those things need to be"
- ewarn "recompiled. Sorry for the inconvenience!"
- ewarn
-}
diff --git a/media-gfx/exiv2/files/exiv2-0.21-xmp-fix.patch b/media-gfx/exiv2/files/exiv2-0.21-xmp-fix.patch
deleted file mode 100644
index 5f67cc95e456..000000000000
--- a/media-gfx/exiv2/files/exiv2-0.21-xmp-fix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- exiv2-0.21.orig/src/xmp.cpp 2010-11-06 13:53:15.000000000 +0000
-+++ exiv2-0.21/src/xmp.cpp 2010-12-20 12:35:34.931520681 +0000
-@@ -420,11 +420,10 @@ namespace Exiv2 {
- }
- } // XmpParser::registerNs
- #else
-- bool XmpParser::registerNs(const std::string& /*ns*/,
-+ void XmpParser::registerNs(const std::string& /*ns*/,
- const std::string& /*prefix*/)
- {
- initialize();
-- return true;
- } // XmpParser::registerNs
- #endif
-