summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2008-11-23 20:25:34 +0000
committerMark Loeser <halcy0n@gentoo.org>2008-11-23 20:25:34 +0000
commit7c0c3acc1ff14040f04c9d511444389a9d32bfda (patch)
tree14f064c6765113102c7f6460f0f920c663398f83 /media-gfx/flphoto
parentDefault enable USE=gtk as all current users of libcanberra need it (diff)
downloadgentoo-2-7c0c3acc1ff14040f04c9d511444389a9d32bfda.tar.gz
gentoo-2-7c0c3acc1ff14040f04c9d511444389a9d32bfda.tar.bz2
gentoo-2-7c0c3acc1ff14040f04c9d511444389a9d32bfda.zip
Fix compilation with glibc-2.8, thanks to Diego E. 'Flameeyes' Pettenò <flameeyes AT gentoo DOT org> for reporting; bug #247722
(Portage version: 2.2_rc15/cvs/Linux 2.6.27.1 x86_64)
Diffstat (limited to 'media-gfx/flphoto')
-rw-r--r--media-gfx/flphoto/ChangeLog8
-rw-r--r--media-gfx/flphoto/files/flphoto-1.3.1-glibc28.patch11
-rw-r--r--media-gfx/flphoto/flphoto-1.2.ebuild10
-rw-r--r--media-gfx/flphoto/flphoto-1.3.1.ebuild10
4 files changed, 36 insertions, 3 deletions
diff --git a/media-gfx/flphoto/ChangeLog b/media-gfx/flphoto/ChangeLog
index 4dd37e69dd7b..d73451f18d66 100644
--- a/media-gfx/flphoto/ChangeLog
+++ b/media-gfx/flphoto/ChangeLog
@@ -1,11 +1,17 @@
# ChangeLog for media-gfx/flphoto
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/ChangeLog,v 1.12 2008/11/14 18:54:20 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/ChangeLog,v 1.13 2008/11/23 20:25:34 halcy0n Exp $
26 Jul 2003; Jared Hudson <jhhudso@gentoo.org> : Fixed flphoto so that it only
depends on a specific version of fltk, since the other versions cause
compile errors.
+ 23 Nov 2008; Mark Loeser <halcy0n@gentoo.org>
+ +files/flphoto-1.3.1-glibc28.patch, flphoto-1.2.ebuild,
+ flphoto-1.3.1.ebuild:
+ Fix compilation with glibc-2.8, thanks to Diego E. 'Flameeyes' Pettenò
+ <flameeyes AT gentoo DOT org> for reporting; bug #247722
+
14 Nov 2008; Santiago M. Mola <coldwind@gentoo.org> flphoto-1.2.ebuild,
flphoto-1.3.1.ebuild:
Restrict fltk dependency to SLOT 1.1 (bug #246445).
diff --git a/media-gfx/flphoto/files/flphoto-1.3.1-glibc28.patch b/media-gfx/flphoto/files/flphoto-1.3.1-glibc28.patch
new file mode 100644
index 000000000000..e22c2dddb8ee
--- /dev/null
+++ b/media-gfx/flphoto/files/flphoto-1.3.1-glibc28.patch
@@ -0,0 +1,11 @@
+diff -ur flphoto-1.3.1-orig/camera.cxx flphoto-1.3.1/camera.cxx
+--- flphoto-1.3.1-orig/camera.cxx 2008-11-23 15:15:54.000000000 -0500
++++ flphoto-1.3.1/camera.cxx 2008-11-23 15:18:34.000000000 -0500
+@@ -42,6 +42,7 @@
+ # define fl_mkdir(p) mkdir(p)
+ #else
+ # include <unistd.h>
++# include <sys/stat.h>
+ # define fl_mkdir(p) mkdir(p, 0777)
+ #endif // WIN32 && !__CYGWIN__
+ #include <errno.h>
diff --git a/media-gfx/flphoto/flphoto-1.2.ebuild b/media-gfx/flphoto/flphoto-1.2.ebuild
index fd3a8549da74..5827fda07cec 100644
--- a/media-gfx/flphoto/flphoto-1.2.ebuild
+++ b/media-gfx/flphoto/flphoto-1.2.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.2.ebuild,v 1.7 2008/11/14 18:54:20 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.2.ebuild,v 1.8 2008/11/23 20:25:34 halcy0n Exp $
EAPI=1
+inherit eutils
+
DESCRIPTION="Basic image management and display program based on the FLTK toolkit"
HOMEPAGE="http://www.easysw.com/~mike/flphoto/"
SRC_URI="mirror://sourceforge/fltk/${P}-source.tar.gz"
@@ -17,6 +19,12 @@ DEPEND=">=x11-libs/fltk-1.1.4:1.1
cups? ( net-print/cups )
gphoto2? ( media-gfx/gphoto2 )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/flphoto-1.3.1-glibc28.patch
+}
+
src_compile() {
econf || die
emake -j1 || die
diff --git a/media-gfx/flphoto/flphoto-1.3.1.ebuild b/media-gfx/flphoto/flphoto-1.3.1.ebuild
index bf9c84bb4590..99786625cc33 100644
--- a/media-gfx/flphoto/flphoto-1.3.1.ebuild
+++ b/media-gfx/flphoto/flphoto-1.3.1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.3.1.ebuild,v 1.2 2008/11/14 18:54:20 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.3.1.ebuild,v 1.3 2008/11/23 20:25:34 halcy0n Exp $
EAPI=1
+inherit eutils
+
DESCRIPTION="Basic image management and display program based on the FLTK toolkit"
HOMEPAGE="http://www.easysw.com/~mike/flphoto/"
SRC_URI="mirror://sourceforge/fltk/${P}-source.tar.gz"
@@ -17,6 +19,12 @@ DEPEND=">=x11-libs/fltk-1.1.4:1.1
cups? ( net-print/cups )
gphoto2? ( media-gfx/gphoto2 )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/flphoto-1.3.1-glibc28.patch
+}
+
src_compile() {
econf --with-docdir=/usr/share/doc/${P} || die
emake -j1 || die