summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-02-10 01:19:05 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-02-10 01:19:05 +0000
commit315c6cbe988e1bebf8a1bc4d080bf975bcae3297 (patch)
tree7ce3cdd1f939e880c2a052bb2328ea2cb1ae38c2 /media-gfx/gimp
parentUnstable ppc-macos (diff)
downloadgentoo-2-315c6cbe988e1bebf8a1bc4d080bf975bcae3297.tar.gz
gentoo-2-315c6cbe988e1bebf8a1bc4d080bf975bcae3297.tar.bz2
gentoo-2-315c6cbe988e1bebf8a1bc4d080bf975bcae3297.zip
Hard enabling SIMD assembler for AMD64, closes bug 80638.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'media-gfx/gimp')
-rw-r--r--media-gfx/gimp/ChangeLog5
-rw-r--r--media-gfx/gimp/gimp-2.2.3.ebuild14
2 files changed, 15 insertions, 4 deletions
diff --git a/media-gfx/gimp/ChangeLog b/media-gfx/gimp/ChangeLog
index be3f7e397741..33e116374d04 100644
--- a/media-gfx/gimp/ChangeLog
+++ b/media-gfx/gimp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/gimp
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.103 2005/02/03 04:18:25 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.104 2005/02/10 01:19:05 cryos Exp $
+
+ 10 Feb 2005; Marcus D. Hanwell <cryos@gentoo.org> gimp-2.2.3.ebuild:
+ Hard enabling SIMD assembler for AMD64, closes bug 80638.
*gimp-2.2.3 (02 Feb 2005)
diff --git a/media-gfx/gimp/gimp-2.2.3.ebuild b/media-gfx/gimp/gimp-2.2.3.ebuild
index 3c59e814452b..680cca30782b 100644
--- a/media-gfx/gimp/gimp-2.2.3.ebuild
+++ b/media-gfx/gimp/gimp-2.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-2.2.3.ebuild,v 1.1 2005/02/03 04:18:25 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-2.2.3.ebuild,v 1.2 2005/02/10 01:19:05 cryos Exp $
inherit flag-o-matic libtool eutils
@@ -86,19 +86,27 @@ src_compile() {
if use hardened; then
ewarn "hardened use flag suppressing mmx use flag"
HARDENED_SUPPRESS_MMX="--disable-mmx"
- else
+ elif use x86; then
HARDENED_SUPPRESS_MMX="`use_enable mmx`"
+ elif use amd64; then
+ HARDENED_SUPPRESS_MMX="--enable-mmx"
fi
local myconf
use doc || myconf="${myconf} --disable-devel-docs"
+ # Hard enable SIMD assembler code for AMD64.
+ if use x86; then
+ myconf="${myconf} `use_enable sse`"
+ elif use amd64; then
+ myconf="${myconf} --enable-sse"
+ fi
+
econf \
--disable-default-binary \
--with-x \
"${HARDENED_SUPPRESS_MMX}" \
${myconf} \
- `use_enable sse` \
`use_enable altivec` \
`use_enable doc gtk-doc` \
`use_enable python` \