summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2001-10-23 15:34:18 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2001-10-23 15:34:18 +0000
commit56e7bbf21c183e85e6a70935bbc60f432597febc (patch)
treef3adfe289622ec72654a42448cbffc832b5cd9ea /media-gfx/gnuplot
parentcorrected digest, removed A=, fixed S= (diff)
downloadgentoo-2-56e7bbf21c183e85e6a70935bbc60f432597febc.tar.gz
gentoo-2-56e7bbf21c183e85e6a70935bbc60f432597febc.tar.bz2
gentoo-2-56e7bbf21c183e85e6a70935bbc60f432597febc.zip
New ebuild -- gnuplot
Diffstat (limited to 'media-gfx/gnuplot')
-rw-r--r--media-gfx/gnuplot/files/digest-gnuplot-3.7.11
-rw-r--r--media-gfx/gnuplot/gnuplot-3.7.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-gfx/gnuplot/files/digest-gnuplot-3.7.1 b/media-gfx/gnuplot/files/digest-gnuplot-3.7.1
new file mode 100644
index 000000000000..82a8318c3c03
--- /dev/null
+++ b/media-gfx/gnuplot/files/digest-gnuplot-3.7.1
@@ -0,0 +1 @@
+MD5 30798b4c14ea734969a86ee41a9c1dca gnuplot-3.7.1.tar.gz
diff --git a/media-gfx/gnuplot/gnuplot-3.7.1.ebuild b/media-gfx/gnuplot/gnuplot-3.7.1.ebuild
new file mode 100644
index 000000000000..926e23a040a0
--- /dev/null
+++ b/media-gfx/gnuplot/gnuplot-3.7.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Grant Goodyear <g2boojum@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/gnuplot-3.7.1.ebuild,v 1.1 2001/10/23 15:34:18 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Quick and useful plotting program"
+SRC_URI="ftp://ftp.gnuplot.org/pub/gnuplot/${P}.tar.gz"
+HOMEPAGE="http://www.gnuplot.org"
+
+DEPEND="media-libs/libpng"
+
+src_compile() {
+ local myvar
+ #myvar=" --with-png --without-gd --with-lasergnu"
+ myvar=" --with-png --without-gd"
+ if [ -z "`use X`" ]
+ then
+ myvar="${myvar} --without-x"
+ else
+ myvar="${myvar} --with-x"
+ fi
+ if [ -z "`use readline`" ]
+ then
+ #use the built-in readline
+ myvar="${myvar} --with-readline"
+ else
+ #use gnu readline
+ myvar="${myvar} --with-readline=gnu"
+ fi
+ ./configure \
+ ${myvar} \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share/gnuplot \
+ --mandir=/usr/share/man || die
+ mv Makefile Makefile.orig
+ sed -e 's/datadir = \/usr/datadir = ${prefix}/' \
+ -e 's/mandir = \/usr/mandir = ${prefix}/' \
+ Makefile.orig > Makefile
+ cd docs
+ mv Makefile Makefile.orig
+ sed -e 's/datadir = \/usr/datadir = ${prefix}/' Makefile.orig > Makefile
+ cd ..
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+}