summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-09 04:01:51 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-09 04:01:51 +0000
commit84e29eaa970aaaf89ca6ab863512bebbd7741d2f (patch)
tree577b0cc1094942798f5ced0dbeda0243cab1488e /media-gfx/gnuplot
parentInitial Import (Manifest recommit) (diff)
downloadgentoo-2-84e29eaa970aaaf89ca6ab863512bebbd7741d2f.tar.gz
gentoo-2-84e29eaa970aaaf89ca6ab863512bebbd7741d2f.tar.bz2
gentoo-2-84e29eaa970aaaf89ca6ab863512bebbd7741d2f.zip
added a patch to fix a segfault on amd64 - see bug #46981 for more info
Diffstat (limited to 'media-gfx/gnuplot')
-rw-r--r--media-gfx/gnuplot/ChangeLog8
-rw-r--r--media-gfx/gnuplot/Manifest3
-rw-r--r--media-gfx/gnuplot/files/digest-gnuplot-3.8j-r11
-rw-r--r--media-gfx/gnuplot/files/gnuplot-3.8j-amd64.diff10
-rw-r--r--media-gfx/gnuplot/gnuplot-3.8j-r1.ebuild78
5 files changed, 99 insertions, 1 deletions
diff --git a/media-gfx/gnuplot/ChangeLog b/media-gfx/gnuplot/ChangeLog
index f527ba2a3a9f..a5644a5d8028 100644
--- a/media-gfx/gnuplot/ChangeLog
+++ b/media-gfx/gnuplot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/gnuplot
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/ChangeLog,v 1.17 2004/04/06 17:55:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/ChangeLog,v 1.18 2004/04/09 04:01:51 lv Exp $
+
+*gnuplot-3.8j-r1 (08 Apr 2004)
+
+ 08 Apr 2004; Travis Tilley <lv@gentoo.org> gnuplot-3.8j-r1.ebuild,
+ files/gnuplot-3.8j-amd64.diff:
+ added a patch to fix a segfault on amd64 - see bug #46981 for more info
06 Apr 2004; Aron Griffis <agriffis@gentoo.org> gnuplot-3.8j.ebuild:
Stable on ia64
diff --git a/media-gfx/gnuplot/Manifest b/media-gfx/gnuplot/Manifest
index a8c405fcb5af..ff14bc7c8a15 100644
--- a/media-gfx/gnuplot/Manifest
+++ b/media-gfx/gnuplot/Manifest
@@ -1,4 +1,7 @@
MD5 58b5bdb409e4a707a7d8be5d01b08b82 ChangeLog 2831
MD5 d36d3a29a6a4328e002cd4bd62b1e74b gnuplot-3.8j.ebuild 2028
MD5 0d0ccbc08efef8b97818204479649574 metadata.xml 220
+MD5 2ec604af84a4afc63361d93c7d4fdb52 gnuplot-3.8j-r1.ebuild 2131
MD5 4ca2057b57f07811b4da7bd8958d50c2 files/digest-gnuplot-3.8j 67
+MD5 d6d201e466142a8e19ab7a86da486dde files/gnuplot-3.8j-amd64.diff 329
+MD5 4ca2057b57f07811b4da7bd8958d50c2 files/digest-gnuplot-3.8j-r1 67
diff --git a/media-gfx/gnuplot/files/digest-gnuplot-3.8j-r1 b/media-gfx/gnuplot/files/digest-gnuplot-3.8j-r1
new file mode 100644
index 000000000000..a7642c4ce441
--- /dev/null
+++ b/media-gfx/gnuplot/files/digest-gnuplot-3.8j-r1
@@ -0,0 +1 @@
+MD5 929e210e2d6585d34b029fa59d39915f gnuplot-3.8j.0.tar.gz 2072307
diff --git a/media-gfx/gnuplot/files/gnuplot-3.8j-amd64.diff b/media-gfx/gnuplot/files/gnuplot-3.8j-amd64.diff
new file mode 100644
index 000000000000..04d38dc9338c
--- /dev/null
+++ b/media-gfx/gnuplot/files/gnuplot-3.8j-amd64.diff
@@ -0,0 +1,10 @@
+--- src/fit.c.orig 2004-04-09 03:12:49.249588328 +0200
++++ src/fit.c 2004-04-09 03:11:56.805561032 +0200
+@@ -1685,6 +1685,7 @@
+ VA_START(args, fmt);
+ # if defined(HAVE_VFPRINTF) || _LIBC
+ vfprintf(STANDARD, fmt, args);
++ VA_START(args, fmt);
+ vfprintf(log_f, fmt, args);
+ # else
+ _doprnt(fmt, args, STANDARD);
diff --git a/media-gfx/gnuplot/gnuplot-3.8j-r1.ebuild b/media-gfx/gnuplot/gnuplot-3.8j-r1.ebuild
new file mode 100644
index 000000000000..305160cbcf77
--- /dev/null
+++ b/media-gfx/gnuplot/gnuplot-3.8j-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/gnuplot-3.8j-r1.ebuild,v 1.1 2004/04/09 04:01:51 lv Exp $
+
+MY_P="${P}.0"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Quick and useful plotting program"
+HOMEPAGE="http://www.gnuplot.info/"
+SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
+
+LICENSE="gnuplot"
+SLOT="0"
+KEYWORDS="-x86 -ppc -sparc -alpha amd64 -ia64"
+IUSE="X readline svga plotutils pdflib doc"
+
+# Old png driver seems to have problems; switching to gd instead
+DEPEND=">=media-libs/libgd-2
+ pdflib? ( media-libs/pdflib )
+ doc? ( virtual/tetex )
+ X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )
+ readline? ( sys-libs/readline )
+ plotutils? ( media-libs/plotutils )"
+
+src_unpack() {
+ unpack ${A}
+ use amd64 && (cd ${S} ; epatch ${FILESDIR}/gnuplot-3.8j-amd64.diff)
+}
+
+src_compile() {
+ local myconf
+ #--with-lasergnu flag seems to be broken and I'm too lazy to fix now
+ #myconf=" --with-png --without-gd --with-lasergnu"
+ myconf=" --with-gd --with-plot=/usr/lib"
+ #--with-plot enables the Gnu plotutils library
+ #need to specify path to differentiate from Unix plot
+
+ use plotutils \
+ && myconf="${myconf} --with-plot=/usr/lib" \
+ || myconf="${myconf} --without-plot"
+
+ myconf="${myconf} `use_with pdflib pdf`"
+ myconf="${myconf} `use_with X x`"
+
+ use readline \
+ && myconf="${myconf} --with-readline=gnu" \
+ || myconf="${myconf} --with-readline"
+
+ myconf="${myconf} `use_with svga vga`"
+
+ econf \
+ --datadir=/usr/share/gnuplot \
+ ${myconf} || die
+
+ cd ${S}
+ emake || die
+
+ if [ -n "`use doc`" ] ; then
+ cd docs
+ make pdf || die
+ fi
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc 0* ChangeLog CodeStyle Copyright NEWS PGPKEYS TODO
+ use doc && dodoc docs/gnuplot.pdf
+}
+
+pkg_postinst() {
+ if [ "`use svga`" ] ; then
+ einfo "In order to enable ordinary users to use SVGA console graphics"
+ einfo "gnuplot needs to be set up as setuid root. Please note that"
+ einfo "this is usually considered to be a security hazard."
+ einfo "As root, manually chmod u+s /usr/bin/gnuplot"
+ fi
+}