summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-10-23 18:42:43 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-10-23 18:42:43 +0000
commit591ffe37a9297316067c291ab0826e787f7ccde4 (patch)
treea45a632d4a937b3890f5f1a1e6c3e53383002ff2 /media-gfx/gphoto2
parentadd control-center-1.4 as dep to eazel (diff)
downloadgentoo-2-591ffe37a9297316067c291ab0826e787f7ccde4.tar.gz
gentoo-2-591ffe37a9297316067c291ab0826e787f7ccde4.tar.bz2
gentoo-2-591ffe37a9297316067c291ab0826e787f7ccde4.zip
Added the new version
Diffstat (limited to 'media-gfx/gphoto2')
-rw-r--r--media-gfx/gphoto2/ChangeLog15
-rw-r--r--media-gfx/gphoto2/files/digest-gphoto2-2.1.01
-rw-r--r--media-gfx/gphoto2/gphoto2-2.1.0.ebuild49
3 files changed, 62 insertions, 3 deletions
diff --git a/media-gfx/gphoto2/ChangeLog b/media-gfx/gphoto2/ChangeLog
index 92d0db6dad6f..cd909174dce8 100644
--- a/media-gfx/gphoto2/ChangeLog
+++ b/media-gfx/gphoto2/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for media-gfx/gphoto
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto2/ChangeLog,v 1.3 2002/10/19 20:25:56 cselkirk Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto2/ChangeLog,v 1.4 2002/10/23 18:42:43 spider Exp $
+
+
+*gphoto2-2.1.0 (23 Oct 2002)
+
+ 23 Oct 2002 ; Spider <spider@gentoo.org> gphoto2-2.1.0.ebuild :
+ new ebuild introduced to bugzilla by
+ Robert Davis <rdavis@uniformcompany.com>
+
+
+
+*gphoto2-2.0-r1 (01 April 2002)
19 Oct 2002; Calum Selkirk <cselkirk@gentoo.org> gphoto2-2.0-r1.ebuild :
@@ -10,8 +21,6 @@
Update all glib dependencies to use glib-1.2* in preparation of
unmasking the glib-2.0.1 packages
-
-*gphoto2-2.0-r1 (01 April 2002)
01 April 2002; Spider <spider@gentoo.org>
move to gphoto2
diff --git a/media-gfx/gphoto2/files/digest-gphoto2-2.1.0 b/media-gfx/gphoto2/files/digest-gphoto2-2.1.0
new file mode 100644
index 000000000000..3e4d28ec8c38
--- /dev/null
+++ b/media-gfx/gphoto2/files/digest-gphoto2-2.1.0
@@ -0,0 +1 @@
+MD5 7ea810311ddb2a8f5dfac0e2a720f155 gphoto2-2.1.0.tar.gz 2137982
diff --git a/media-gfx/gphoto2/gphoto2-2.1.0.ebuild b/media-gfx/gphoto2/gphoto2-2.1.0.ebuild
new file mode 100644
index 000000000000..269174888cd5
--- /dev/null
+++ b/media-gfx/gphoto2/gphoto2-2.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto2/gphoto2-2.1.0.ebuild,v 1.1 2002/10/23 18:42:43 spider Exp $
+
+inherit libtool
+
+MY_P=${PN}-${PV/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="free, redistributable digital camera software application"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/gphoto/${MY_P}.tar.gz"
+HOMEPAGE="http://www.gphoto.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=dev-libs/libusb-0.1.6
+ =dev-libs/glib-1.2*
+ >=sys-libs/zlib-1.1.4"
+
+src_compile() {
+
+ elibtoolize
+ aclocal
+
+ # -pipe does no work
+ env CFLAGS="${CFLAGS/-pipe/}" ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ || die
+
+ cp libgphoto2/Makefile libgphoto2/Makefile.orig
+ sed -e 's:$(prefix)/doc/gphoto2:/usr/share/doc/${PF}:' \
+ libgphoto2/Makefile.orig >libgphoto2/Makefile
+
+ make || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ gphotodocdir=${D}/usr/share/doc/${PF} \
+ HTML_DIR=${D}/usr/share/doc/${PF}/sgml \
+ install || die
+
+ dodoc ChangeLog NEWS* README
+ rm -rf ${D}/usr/share/doc/${PF}/sgml/gphoto2
+}