summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-05 19:43:20 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-05 19:43:20 +0000
commit57cfcbec70fd3ce8babfc5de34d5625964a04295 (patch)
treecd9d7a36b1389f7e6327a7101803aecbf8662d58 /media-gfx/gphoto
parent- bah. forgot digest. (diff)
downloadgentoo-2-57cfcbec70fd3ce8babfc5de34d5625964a04295.tar.gz
gentoo-2-57cfcbec70fd3ce8babfc5de34d5625964a04295.tar.bz2
gentoo-2-57cfcbec70fd3ce8babfc5de34d5625964a04295.zip
*** empty log message ***
Diffstat (limited to 'media-gfx/gphoto')
-rw-r--r--media-gfx/gphoto/files/digest-gphoto-2.0_beta11
-rw-r--r--media-gfx/gphoto/gphoto-0.4.3.ebuild4
-rw-r--r--media-gfx/gphoto/gphoto-2.0_beta1.ebuild34
3 files changed, 37 insertions, 2 deletions
diff --git a/media-gfx/gphoto/files/digest-gphoto-2.0_beta1 b/media-gfx/gphoto/files/digest-gphoto-2.0_beta1
new file mode 100644
index 000000000000..e83f03b94851
--- /dev/null
+++ b/media-gfx/gphoto/files/digest-gphoto-2.0_beta1
@@ -0,0 +1 @@
+MD5 a6c0ec7ac7ee34486440637ee48d09a7 gphoto-2.0beta1.tar.gz
diff --git a/media-gfx/gphoto/gphoto-0.4.3.ebuild b/media-gfx/gphoto/gphoto-0.4.3.ebuild
index bcb49f1bbe07..a2613a6d0363 100644
--- a/media-gfx/gphoto/gphoto-0.4.3.ebuild
+++ b/media-gfx/gphoto/gphoto-0.4.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author AJ Lewis <aj@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto/gphoto-0.4.3.ebuild,v 1.5 2001/06/04 10:34:15 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto/gphoto-0.4.3.ebuild,v 1.6 2001/06/05 19:43:20 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -23,7 +23,7 @@ src_compile() {
}
src_install() {
- try make prefix=${D}/opt/gnome --sysconfdir=${D}/etc/opd/gnome install
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
dodoc AUTHORS CONTACTS COPYING ChangeLog FAQ MANUAL NEWS* PROGRAMMERS \
README THANKS THEMES TODO
}
diff --git a/media-gfx/gphoto/gphoto-2.0_beta1.ebuild b/media-gfx/gphoto/gphoto-2.0_beta1.ebuild
new file mode 100644
index 000000000000..99c125485845
--- /dev/null
+++ b/media-gfx/gphoto/gphoto-2.0_beta1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author AJ Lewis <aj@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto/gphoto-2.0_beta1.ebuild,v 1.1 2001/06/05 19:43:20 achim Exp $
+
+A=${PN}-2.0beta1.tar.gz
+S=${WORKDIR}/${PN}-2.0beta1
+DESCRIPTION="free, redistributable digital camera software application"
+SRC_URI="http://www.gphoto.net/dist/${A}"
+HOMEPAGE="http://www.gphoto.org"
+
+DEPEND="virtual/glibc >=dev-libs/libusb-0.1.3b >=dev-libs/glib-1.2.10 >=sys-libs/zlib-1.1.3"
+
+
+src_compile() {
+
+ # -pipe does no work
+ cd libgphoto2_port
+ try CFLAGS=\"${CFLAGS/-pipe/}\" ./configure --prefix=/usr --sysconfdir=/etc
+ cd ..
+ try CFLAGS=\"${CFLAGS/-pipe/}\" ./configure --prefix=/usr --sysconfdir=/etc
+ # -j does not work
+ try make
+}
+
+src_install() {
+ try make prefix=${D}/usr sysconfdir=${D}/etc install
+ dodoc ChangeLog NEWS* README
+ mv ${D}/usr/share/gphoto2/html ${D}/usr/share/doc/${PF}/sgml
+ mv ${D}/usr/doc/gphoto2/* ${D}/usr/share/doc/${PF}
+ rm -rf ${D}/usr/share/gphoto2 ${D}/usr/share/doc/${PF}/sgml/gphoto2 ${D}/usr/doc
+ prepalldocs
+}
+