summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2009-06-28 17:35:31 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2009-06-28 17:35:31 +0000
commit811374ae368905db33f2a8defa63a2418a7efc31 (patch)
tree5b05de241a44f1b69597a08a1c04472636a6778b /media-gfx/jhead/jhead-2.87.ebuild
parentx11-base/xorg-server: backport some more patches from upstream's 1.6 nominati... (diff)
downloadgentoo-2-811374ae368905db33f2a8defa63a2418a7efc31.tar.gz
gentoo-2-811374ae368905db33f2a8defa63a2418a7efc31.tar.bz2
gentoo-2-811374ae368905db33f2a8defa63a2418a7efc31.zip
2.87 version bump, patch to respect flags and change mktemp to mkstemp for bug 275200. Thanks to Zeev
Tarantov <zeev dot tarantov at gmail dot com>. (Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-gfx/jhead/jhead-2.87.ebuild')
-rw-r--r--media-gfx/jhead/jhead-2.87.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/jhead/jhead-2.87.ebuild b/media-gfx/jhead/jhead-2.87.ebuild
new file mode 100644
index 000000000000..a10905258841
--- /dev/null
+++ b/media-gfx/jhead/jhead-2.87.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/jhead-2.87.ebuild,v 1.1 2009/06/28 17:35:31 vanquirius Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
+HOMEPAGE="http://www.sentex.net/~mwandel/jhead"
+SRC_URI="http://www.sentex.net/~mwandel/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ # bug 275200 - respect flags and use mktemp instead of mkstemp
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-${PV}-respect_flags.patch
+ epatch "${FILESDIR}"/${PN}-${PV}-mkstemp.patch
+}
+
+src_compile() {
+ emake || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed."
+ dodoc *.txt
+ dohtml *.html
+ doman ${PN}.1
+}