summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-02-15 02:56:52 +0000
committerTim Harder <radhermit@gentoo.org>2015-02-15 02:56:52 +0000
commit04f6a22f8c3d2bda12f1d40e5c636b23ffa7cd6b (patch)
tree58f3903b266ec5bbebf8c87f3221031416d637b4 /media-gfx/jhead
parentVersion bump. (diff)
downloadgentoo-2-04f6a22f8c3d2bda12f1d40e5c636b23ffa7cd6b.tar.gz
gentoo-2-04f6a22f8c3d2bda12f1d40e5c636b23ffa7cd6b.tar.bz2
gentoo-2-04f6a22f8c3d2bda12f1d40e5c636b23ffa7cd6b.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-gfx/jhead')
-rw-r--r--media-gfx/jhead/ChangeLog9
-rw-r--r--media-gfx/jhead/jhead-3.00.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/media-gfx/jhead/ChangeLog b/media-gfx/jhead/ChangeLog
index f48d1071b19e..640567faaad5 100644
--- a/media-gfx/jhead/ChangeLog
+++ b/media-gfx/jhead/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/jhead
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/ChangeLog,v 1.150 2013/04/02 23:06:54 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/ChangeLog,v 1.151 2015/02/15 02:56:52 radhermit Exp $
+
+*jhead-3.00 (15 Feb 2015)
+
+ 15 Feb 2015; Tim Harder <radhermit@gentoo.org> +jhead-3.00.ebuild:
+ Version bump.
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> jhead-2.97.ebuild:
Stable for hppa, wrt bug #463094
diff --git a/media-gfx/jhead/jhead-3.00.ebuild b/media-gfx/jhead/jhead-3.00.ebuild
new file mode 100644
index 000000000000..20be2b5d2125
--- /dev/null
+++ b/media-gfx/jhead/jhead-3.00.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/jhead-3.00.ebuild,v 1.1 2015/02/15 02:56:52 radhermit Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
+HOMEPAGE="http://www.sentex.net/~mwandel/jhead"
+SRC_URI="http://www.sentex.net/~mwandel/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_prepare() {
+ # bug 275200 - respect flags and use mktemp instead of mkstemp
+ epatch "${FILESDIR}"/${PN}-2.90-mkstemp_respect_flags.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc *.txt
+ dohtml *.html
+ doman ${PN}.1
+}