summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-12-04 10:13:41 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-12-04 10:13:41 +0000
commitb3427631c4eb93da4ebb82f697b95cc3338237b1 (patch)
tree1f54e649e2a74b3d6e8ed92c5f9e5a861d010572 /media-gfx/mypaint/mypaint-1.0.0.ebuild
parentmove ping to extra_started_commands (diff)
downloadgentoo-2-b3427631c4eb93da4ebb82f697b95cc3338237b1.tar.gz
gentoo-2-b3427631c4eb93da4ebb82f697b95cc3338237b1.tar.bz2
gentoo-2-b3427631c4eb93da4ebb82f697b95cc3338237b1.zip
Version bump. Bug #391867
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/mypaint/mypaint-1.0.0.ebuild')
-rw-r--r--media-gfx/mypaint/mypaint-1.0.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-gfx/mypaint/mypaint-1.0.0.ebuild b/media-gfx/mypaint/mypaint-1.0.0.ebuild
new file mode 100644
index 000000000000..0bcbbe7e2546
--- /dev/null
+++ b/media-gfx/mypaint/mypaint-1.0.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/mypaint/mypaint-1.0.0.ebuild,v 1.1 2011/12/04 10:13:41 hwoarang Exp $
+
+EAPI=2
+
+inherit eutils fdo-mime gnome2-utils multilib scons-utils toolchain-funcs
+
+DESCRIPTION="fast and easy graphics application for digital painters"
+HOMEPAGE="http://mypaint.intilinux.com/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pygtk
+ dev-python/numpy
+ >=dev-python/pycairo-1.4
+ >=dev-lang/python-2.4
+ <dev-lang/python-3
+ dev-libs/protobuf[python]"
+DEPEND="${RDEPEND}
+ >=dev-util/scons-1.0
+ dev-lang/swig"
+
+src_prepare() {
+ # multilib support
+ sed -i -e "s:lib\/${PN}:$(get_libdir)\/${PN}:" "${S}"/SConstruct || die
+ # respect CXXFLAGS,CXX,LDFLAGS
+ epatch "${FILESDIR}"/${PN}-0.9.1-gentoo.patch
+}
+
+src_compile() {
+ #workaround scons bug with locales. Bug #352700
+ export LANG="en_US.UTF-8"
+ tc-export CXX
+ escons || die "scons failed"
+}
+
+src_install () {
+ escons prefix="${D}/usr" install || die "scons install failed"
+ newicon pixmaps/${PN}_logo.png ${PN}.png
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}