summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2005-01-13 23:49:08 +0000
committerTavis Ormandy <taviso@gentoo.org>2005-01-13 23:49:08 +0000
commit77189a30153f8685ab67eaf1d402672b4f18d81b (patch)
treea8196a1dc375659a475a16b4175553e35eb27821 /media-gfx/optipng/optipng-0.4.7.ebuild
parentsec fix can 1137 1056 (Manifest recommit) (diff)
downloadgentoo-2-77189a30153f8685ab67eaf1d402672b4f18d81b.tar.gz
gentoo-2-77189a30153f8685ab67eaf1d402672b4f18d81b.tar.bz2
gentoo-2-77189a30153f8685ab67eaf1d402672b4f18d81b.zip
new version
Diffstat (limited to 'media-gfx/optipng/optipng-0.4.7.ebuild')
-rw-r--r--media-gfx/optipng/optipng-0.4.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/optipng/optipng-0.4.7.ebuild b/media-gfx/optipng/optipng-0.4.7.ebuild
new file mode 100644
index 000000000000..250753c5700b
--- /dev/null
+++ b/media-gfx/optipng/optipng-0.4.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/optipng/optipng-0.4.7.ebuild,v 1.1 2005/01/13 23:49:08 taviso Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Find the optimal compression settings for your png files"
+SRC_URI="http://www.cs.toronto.edu/~cosmin/pngtech/optipng/${P}.tar.gz"
+HOMEPAGE="http://www.cs.toronto.edu/~cosmin/pngtech/optipng/"
+
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ cd ${S}/src
+ sed -i -e 's!-O2!${CFLAGS}!' scripts/gcc.mak
+ emake -f scripts/gcc.mak optipng CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+
+ # some feedback everything went ok...
+ echo; ls -l optipng; size optipng
+}
+
+src_install() {
+ dobin ${S}/src/optipng
+ dodoc ${S}/doc/{CAVEAT,DESIGN,FEATURES,HISTORY,LICENSE,README,TODO,USAGE}
+ dohtml ${S}/doc/index.html
+}