summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-10-02 14:28:49 +0000
committerMike Gardiner <obz@gentoo.org>2003-10-02 14:28:49 +0000
commit23cf5a5a1851b04da95a24b0ca6a2eee4b6d465f (patch)
treecda57bbb3c2d77027357a5fcc3cbe40d2f458aee /media-gfx/pstoedit/pstoedit-3.33.ebuild
parentchangelog:p (diff)
downloadgentoo-2-23cf5a5a1851b04da95a24b0ca6a2eee4b6d465f.tar.gz
gentoo-2-23cf5a5a1851b04da95a24b0ca6a2eee4b6d465f.tar.bz2
gentoo-2-23cf5a5a1851b04da95a24b0ca6a2eee4b6d465f.zip
Fixes for libEMF and ming problems
Diffstat (limited to 'media-gfx/pstoedit/pstoedit-3.33.ebuild')
-rw-r--r--media-gfx/pstoedit/pstoedit-3.33.ebuild27
1 files changed, 20 insertions, 7 deletions
diff --git a/media-gfx/pstoedit/pstoedit-3.33.ebuild b/media-gfx/pstoedit/pstoedit-3.33.ebuild
index 3b9ad8823ece..a132a865169a 100644
--- a/media-gfx/pstoedit/pstoedit-3.33.ebuild
+++ b/media-gfx/pstoedit/pstoedit-3.33.ebuild
@@ -1,35 +1,48 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.33.ebuild,v 1.2 2003/09/06 23:56:39 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.33.ebuild,v 1.3 2003/10/02 14:28:12 obz Exp $
inherit libtool
-IUSE="flash"
+# see bug #29724. please don't re-enable flash support until
+# ming has the patches applied <obz@gentoo.org>
+# IUSE="flash"
+IUSE=""
-S=${WORKDIR}/${P}
DESCRIPTION="translates PostScript and PDF graphics into other vector formats"
SRC_URI="http://home.t-online.de/home/helga.glunz/wglunz/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.pstoedit.net/pstoedit"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ~ppc"
DEPEND="media-libs/libpng
- sys-libs/zlib
- flash? ( media-libs/ming )"
+ sys-libs/zlib"
+
+# flash? ( media-libs/ming )"
RDEPEND="${DEPEND}
app-text/ghostscript"
src_compile() {
+
+ local myconf=""
+ # checking if libemf is previously installed, bug #29724
+ # <obz@gentoo.org>
+ [ -f /usr/include/libEMF/emf.h ] \
+ && myconf="${myconf} --with-libemf-include=/usr/include/libEMF"
+
elibtoolize
- econf
+ econf ${myconf}
make || die
+
}
src_install () {
+
make DESTDIR=${D} install || die "make install failed"
dodoc readme.txt copying
dodoc changelog.htm
+
}