summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-08-07 18:01:03 +0000
committerJustin Lecher <jlec@gentoo.org>2010-08-07 18:01:03 +0000
commit430e957026d4e023a41a3ec11b6414562551f8d0 (patch)
tree036f398704c6b485c4f9052f29b299a710730977 /media-gfx/uniconvertor
parentx86 stable wrt security bug #301828 (diff)
downloadgentoo-2-430e957026d4e023a41a3ec11b6414562551f8d0.tar.gz
gentoo-2-430e957026d4e023a41a3ec11b6414562551f8d0.tar.bz2
gentoo-2-430e957026d4e023a41a3ec11b6414562551f8d0.zip
Added missing deps, thanks to Nikoli
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/uniconvertor')
-rw-r--r--media-gfx/uniconvertor/ChangeLog6
-rw-r--r--media-gfx/uniconvertor/files/uniconvertor-1.1.5_export_raster.py_fix_import.patch11
-rw-r--r--media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild23
3 files changed, 25 insertions, 15 deletions
diff --git a/media-gfx/uniconvertor/ChangeLog b/media-gfx/uniconvertor/ChangeLog
index c57efa6c5e18..55fc651ef225 100644
--- a/media-gfx/uniconvertor/ChangeLog
+++ b/media-gfx/uniconvertor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/uniconvertor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/uniconvertor/ChangeLog,v 1.3 2010/08/06 13:43:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/uniconvertor/ChangeLog,v 1.4 2010/08/07 18:01:02 jlec Exp $
+
+ 07 Aug 2010; Justin Lecher <jlec@gentoo.org> uniconvertor-1.1.5.ebuild,
+ +files/uniconvertor-1.1.5_export_raster.py_fix_import.patch:
+ Added missing deps and patches, thanks to Nikoli
*uniconvertor-1.1.5 (06 Aug 2010)
diff --git a/media-gfx/uniconvertor/files/uniconvertor-1.1.5_export_raster.py_fix_import.patch b/media-gfx/uniconvertor/files/uniconvertor-1.1.5_export_raster.py_fix_import.patch
new file mode 100644
index 000000000000..e2794b269913
--- /dev/null
+++ b/media-gfx/uniconvertor/files/uniconvertor-1.1.5_export_raster.py_fix_import.patch
@@ -0,0 +1,11 @@
+--- UniConvertor/trunk/uniconvertor/src/app/scripts/export_raster.py 2010/06/19 10:26:44 216
++++ UniConvertor/trunk/uniconvertor/src/app/scripts/export_raster.py 2010/06/28 01:15:30 283
+@@ -37,7 +37,7 @@
+
+ import os, tempfile
+
+-from sk1libs import imaging.Image, imaging.ImageChops
++from sk1libs.imaging import Image, ImageChops
+
+ import app.Scripting
+ from app import _, PostScriptDevice
diff --git a/media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild b/media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild
index cab71a649b1e..48d6ed6ec978 100644
--- a/media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild
+++ b/media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild,v 1.1 2010/08/06 13:43:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild,v 1.2 2010/08/07 18:01:02 jlec Exp $
-EAPI=2
+EAPI="2"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.7 3.*"
+RESTRICT_PYTHON_ABIS="3.*"
-inherit distutils
+inherit distutils eutils
DESCRIPTION="Commandline tool for popular vector formats convertion"
HOMEPAGE="http://sk1project.org/modules.php?name=Products&product=uniconvertor"
@@ -19,21 +19,16 @@ SLOT="0"
LICENSE="GPL-2 LGPL-2"
IUSE=""
-DEPEND="
- dev-python/imaging
- dev-python/reportlab
- >=media-libs/sk1libs-0.9.1"
-
-S=${WORKDIR}/${P}
+DEPEND=">=media-libs/sk1libs-0.9.1"
+RDEPEND="${DEPEND}
+ app-text/ghostscript-gpl"
src_prepare() {
sed -i \
-e "s/'GNU_GPL_v2', 'GNU_LGPL_v2', 'COPYRIGHTS',//" \
setup.py || die
- distutils_src_prepare
-}
+ epatch "${FILESDIR}/uniconvertor-1.1.5_export_raster.py_fix_import.patch"
-src_install() {
- distutils_src_install
+ distutils_src_prepare
}