summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-09-10 09:29:59 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-09-10 09:29:59 +0000
commit5f51af125bd29289bd165ca0dccc2265b046c95b (patch)
tree752e04ea23c5d1012b7d130861bbb67bed393cce /media-gfx/wally
parentRemove old versions. (diff)
downloadgentoo-2-5f51af125bd29289bd165ca0dccc2265b046c95b.tar.gz
gentoo-2-5f51af125bd29289bd165ca0dccc2265b046c95b.tar.bz2
gentoo-2-5f51af125bd29289bd165ca0dccc2265b046c95b.zip
Version bump
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/wally')
-rw-r--r--media-gfx/wally/ChangeLog7
-rw-r--r--media-gfx/wally/wally-2.4.2.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/media-gfx/wally/ChangeLog b/media-gfx/wally/ChangeLog
index e9a5b95dcb39..607c76dfe4e1 100644
--- a/media-gfx/wally/ChangeLog
+++ b/media-gfx/wally/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/wally
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/ChangeLog,v 1.33 2011/06/01 15:40:40 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/ChangeLog,v 1.34 2011/09/10 09:29:59 hwoarang Exp $
+
+*wally-2.4.2 (10 Sep 2011)
+
+ 10 Sep 2011; Markos Chandras <hwoarang@gentoo.org> +wally-2.4.2.ebuild:
+ Version bump
01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> wally-2.3.2.ebuild,
wally-2.4.1.ebuild:
diff --git a/media-gfx/wally/wally-2.4.2.ebuild b/media-gfx/wally/wally-2.4.2.ebuild
new file mode 100644
index 000000000000..1f169eb5fe27
--- /dev/null
+++ b/media-gfx/wally/wally-2.4.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/wally-2.4.2.ebuild,v 1.1 2011/09/10 09:29:59 hwoarang Exp $
+
+EAPI=3
+KDE_REQUIRED="optional"
+inherit eutils kde4-base
+
+DESCRIPTION="A Qt4/KDE4 wallpaper changer"
+HOMEPAGE="http://www.becrux.com/index.php?page=projects&name=wally"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug kde"
+
+DEPEND="
+ media-libs/libexif
+ x11-libs/qt-svg:4
+ x11-libs/qt-dbus:4
+ x11-libs/qt-sql:4
+ kde? ( $(add_kdebase_dep kdelibs) )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.2.0-disable_popup.patch"
+)
+
+src_prepare() {
+ kde4-base_src_prepare
+ use kde || epatch "${FILESDIR}/${PN}-2.2.0-disable-kde4.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DSTATIC=FALSE
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newicon "${S}"/res/images/idle.png wally.png || die
+ make_desktop_entry wally Wally wally "Graphics;Qt" || die
+}
+
+pkg_postinst() {
+ if use kde; then
+ elog
+ elog "In order to use wallyplugin you need to"
+ elog "restart plasma in your KDE4 enviroment."
+ elog
+ fi
+}