summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-05 18:56:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-05 18:56:54 +0000
commit077afa00507731b738e257e7240058a03ebe172a (patch)
tree28dbcdfdcb70890ce4dd4e3500ed462f49c618cf /media-gfx
parentRe-sign manifest. (diff)
downloadgentoo-2-077afa00507731b738e257e7240058a03ebe172a.tar.gz
gentoo-2-077afa00507731b738e257e7240058a03ebe172a.tar.bz2
gentoo-2-077afa00507731b738e257e7240058a03ebe172a.zip
Initial import of iscan-plugin-gt-x770 by Matthew Schultz (see bug #367585). This will require an unmerge of the sunrise version before merge to ensure proper path is registered with iscan.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/iscan-plugin-gt-x770/ChangeLog11
-rw-r--r--media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r2.ebuild93
-rw-r--r--media-gfx/iscan-plugin-gt-x770/metadata.xml19
3 files changed, 123 insertions, 0 deletions
diff --git a/media-gfx/iscan-plugin-gt-x770/ChangeLog b/media-gfx/iscan-plugin-gt-x770/ChangeLog
new file mode 100644
index 000000000000..a6c59b0767e2
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-x770/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-gfx/iscan-plugin-gt-x770
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-plugin-gt-x770/ChangeLog,v 1.1 2012/07/05 18:56:54 flameeyes Exp $
+
+*iscan-plugin-gt-x770-2.1.2.1-r2 (05 Jul 2012)
+
+ 05 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +iscan-plugin-gt-x770-2.1.2.1-r2.ebuild, +metadata.xml:
+ Initial import of iscan-plugin-gt-x770 by Matthew Schultz (see bug #367585).
+ This will require an unmerge of the sunrise version before merge to ensure
+ proper path is registered with iscan.
diff --git a/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r2.ebuild b/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r2.ebuild
new file mode 100644
index 000000000000..ea564dded4e7
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r2.ebuild,v 1.1 2012/07/05 18:56:54 flameeyes Exp $
+
+EAPI="4"
+
+inherit rpm versionator multilib
+
+MY_PV="$(get_version_component_range 1-3)"
+MY_PVR="$(replace_version_separator 3 -)"
+
+DESCRIPTION="Epson Perfection V500 scanner plugin for SANE 'epkowa' backend."
+HOMEPAGE="http://www.avasys.jp/english/linux_e/dl_scan.html"
+SRC_URI="
+ x86? ( http://linux.avasys.jp/drivers/iscan-plugins/${PN}/${MY_PV}/${PN}-${MY_PVR}.i386.rpm )
+ amd64? ( http://linux.avasys.jp/drivers/iscan-plugins/${PN}/${MY_PV}/${PN}-${MY_PVR}.x86_64.rpm )
+"
+
+LICENSE="AVASYS"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=">=media-gfx/iscan-2.21.0
+ !!<media-gfx/iscan-plugin-gt-x770-2.1.2.1-r2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="
+ /opt/iscan/esci/libesint7C.so.2.0.1
+ /opt/iscan/esci/libesint7C.so.2
+ /opt/iscan/esci/libesint7C.so"
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ # install scanner firmware
+ insinto /usr/share/iscan
+ doins "${WORKDIR}/usr/share/iscan/"*
+
+ dodoc usr/share/doc/*/*
+
+ # install scanner plugins
+ exeinto /opt/iscan/esci
+ doexe "${WORKDIR}/usr/$(get_libdir)/iscan/"*
+}
+
+pkg_setup() {
+ basecmds=(
+ "iscan-registry --COMMAND interpreter usb 0x04b8 0x0130 /opt/iscan/esci/libesint7C /usr/share/iscan/esfw7C.bin"
+ )
+}
+
+pkg_postinst() {
+ elog
+ elog "Firmware file esfw41.bin for Epson Perfection V500"
+ elog "has been installed in /usr/share/iscan."
+ elog
+
+ [[ -n ${REPLACING_VERSIONS} ]] && return
+
+ # Needed for scanner to work properly.
+ if [[ ${ROOT} == "/" ]]; then
+ for basecmd in "${basecmds[@]}"; do
+ eval ${basecmd/COMMAND/add}
+ done
+ else
+ ewarn "Unable to register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ for basecmd in "${basecmds[@]}"; do
+ ewarn "${basecmd/COMMAND/add}"
+ done
+ fi
+}
+
+pkg_prerm() {
+ [[ -n ${REPLACED_BY_VERSION} ]] && return
+
+ if [[ ${ROOT} == "/" ]]; then
+ for basecmd in "${basecmds[@]}"; do
+ eval ${basecmd/COMMAND/remove}
+ done
+ else
+ ewarn "Unable to de-register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ for basecmd in "${basecmds[@]}"; do
+ ewarn "${basecmd/COMMAND/remove}"
+ done
+ fi
+}
diff --git a/media-gfx/iscan-plugin-gt-x770/metadata.xml b/media-gfx/iscan-plugin-gt-x770/metadata.xml
new file mode 100644
index 000000000000..94e69f1d8ff6
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-x770/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mattsch@gmail.com</email>
+ </maintainer>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Proprietary plugin for several EPSON scanner models, to be used
+ with the epkowa SANE backend (provided by
+ <pkg>media-gfx/iscan</pkg>). 32-bit and 64-bit.
+
+ Supports the following models:
+
+ EPSON Perfection V500 (GT-X770)
+ </longdescription>
+</pkgmetadata>