summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-07-29 11:11:10 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-07-29 11:11:10 +0000
commit2741816b11f52154ef32aab06565b8fab3fc490b (patch)
tree73aeb8366295daa80042d3d01405a401e409c257 /media-gfx
parentCleanup (diff)
downloadgentoo-2-2741816b11f52154ef32aab06565b8fab3fc490b.tar.gz
gentoo-2-2741816b11f52154ef32aab06565b8fab3fc490b.tar.bz2
gentoo-2-2741816b11f52154ef32aab06565b8fab3fc490b.zip
Fix compilation under gcc-4.6. Fixes bug #376799.
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/graphite2/ChangeLog6
-rw-r--r--media-gfx/graphite2/files/graphite2-fix_wrong_linker_opts.patch11
-rw-r--r--media-gfx/graphite2/graphite2-0.9.4-r1.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/media-gfx/graphite2/ChangeLog b/media-gfx/graphite2/ChangeLog
index b2fafb003e4c..a2306514801a 100644
--- a/media-gfx/graphite2/ChangeLog
+++ b/media-gfx/graphite2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/graphite2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/ChangeLog,v 1.7 2011/07/29 10:14:59 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/ChangeLog,v 1.8 2011/07/29 11:11:10 scarabeus Exp $
+
+ 29 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/graphite2-fix_wrong_linker_opts.patch, graphite2-0.9.4-r1.ebuild:
+ Fix compilation under gcc-4.6. Fixes bug #376799.
29 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+files/graphite2-fix-nostdlib.patch, graphite2-0.9.4-r1.ebuild:
diff --git a/media-gfx/graphite2/files/graphite2-fix_wrong_linker_opts.patch b/media-gfx/graphite2/files/graphite2-fix_wrong_linker_opts.patch
new file mode 100644
index 000000000000..233995647ce3
--- /dev/null
+++ b/media-gfx/graphite2/files/graphite2-fix_wrong_linker_opts.patch
@@ -0,0 +1,11 @@
+diff -urN graphite2-0.9.4.old/src/CMakeLists.txt graphite2-0.9.4/src/CMakeLists.txt
+--- graphite2-0.9.4.old/src/CMakeLists.txt 2011-07-29 12:53:36.000000000 +0200
++++ graphite2-0.9.4/src/CMakeLists.txt 2011-07-29 13:06:18.000000000 +0200
+@@ -166,7 +166,6 @@
+ -Wshadow -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -fdiagnostics-show-option
+ -fno-rtti -fno-exceptions -nodefaultlibs -nostdlib
+ -fvisibility=hidden -fvisibility-inlines-hidden -fno-stack-protector)
+- set_target_properties(graphite2 PROPERTIES LINK_FLAGS "-nostdlib -nodefaultlibs" LINKER_LANGUAGE C)
+ if (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
+ target_link_libraries(graphite2 "-lkernel32 -lmsvcr90 -lmingw32 -lgcc -luser32")
+ else (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
diff --git a/media-gfx/graphite2/graphite2-0.9.4-r1.ebuild b/media-gfx/graphite2/graphite2-0.9.4-r1.ebuild
index abaaea86894a..98dd8108efbf 100644
--- a/media-gfx/graphite2/graphite2-0.9.4-r1.ebuild
+++ b/media-gfx/graphite2/graphite2-0.9.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/graphite2-0.9.4-r1.ebuild,v 1.4 2011/07/29 10:14:59 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/graphite2-0.9.4-r1.ebuild,v 1.5 2011/07/29 11:11:10 scarabeus Exp $
EAPI=4
@@ -29,6 +29,7 @@ PATCHES=(
"${FILESDIR}/${PN}-disablefonttest.patch"
"${FILESDIR}/${PN}-multilib-strict.patch"
"${FILESDIR}/${PN}-fix-nostdlib.patch"
+ "${FILESDIR}/${PN}-fix_wrong_linker_opts.patch"
)
pkg_setup() {