summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-11-09 15:52:31 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-11-09 15:52:31 +0000
commit557c59b7df01ee35b1c146db115e6c3e47a4ebe4 (patch)
treeaa4fdb50af6e8f4648982a2a8347c2fe81a439bf /media-gfx
parentstable sparc, security bug 286102 (diff)
downloadgentoo-2-557c59b7df01ee35b1c146db115e6c3e47a4ebe4.tar.gz
gentoo-2-557c59b7df01ee35b1c146db115e6c3e47a4ebe4.tar.bz2
gentoo-2-557c59b7df01ee35b1c146db115e6c3e47a4ebe4.zip
Version bump
(Portage version: 2.2_rc49/cvs/Linux i686)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/asymptote/ChangeLog9
-rw-r--r--media-gfx/asymptote/asymptote-1.89.ebuild195
-rw-r--r--media-gfx/asymptote/files/asymptote-1.89-configure-ac.patch32
-rw-r--r--media-gfx/asymptote/files/asymptote-1.89-xdg-utils.patch22
4 files changed, 257 insertions, 1 deletions
diff --git a/media-gfx/asymptote/ChangeLog b/media-gfx/asymptote/ChangeLog
index d3ed825fbc15..8c56c5b9134c 100644
--- a/media-gfx/asymptote/ChangeLog
+++ b/media-gfx/asymptote/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/asymptote
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/ChangeLog,v 1.61 2009/10/21 16:20:22 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/ChangeLog,v 1.62 2009/11/09 15:52:31 grozin Exp $
+
+*asymptote-1.89 (09 Nov 2009)
+
+ 09 Nov 2009; Andrey Grozin <grozin@gentoo.org> +asymptote-1.89.ebuild,
+ +files/asymptote-1.89-configure-ac.patch,
+ +files/asymptote-1.89-xdg-utils.patch:
+ Version bump
21 Oct 2009; Andrey Grozin <grozin@gentoo.org> -files/64asy-gentoo.el,
-asymptote-1.29.ebuild, -files/asymptote-1.29-configure-ac.patch,
diff --git a/media-gfx/asymptote/asymptote-1.89.ebuild b/media-gfx/asymptote/asymptote-1.89.ebuild
new file mode 100644
index 000000000000..aa46e8c90581
--- /dev/null
+++ b/media-gfx/asymptote/asymptote-1.89.ebuild
@@ -0,0 +1,195 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/asymptote-1.89.ebuild,v 1.1 2009/11/09 15:52:31 grozin Exp $
+EAPI=2
+inherit eutils autotools elisp-common latex-package multilib python
+
+DESCRIPTION="A vector graphics language that provides a framework for technical drawing"
+HOMEPAGE="http://asymptote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/asymptote/${P}.src.tgz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+boehm-gc doc emacs examples fftw gsl +imagemagick latex python sigsegv vim-syntax X"
+
+RDEPEND=">=sys-libs/readline-4.3-r5
+ >=sys-libs/ncurses-5.4-r5
+ imagemagick? ( media-gfx/imagemagick[png] )
+ sigsegv? ( dev-libs/libsigsegv )
+ boehm-gc? ( >=dev-libs/boehm-gc-7.0[-nocxx,threads] )
+ fftw? ( >=sci-libs/fftw-3.0.1 )
+ gsl? ( sci-libs/gsl )
+ X? ( x11-misc/xdg-utils dev-lang/python dev-python/imaging[tk] )
+ python? ( dev-lang/python )
+ latex? ( virtual/latex-base )
+ emacs? ( virtual/emacs )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="${RDEPEND}
+ doc? ( dev-lang/perl virtual/texi2dvi virtual/latex-base media-gfx/imagemagick[png] )"
+
+TEXMF=/usr/share/texmf-site
+
+src_prepare() {
+ # Fixing sigsegv enabling
+ epatch "${FILESDIR}/${P}-configure-ac.patch"
+ einfo "Patching configure.ac"
+ sed -e "s:Datadir/doc/asymptote:Datadir/doc/${PF}:" \
+ -i configure.ac \
+ || die "sed configure.ac failed"
+
+ # Changing pdf, ps, image viewers to xdg-open
+ epatch "${FILESDIR}/${P}-xdg-utils.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ # for the CPPFLAGS see
+ # http://sourceforge.net/forum/forum.php?thread_id=1683277&forum_id=409349
+ econf CPPFLAGS=-DHAVE_SYS_TYPES_H \
+ --disable-gc-debug \
+ $(use_enable boehm-gc gc system) \
+ $(use_enable fftw) \
+ $(use_enable gsl) \
+ $(use_with sigsegv)
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ cd doc
+ emake asy.1 || die "emake asy.1 failed"
+ if use doc; then
+ # info
+ einfo "Making info"
+ emake ${PN}.info || die "emake ${PN}.info failed"
+ # html
+ einfo "Making html docs"
+ emake ${PN}/index.html
+ einfo "Making FAQ"
+ cd FAQ
+ emake
+ cd ..
+ # pdf
+ einfo "Making pdf docs"
+ export VARTEXFONTS="${T}"/fonts
+ # see bug #260606
+ emake -j1 asymptote.pdf
+ emake CAD.pdf
+ fi
+ cd ..
+
+ if use emacs; then
+ einfo "Compiling emacs lisp files"
+ elisp-compile base/*.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ # the program
+ exeinto /usr/bin
+ doexe asy
+
+ # .asy files
+ insinto /usr/share/${PN}
+ doins base/*.asy
+
+ # documentation
+ dodoc BUGS ChangeLog README ReleaseNotes TODO
+ doman doc/asy.1
+
+ # X GUI
+ if use X; then
+ exeinto /usr/share/${PN}/GUI
+ doexe GUI/xasy.py
+ rm GUI/xasy.py
+ insinto /usr/share/${PN}/GUI
+ doins GUI/*.py
+ dosym /usr/share/${PN}/GUI/xasy.py /usr/bin/xasy
+ doman doc/xasy.1x
+ fi
+
+ # examples
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins examples/*.asy \
+ examples/*.eps \
+ doc/*.asy \
+ doc/*.csv \
+ doc/*.dat \
+ doc/extra/*.asy
+ if use X; then
+ doins GUI/*.asy
+ fi
+ insinto /usr/share/${PN}/examples/animations
+ doins examples/animations/*.asy
+ fi
+
+ # LaTeX style
+ if use latex; then
+ cd doc
+ insinto "${TEXMF}"/tex/latex/${PN}
+ doins ${PN}.sty asycolors.sty
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins latexusage.tex
+ fi
+ cd ..
+ fi
+
+ # asymptote.py
+ if use python; then
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doins base/${PN}.py
+ fi
+
+ # emacs mode
+ if use emacs; then
+ elisp-install ${PN} base/*.el base/*.elc
+ elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
+ fi
+
+ # vim syntax
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins base/asy.vim
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/asy-ftd.vim
+ fi
+
+ # extra documentation
+ if use doc; then
+ cd doc
+ doinfo ${PN}.info*
+ cd FAQ
+ dodoc asy-faq.ascii
+ doinfo asy-faq.info
+ insinto /usr/share/doc/${PF}/html/FAQ
+ doins asy-faq.html/*
+ cd ..
+ insinto /usr/share/doc/${PF}
+ doins ${PN}.pdf CAD.pdf
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_version
+ python_mod_compile \
+ /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}.py
+ fi
+
+ use latex && latex-package_rehash
+
+ use emacs && elisp-site-regen
+
+ elog 'Use the variable ASYMPTOTE_PSVIEWER to set the postscript viewer'
+ elog 'Use the variable ASYMPTOTE_PDFVIEWER to set the PDF viewer'
+}
+
+pkg_postrm() {
+ use latex && latex-package_rehash
+ use emacs && elisp-site-regen
+ use python && python_mod_cleanup
+}
diff --git a/media-gfx/asymptote/files/asymptote-1.89-configure-ac.patch b/media-gfx/asymptote/files/asymptote-1.89-configure-ac.patch
new file mode 100644
index 000000000000..8a152836d9a8
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-1.89-configure-ac.patch
@@ -0,0 +1,32 @@
+Index: asymptote-1.89/configure.ac
+===================================================================
+--- asymptote-1.89.orig/configure.ac
++++ asymptote-1.89/configure.ac
+@@ -148,7 +148,7 @@ if test "x$ac_cv_use_gc" != "xno" ; then
+ fi
+ CPPFLAGS_SAVE=$CPPFLAGS
+ CPPFLAGS=$CPPFLAGS" $INCL"
+- AC_CHECK_HEADER(gc.h,
++ AC_CHECK_HEADER([gc/gc.h],
+ AC_CHECK_LIB([gc],[GC_malloc],[
+ LIBS=$LIBS"-lgc "
+ AC_MSG_NOTICE([enabling system $GCNAME])],[
+@@ -215,7 +215,17 @@ AC_MSG_ERROR([*** Please install libm on
+ AC_CHECK_LIB([z], [deflate],,
+ AC_MSG_ERROR([*** Please install libz on your system ***]))
+ AC_CHECK_LIB([pthread], [pthread_create])
+-AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler])
++
++AC_ARG_WITH(sigsegv,
++ [ --with-sigsegv use libsigsegv],
++ [with_sigsegv=$withval],
++ [with_sigsegv="no"])
++if test "$with_sigsegv" = "yes"; then
++AC_CHECK_HEADER([sigsegv.h],
++ AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler]),
++ AC_MSG_NOTICE([*** Header file sigsegv.h not found ***]))
++fi
++
+ AC_CHECK_LIB([rt], [sched_yield])
+
+ AC_ARG_ENABLE(readline,
diff --git a/media-gfx/asymptote/files/asymptote-1.89-xdg-utils.patch b/media-gfx/asymptote/files/asymptote-1.89-xdg-utils.patch
new file mode 100644
index 000000000000..683692170394
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-1.89-xdg-utils.patch
@@ -0,0 +1,22 @@
+Index: asymptote-1.89/settings.cc
+===================================================================
+--- asymptote-1.89.orig/settings.cc
++++ asymptote-1.89/settings.cc
+@@ -86,14 +86,14 @@ mode_t mask;
+ bool msdos=false;
+ string HOME="HOME";
+ const char pathSeparator=':';
+-string defaultPSViewer="gv";
++string defaultPSViewer="xdg-open";
+ #ifdef __APPLE__
+ string defaultPDFViewer="open";
+ #else
+-string defaultPDFViewer="acroread";
++string defaultPDFViewer="xdg-open";
+ #endif
+ string defaultGhostscript="gs";
+-string defaultDisplay="display";
++string defaultDisplay="xdg-open";
+ string defaultAnimate="animate";
+ string systemDir=ASYMPTOTE_SYSDIR;
+ string docdir=ASYMPTOTE_DOCDIR;