summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-28 22:50:17 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-28 22:50:17 +0000
commit6e41f14a2688733613663bae21ec6f460da0b5fd (patch)
treec28b57bfd4ff1cfeee91d61fbd9dcb2ee4f7a33c /media-gfx
parentFixed to work with portage fakeroot patch, ebuild tries to overwrite a (diff)
downloadgentoo-2-6e41f14a2688733613663bae21ec6f460da0b5fd.tar.gz
gentoo-2-6e41f14a2688733613663bae21ec6f460da0b5fd.tar.bz2
gentoo-2-6e41f14a2688733613663bae21ec6f460da0b5fd.zip
version bump
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/imagemagick/ChangeLog12
-rw-r--r--media-gfx/imagemagick/files/digest-imagemagick-5.4.7.41
-rw-r--r--media-gfx/imagemagick/imagemagick-5.4.7.4.ebuild82
3 files changed, 93 insertions, 2 deletions
diff --git a/media-gfx/imagemagick/ChangeLog b/media-gfx/imagemagick/ChangeLog
index cbb2216eaafc..5d2ccd806398 100644
--- a/media-gfx/imagemagick/ChangeLog
+++ b/media-gfx/imagemagick/ChangeLog
@@ -1,9 +1,17 @@
# ChangeLog for media-gfx/imagemagick
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/ChangeLog,v 1.21 2002/10/27 18:45:10 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/ChangeLog,v 1.22 2002/10/28 22:50:17 seemant Exp $
-*imagemagick-5.4.9.1 (22 Oct 2002)
+*imagemagick-5.4.7.4 (28 Oct 2002)
+
+ 28 Oct 2002; Seemant Kulleen <seemant@gentoo.org>
+ imagemagick-5.4.7.4.ebuild files/digest-imagemagick-5.4.7.4 :
+ Version bump on the 5.4.7 (stable KEYWORDS) version, as the old tarball is
+ no longer available. Thanks to: ince@pacifier.com (Michael Labhard) in
+ bug #9848.
+
+*imagemagick-5.4.9.1 (22 Oct 2002)
27 Oct 2002; <mcummings@gentoo.org> :
Tested on x86 - there is no longer a tar ball for 5.4.7, testing required
diff --git a/media-gfx/imagemagick/files/digest-imagemagick-5.4.7.4 b/media-gfx/imagemagick/files/digest-imagemagick-5.4.7.4
new file mode 100644
index 000000000000..b08cbf0d7094
--- /dev/null
+++ b/media-gfx/imagemagick/files/digest-imagemagick-5.4.7.4
@@ -0,0 +1 @@
+MD5 86fdd3f4ceef005ef164a63996b5187f ImageMagick-5.4.7-4.tar.bz2 2900510
diff --git a/media-gfx/imagemagick/imagemagick-5.4.7.4.ebuild b/media-gfx/imagemagick/imagemagick-5.4.7.4.ebuild
new file mode 100644
index 000000000000..55a200dac177
--- /dev/null
+++ b/media-gfx/imagemagick/imagemagick-5.4.7.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/imagemagick-5.4.7.4.ebuild,v 1.1 2002/10/28 22:50:17 seemant Exp $
+
+IUSE="perl X cups xml2 lcms"
+
+inherit libtool
+inherit perl-module
+
+MY_PN=ImageMagick
+MY_P=${MY_PN}-${PV%.*}-${PV#*.*.*.}
+S=${WORKDIR}/${MY_PN}-${PV%.*}
+DESCRIPTION="A collection of tools and libraries for many image formats"
+SRC_URI="http://imagemagick.sourceforge.net/http/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.imagemagick.org/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 ppc sparc64"
+
+DEPEND="media-libs/libpng
+ >=sys-apps/bzip2-1
+ >=sys-libs/zlib-1.1.3
+ >=media-libs/freetype-2.0
+ >=media-libs/jpeg-6b
+ >=media-libs/tiff-3.5.5
+ X? ( virtual/x11
+ >=app-text/dgs-0.5.9.1 )
+ cups? ( >=app-text/ghostscript-6.50 )
+ lcms? ( >=media-libs/lcms-1.06 )
+ perl? ( >=sys-devel/perl-5 )
+ xml2? ( >=dev-libs/libxml2-2.4.10 )"
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ use perl || myconf="--without-perl"
+ use lcms || myconf="${myconf} --without-lcms"
+ use xml2 || myconf="${myconf} --without-xml"
+ use X || myconf="${myconf} --with-x=no"
+
+ # Netscape is still used ? More people should have Mozilla
+ cp configure configure.orig
+ sed -e 's:netscape:mozilla:g' configure.orig > configure
+
+ #patch to allow building by perl
+ patch -p0 < ${FILESDIR}/perlpatch.diff
+
+ econf \
+ --enable-shared \
+ --enable-static \
+ --enable-lzw \
+ --with-ttf \
+ --with-fpx \
+ --without-gslib \
+ --without-hdf \
+ --with-jbig \
+ --with-wmf \
+ --with-threads \
+ ${myconf} || die "bad configure"
+ emake || die "compile problem"
+
+ # More perl stuff
+ cd PerlMagick
+ make clean
+ perl-module_src_prep
+ cd ..
+}
+
+src_install() {
+ myinst="prefix=${D}/usr PREFIX=${D}/usr"
+ myinst="${myinst} MagickSharePath=${D}/usr/share/ImageMagick/"
+ myinst="${myinst} pkgdocdir=${D}/usr/share/doc/${PF}/html"
+ myinst="${myinst} mandir=${D}/usr/share/man"
+ myinst="${myinst} datadir=${D}/usr/share"
+
+ mydoc="*.txt"
+ perl-module_src_install
+
+ rm -f ${D}/usr/share/ImageMagick/*.txt
+}