summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 17:27:45 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 17:27:45 +0000
commit71f6b2a4e6a6834c3200350c68ba1a990110c71a (patch)
tree43ec3ef149ecc9112f3d254a52d4613abfb9df36 /media-gfx
parentVersion bump for Gnome 3.12. (diff)
downloadgentoo-2-71f6b2a4e6a6834c3200350c68ba1a990110c71a.tar.gz
gentoo-2-71f6b2a4e6a6834c3200350c68ba1a990110c71a.tar.bz2
gentoo-2-71f6b2a4e6a6834c3200350c68ba1a990110c71a.zip
Version bump for Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/eog-plugins/ChangeLog8
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.12.1.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/media-gfx/eog-plugins/ChangeLog b/media-gfx/eog-plugins/ChangeLog
index 6834a8f4fc78..4de93dfc5280 100644
--- a/media-gfx/eog-plugins/ChangeLog
+++ b/media-gfx/eog-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/eog-plugins
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog-plugins/ChangeLog,v 1.15 2014/04/18 11:00:46 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog-plugins/ChangeLog,v 1.16 2014/04/27 17:27:45 eva Exp $
+
+*eog-plugins-3.12.1 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org>
+ +eog-plugins-3.12.1.ebuild:
+ Version bump for Gnome 3.12.
18 Apr 2014; Pacho Ramos <pacho@gentoo.org> -eog-plugins-3.8.1.ebuild:
Drop old
diff --git a/media-gfx/eog-plugins/eog-plugins-3.12.1.ebuild b/media-gfx/eog-plugins/eog-plugins-3.12.1.ebuild
new file mode 100644
index 000000000000..02f1f2d9e699
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.12.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog-plugins/eog-plugins-3.12.1.ebuild,v 1.1 2014/04/27 17:27:45 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_2,3_3} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://live.gnome.org/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+exif +flickr map +picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.11.4
+ >=x11-libs/gtk+-3.3.8:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ flickr? ( media-gfx/postr )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/libpeas:=[gtk,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use flickr && plugins="${plugins},postr"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder"
+ gnome2_src_configure \
+ $(use_enable python) \
+ --with-plugins=${plugins}
+}