summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2008-05-11 13:07:08 +0000
committerMarkus Meier <maekke@gentoo.org>2008-05-11 13:07:08 +0000
commit73c97707ef9a7101169276056a62a104b51945c0 (patch)
tree04d5141ca7563063f44fa1a370bab0690f4f5102 /media-gfx
parentamd64 stable - 220849 (diff)
downloadgentoo-2-73c97707ef9a7101169276056a62a104b51945c0.tar.gz
gentoo-2-73c97707ef9a7101169276056a62a104b51945c0.tar.bz2
gentoo-2-73c97707ef9a7101169276056a62a104b51945c0.zip
old
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/blender/ChangeLog5
-rw-r--r--media-gfx/blender/blender-2.43.ebuild132
2 files changed, 4 insertions, 133 deletions
diff --git a/media-gfx/blender/ChangeLog b/media-gfx/blender/ChangeLog
index 9b7faa6baae5..22e589d42fb4 100644
--- a/media-gfx/blender/ChangeLog
+++ b/media-gfx/blender/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/blender
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/ChangeLog,v 1.139 2008/05/11 12:10:00 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/ChangeLog,v 1.140 2008/05/11 13:07:08 maekke Exp $
+
+ 11 May 2008; Markus Meier <maekke@gentoo.org> -blender-2.43.ebuild:
+ old
11 May 2008; Tobias Scherbaum <dertobi123@gentoo.org>
blender-2.43-r2.ebuild:
diff --git a/media-gfx/blender/blender-2.43.ebuild b/media-gfx/blender/blender-2.43.ebuild
deleted file mode 100644
index 550217919766..000000000000
--- a/media-gfx/blender/blender-2.43.ebuild
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.43.ebuild,v 1.12 2008/04/07 21:58:02 yngwin Exp $
-
-inherit multilib flag-o-matic eutils python
-
-#IUSE="jpeg mozilla png sdl static truetype"
-IUSE="blender-game ffmpeg jpeg nls openal openexr png"
-FFMPEG_SNAP="0.4.9-p20070330"
-DESCRIPTION="3D Creation/Animation/Publishing System"
-HOMEPAGE="http://www.blender.org/"
-SRC_URI="http://download.blender.org/source/${P}.tar.gz
- ffmpeg? ( mirror://gentoo/ffmpeg-${FFMPEG_SNAP}.tar.bz2 )"
-
-SLOT="0"
-LICENSE="|| ( GPL-2 BL )"
-KEYWORDS="~amd64 ppc ppc64 ~sparc x86"
-
-RDEPEND=">=dev-libs/openssl-0.9.6
- ffmpeg? ( >=media-video/ffmpeg-${FFMPEG_SNAP/-/_}
- media-libs/x264 )
- jpeg? ( media-libs/jpeg )
- media-libs/tiff
- nls? ( >=media-libs/freetype-2.0
- virtual/libintl
- >=media-libs/ftgl-2.1 )
- openal? ( media-libs/openal
- media-libs/freealut )
- openexr? ( media-libs/openexr )
- png? ( media-libs/libpng )
- >=media-libs/libsdl-1.2
- virtual/opengl"
-
-DEPEND="dev-util/scons
- x11-libs/libXt
- x11-proto/inputproto
- ${RDEPEND}"
-
-blend_with() {
- local UWORD="$2"
- if [ -z "${UWORD}" ]; then
- UWORD="$1"
- fi
- if useq $1; then
- echo "WITH_BF_${UWORD}=1" | tr '[:lower:]' '[:upper:]' \
- >> "${S}"/user-config.py
- else
- echo "WITH_BF_${UWORD}=0" | tr '[:lower:]' '[:upper:]' \
- >> "${S}"/user-config.py
- fi
- return 0
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"/release/plugins
- chmod 755 bmake
- rmdir include
- cp -pPR "${S}"/source/blender/blenpluginapi include
-
- cd "${S}"
- epatch "${FILESDIR}"/blender-2.37-dirs.patch
-
- if use ffmpeg ; then
- cd "${S}"/extern
- mv ffmpeg/Makefile ffmpeg/common.mak "${T}"
- unpack ffmpeg-${FFMPEG_SNAP}.tar.bz2
- mv "${T}"/Makefile "${T}"/common.mak ffmpeg
- fi
- # pass compiler flags to the scons build system
- echo "CFLAGS += '${CFLAGS}'" >> "${S}"/user-config.py
- echo "CCFLAGS += ['${CXXFLAGS//' '/','}','-DYESIAMSTUPID']" \
- >> "${S}"/user-config.py
- # disable blender-player and iconv
- # echo "WITH_BF_PLAYER=0" >> ${S}/user-config.py
- # echo "WITH_BF_ICONV=0" >> ${S}/user-config.py
-}
-
-src_compile() {
- myconf="${myconf} $(blend_with openal)"
- myconf="${myconf} $(blend_with openexr)"
- myconf="${myconf} $(blend_with jpeg)"
- myconf="${myconf} $(blend_with ffmpeg)"
- myconf="${myconf} $(blend_with png)"
- myconf="${myconf} $(blend_with nls international)"
- myconf="${myconf} $(blend_with blender-game gameengine)"
-
- # scons uses -l differently -> remove it
- scons ${MAKEOPTS/-l[0-9]} -h > scons.config
- scons ${MAKEOPTS/-l[0-9]} || die \
- "!!! Please add ${S}/scons.config when filing bugs reports to bugs.gentoo.org"
-
- cd "${S}"/release/plugins
- emake || die
-}
-
-src_install() {
- exeinto /usr/bin/
- doexe "${WORKDIR}"/install/linux2/blender
-
- dodir /usr/share/${PN}
-
- exeinto /usr/$(get_libdir)/${PN}/textures
- doexe "${S}"/release/plugins/texture/*.so
- exeinto /usr/$(get_libdir)/${PN}/sequences
- doexe "${S}"/release/plugins/sequence/*.so
- insinto /usr/include/${PN}
- doins "${S}"/release/plugins/include/*.h
-
- if use nls ; then
- mv "${WORKDIR}"/install/linux2/.blender/{.Blanguages,.bfont.ttf} \
- "${D}"/usr/share/${PN}
- mv "${WORKDIR}"/install/linux2/.blender/locale \
- "${D}"/usr/share/locale
- fi
-
- mv "${WORKDIR}"/install/linux2/.blender/scripts "${D}"/usr/share/${PN}
-
- insinto /usr/share/pixmaps
- doins "${FILESDIR}"/${PN}.png
- insinto /usr/share/applications
- doins "${FILESDIR}"/${PN}.desktop
-
- dodoc INSTALL README
-}
-
-pkg_preinst(){
- if [ -h "${ROOT}/usr/$(get_libdir)/blender/plugins/include" ];
- then
- rm -f "${ROOT}"/usr/$(get_libdir)/blender/plugins/include
- fi
-}