summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-04-19 14:44:48 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-04-19 14:44:48 +0000
commitaeaceb9d1a940874125dc1e5da5eb02e11483f14 (patch)
treee4b939a39837a5e9308f2782c37ec8759bbeee07 /media-gfx
parentDepend only on python2. (diff)
downloadgentoo-2-aeaceb9d1a940874125dc1e5da5eb02e11483f14.tar.gz
gentoo-2-aeaceb9d1a940874125dc1e5da5eb02e11483f14.tar.bz2
gentoo-2-aeaceb9d1a940874125dc1e5da5eb02e11483f14.zip
Disable static qt plugins wrt bug #311343
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/wally/ChangeLog6
-rw-r--r--media-gfx/wally/files/wally-2.3.2-disable-plugins.patch23
-rw-r--r--media-gfx/wally/wally-2.3.2.ebuild12
3 files changed, 38 insertions, 3 deletions
diff --git a/media-gfx/wally/ChangeLog b/media-gfx/wally/ChangeLog
index 9f58324ce8ff..52478bc78bc2 100644
--- a/media-gfx/wally/ChangeLog
+++ b/media-gfx/wally/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/wally
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/ChangeLog,v 1.24 2010/03/23 19:09:53 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/ChangeLog,v 1.25 2010/04/19 14:44:48 hwoarang Exp $
+
+ 19 Apr 2010; Markos Chandras <hwoarang@gentoo.org> wally-2.3.2.ebuild,
+ +files/wally-2.3.2-disable-plugins.patch:
+ Disable static qt plugins wrt bug #311343
*wally-2.3.2 (23 Mar 2010)
diff --git a/media-gfx/wally/files/wally-2.3.2-disable-plugins.patch b/media-gfx/wally/files/wally-2.3.2-disable-plugins.patch
new file mode 100644
index 000000000000..a187a93650b5
--- /dev/null
+++ b/media-gfx/wally/files/wally-2.3.2-disable-plugins.patch
@@ -0,0 +1,23 @@
+Index: wally-2.3.2/src/main.cpp
+===================================================================
+--- wally-2.3.2.orig/src/main.cpp
++++ wally-2.3.2/src/main.cpp
+@@ -17,18 +17,6 @@
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+ */
+
+-#if (!defined(QT_SHARED)) && (!defined(QT_DLL))
+- #include <QtPlugin>
+-
+- Q_IMPORT_PLUGIN(qgif)
+- Q_IMPORT_PLUGIN(qico)
+- Q_IMPORT_PLUGIN(qjpeg)
+- Q_IMPORT_PLUGIN(qmng)
+- Q_IMPORT_PLUGIN(qsvg)
+- Q_IMPORT_PLUGIN(qtiff)
+- Q_IMPORT_PLUGIN(qsqlite)
+-#endif
+-
+ #include <QTimer>
+ #include <QMessageBox>
+
diff --git a/media-gfx/wally/wally-2.3.2.ebuild b/media-gfx/wally/wally-2.3.2.ebuild
index b50ff0ba9eb1..e2da5672f6e8 100644
--- a/media-gfx/wally/wally-2.3.2.ebuild
+++ b/media-gfx/wally/wally-2.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/wally-2.3.2.ebuild,v 1.2 2010/03/23 20:35:11 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/wally-2.3.2.ebuild,v 1.3 2010/04/19 14:44:48 hwoarang Exp $
EAPI="2"
KDE_REQUIRED="optional"
@@ -20,13 +20,21 @@ DEPEND="media-libs/libexif
kde? ( >=kde-base/kdelibs-4.2.0 )"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-2.2.0-disable_popup.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-2.2.0-disable_popup.patch"
+ "${FILESDIR}/${P}-disable-plugins.patch"
+)
src_prepare() {
kde4-base_src_prepare
use kde || epatch "${FILESDIR}/${PN}-2.2.0-disable-kde4.patch"
}
+src_configure() {
+ mycmakeargs="${mycmakeargs} -DSTATIC=FALSE"
+ cmake-utils_src_configure
+}
+
src_install() {
cmake-utils_src_install
newicon "${S}"/res/images/idle.png wally.png || die