summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-20 12:54:22 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-20 12:54:22 +0000
commitd30671fd231aa67352c9d87366d506799ad22b1c (patch)
tree411c3e29c35e875882d6951a663fd3f50d8b0c77 /media-gfx
parentFixed SRC_URI. Closes #27946. (diff)
downloadgentoo-2-d30671fd231aa67352c9d87366d506799ad22b1c.tar.gz
gentoo-2-d30671fd231aa67352c9d87366d506799ad22b1c.tar.bz2
gentoo-2-d30671fd231aa67352c9d87366d506799ad22b1c.zip
revamped and test symlink generation to be a bit smarter
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gimp/ChangeLog5
-rw-r--r--media-gfx/gimp/Manifest4
-rw-r--r--media-gfx/gimp/gimp-1.3.20.ebuild16
3 files changed, 17 insertions, 8 deletions
diff --git a/media-gfx/gimp/ChangeLog b/media-gfx/gimp/ChangeLog
index ae298c14d33e..099d9abe6181 100644
--- a/media-gfx/gimp/ChangeLog
+++ b/media-gfx/gimp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/gimp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.52 2003/09/20 08:47:55 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.53 2003/09/20 12:54:15 liquidx Exp $
+
+ 20 Sep 2003; Alastair Tse <liquidx@gentoo.org> gimp-1.3.20.ebuild:
+ added more intelligent symlink generation
*gimp-1.3.20 (20 Sep 2003)
diff --git a/media-gfx/gimp/Manifest b/media-gfx/gimp/Manifest
index f1afca14af69..28306df5f913 100644
--- a/media-gfx/gimp/Manifest
+++ b/media-gfx/gimp/Manifest
@@ -1,9 +1,9 @@
-MD5 ee82130ecd24e2c563151eca5179e919 ChangeLog 8451
+MD5 bcbde86834c64358a3cb69e735dadc20 ChangeLog 8565
MD5 d410d062966d05248f9c4251bd81d3af gimp-1.2.3-r3.ebuild 4707
MD5 3d28dd0ccc739e10db388438d4f06dda gimp-1.2.4.ebuild 3086
MD5 d235271944c1076aa7edb1726b79fecd gimp-1.2.5.ebuild 3253
MD5 75ad0c3088982ebf00bc3d06d2f47602 gimp-1.3.19.ebuild 2400
-MD5 6935b9038788de012413bfed8f1f2e8e gimp-1.3.20.ebuild 2793
+MD5 8723d0d0ea3d7ecfc6aebce1a13d91a4 gimp-1.3.20.ebuild 3218
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 86617fa03849f2ba22c845a31ddf8958 files/digest-gimp-1.2.3-r3 65
MD5 86551dc2402aaed28ccf3612e8fe7b7a files/digest-gimp-1.2.4 65
diff --git a/media-gfx/gimp/gimp-1.3.20.ebuild b/media-gfx/gimp/gimp-1.3.20.ebuild
index c068d476baeb..644c047643b0 100644
--- a/media-gfx/gimp/gimp-1.3.20.ebuild
+++ b/media-gfx/gimp/gimp-1.3.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.20.ebuild,v 1.2 2003/09/20 08:57:04 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.20.ebuild,v 1.3 2003/09/20 12:54:15 liquidx Exp $
IUSE="doc python aalib png jpeg tiff gtkhtml mmx sse X"
@@ -91,10 +91,16 @@ src_install() {
rm ${D}/usr/share/gimp/1.3/misc/gimp-1.3.desktop
mv ${D}/usr/share/gimp/1.3/misc/gimp.desktop ${D}/usr/share/applications/gimp-1.3.desktop
- # create temporary libtool workaround links
- for x in libgimp libgimpwidgets libgimpbase libgimpcolor; do
- dosym /usr/lib/${x}-1.3.so.20 /usr/lib/${x}-1.3.so.19
- done
+ # HACK! create temporary libtool workaround links - liquidx
+ # Finds out if the installed version number and sees if its the same
+ # as the one being merged. If not, then we create the symlinks.
+ OLD_V=$(find ${ROOT}/usr/lib -maxdepth 1 -name libgimp-1.3.so.*.0.0 | sort | head -n 1 | sed -e 's:.*libgimp-1\.3\.so\.\([0-9]*\)\.0\.0:\1:')
+ if [ ! -f "${D}/usr/lib/libgimp-1.3.so.${OLD_V}.0.0" ]; then
+ einfo "Making symlinks from 1.3.${OLD_V} to 1.3.20"
+ for x in libgimp libgimpwidgets libgimpbase libgimpcolor; do
+ dosym /usr/lib/${x}-1.3.so.20 /usr/lib/${x}-1.3.so.${OLD_V}
+ done
+ fi
}
pkg_postinst() {