summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-06 18:59:59 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-06 18:59:59 +0000
commit2bf53238e1acc9b465c2cebd9ef58e7fdedda5c6 (patch)
tree8e49be44e6806006100e101781a2da8805611fb0 /media-libs/aalib
parentUpdate (diff)
downloadgentoo-2-2bf53238e1acc9b465c2cebd9ef58e7fdedda5c6.tar.gz
gentoo-2-2bf53238e1acc9b465c2cebd9ef58e7fdedda5c6.tar.bz2
gentoo-2-2bf53238e1acc9b465c2cebd9ef58e7fdedda5c6.zip
Update
Diffstat (limited to 'media-libs/aalib')
-rw-r--r--media-libs/aalib/aalib-1.4_rc4.ebuild61
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc4-gentoo.diff39
-rw-r--r--media-libs/aalib/files/digest-aalib-1.4_rc41
3 files changed, 101 insertions, 0 deletions
diff --git a/media-libs/aalib/aalib-1.4_rc4.ebuild b/media-libs/aalib/aalib-1.4_rc4.ebuild
new file mode 100644
index 000000000000..d25208dcade5
--- /dev/null
+++ b/media-libs/aalib/aalib-1.4_rc4.ebuild
@@ -0,0 +1,61 @@
+## Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/aalib/aalib-1.4_rc4.ebuild,v 1.1 2001/05/06 18:59:59 achim Exp $
+
+A=${PN}-1.4rc4.tar.gz
+S=${WORKDIR}/${PN}-1.4.0
+DESCRIPTION="A ASCI-Graphics Library"
+SRC_URI="http://prdownloads.sourceforge.net/aa-project/${A}"
+HOMEPAGE="http://www.ta.jcu.cz/aa/"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ slang? ( >=sys-libs/slang-1.4.2 )
+ X? ( virtual/x11 )"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ slang? ( >=sys-libs/slang-1.4.2 )
+ X? ( virtual/x11 )"
+
+src_unpack() {
+
+ unpack ${A}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ touch *
+}
+
+src_compile() {
+
+ local myconf
+ if [ "`use slang`" ]
+ then
+ myconf="--with-slang-driver=yes"
+ else
+ myconf="--with-slang-driver=no"
+ fi
+ if [ "`use X`" ]
+ then
+ myconf="${myconf} --with-x11-driver=yes"
+ else
+ myconf="${myconf} --with-x11-driver=no"
+ fi
+ if [ -z "`use gpm`" ]
+ then
+ myconf="${myconf} --with-gpm-mouse=no"
+ fi
+
+ try ./configure --prefix=/usr --infodir=/usr/share/info \
+ --mandir=${D}/usr/share/man --host=${CHOST} ${myconf}
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man install
+
+ dodoc ANNOUNCE AUTHORS ChangeLog COPYING NEWS README*
+
+}
+
diff --git a/media-libs/aalib/files/aalib-1.4_rc4-gentoo.diff b/media-libs/aalib/files/aalib-1.4_rc4-gentoo.diff
new file mode 100644
index 000000000000..416f3d78d8a9
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc4-gentoo.diff
@@ -0,0 +1,39 @@
+--- aalib-1.4.0/configure.in~ Tue Apr 24 16:00:02 2001
++++ aalib-1.4.0/configure.in Sun May 6 20:37:32 2001
+@@ -83,10 +83,10 @@
+ fi
+ ])
+ AC_ARG_WITH(gpm-mouse,
+- [ --with-gpm-mouse=base-dir Specifies the base gpm directory],
+- if test x$withval = xyes
++ [ --with-gpm-mouse=base-dir/no Specifies the base gpm directory],
++ if test x$withval = xno
+ then
+- AC_MSG_WARN(Usage is: --with-gpm-mouse=base-dir)
++ gpm_mousedriver_test=no
+ else
+ LIBS="$LIBS -L$withval/lib -lgpm"
+ AC_DEFINE(GPM_MOUSEDRIVER)
+--- aalib-1.4.0/configure.orig Sun May 6 20:38:23 2001
++++ aalib-1.4.0/configure Sun May 6 20:38:26 2001
+@@ -28,7 +28,7 @@
+ ac_help="$ac_help
+ --with-curses-driver=no/yes Used to disable/force curses driver"
+ ac_help="$ac_help
+- --with-gpm-mouse=base-dir Specifies the base gpm directory"
++ --with-gpm-mouse=base-dir/no Specifies the base gpm directory"
+ ac_help="$ac_help
+ --with-x use the X Window System"
+ ac_help="$ac_help
+@@ -1960,9 +1960,9 @@
+ # Check whether --with-gpm-mouse or --without-gpm-mouse was given.
+ if test "${with_gpm_mouse+set}" = set; then
+ withval="$with_gpm_mouse"
+- if test x$withval = xyes
++ if test x$withval = xno
+ then
+- echo "configure: warning: Usage is: --with-gpm-mouse=base-dir" 1>&2
++ gpm_mousedriver_test=no
+ else
+ LIBS="$LIBS -L$withval/lib -lgpm"
+ cat >> confdefs.h <<\EOF
diff --git a/media-libs/aalib/files/digest-aalib-1.4_rc4 b/media-libs/aalib/files/digest-aalib-1.4_rc4
new file mode 100644
index 000000000000..0d063c8bd4ba
--- /dev/null
+++ b/media-libs/aalib/files/digest-aalib-1.4_rc4
@@ -0,0 +1 @@
+MD5 d5aa8e9eae07b7441298b5c30490f6a6 aalib-1.4rc4.tar.gz