summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-07-20 04:49:41 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-07-20 04:49:41 +0000
commit92cf7f86866320c4f07dbe75f5222329db54d6b4 (patch)
tree0be51463bb1dcd2811f8b6925ffb8da907a3cb00 /media-libs/aldumb/aldumb-0.9.2.ebuild
parentInitial revision. Closes part of #23464. (diff)
downloadgentoo-2-92cf7f86866320c4f07dbe75f5222329db54d6b4.tar.gz
gentoo-2-92cf7f86866320c4f07dbe75f5222329db54d6b4.tar.bz2
gentoo-2-92cf7f86866320c4f07dbe75f5222329db54d6b4.zip
Initial revision. Closes part of #23464.
Diffstat (limited to 'media-libs/aldumb/aldumb-0.9.2.ebuild')
-rw-r--r--media-libs/aldumb/aldumb-0.9.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/aldumb/aldumb-0.9.2.ebuild b/media-libs/aldumb/aldumb-0.9.2.ebuild
new file mode 100644
index 000000000000..64411a8bf01a
--- /dev/null
+++ b/media-libs/aldumb/aldumb-0.9.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/aldumb/aldumb-0.9.2.ebuild,v 1.1 2003/07/20 04:49:33 jje Exp $
+
+DESCRIPTION="Allegro support for DUMB. See the 'dumb' package's description for details."
+SRC_URI="mirror://sourceforge/dumb/dumb-${PV}-fixed.tar.gz"
+HOMEPAGE="http://dumb.sourceforge.net/"
+
+LICENSE="DUMB-0.9.2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND="=media-libs/dumb-0.9.2-r1
+ media-libs/allegro"
+
+S=${WORKDIR}/dumb
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch Makefile < ${FILESDIR}/aldumb-0.9.2.Makefile.patch || die
+}
+
+src_compile() {
+ echo 'include make/unix.inc' > make/config.txt || die
+ echo 'ALL_TARGETS := allegro allegro-examples allegro-headers' >> make/config.txt || die
+ echo 'PREFIX := /usr' >> make/config.txt || die
+ emake OFLAGS="${CFLAGS}" all || die
+}
+
+src_install() {
+ dodir /usr/lib /usr/include /usr/bin
+ make install PREFIX=${D}/usr || die
+}
+