summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-03 23:54:18 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-03 23:54:18 +0000
commit3133dd84cc273bbc1f127f99bb899eb19408cc47 (patch)
tree671dcd1c33a9eefb2cfbae4e4c2ffb0914267e33 /media-libs/allegro
parentBump version to 1.3.5 (Manifest recommit) (diff)
downloadgentoo-2-3133dd84cc273bbc1f127f99bb899eb19408cc47.tar.gz
gentoo-2-3133dd84cc273bbc1f127f99bb899eb19408cc47.tar.bz2
gentoo-2-3133dd84cc273bbc1f127f99bb899eb19408cc47.zip
clean it up BAM
Diffstat (limited to 'media-libs/allegro')
-rw-r--r--media-libs/allegro/allegro-4.0.3.ebuild10
-rw-r--r--media-libs/allegro/allegro-4.1.11.ebuild14
-rw-r--r--media-libs/allegro/allegro-4.1.12.ebuild16
3 files changed, 20 insertions, 20 deletions
diff --git a/media-libs/allegro/allegro-4.0.3.ebuild b/media-libs/allegro/allegro-4.0.3.ebuild
index a933f39f846a..7bdb8b2b5cfa 100644
--- a/media-libs/allegro/allegro-4.0.3.ebuild
+++ b/media-libs/allegro/allegro-4.0.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.0.3.ebuild,v 1.7 2004/03/19 07:56:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.0.3.ebuild,v 1.8 2004/06/03 23:54:18 vapier Exp $
inherit flag-o-matic
DESCRIPTION="cross-platform multimedia library"
-SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
HOMEPAGE="http://alleg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
LICENSE="Allegro"
SLOT="0"
@@ -53,9 +53,9 @@ src_compile() {
cp makefile{,.orig}
sed -e "/CFLAGS =.*/s:$: ${CFLAGS}:" \
makefile.orig > makefile
- make || die # emake fails
+ emake -j1 || die # parallel fails
- if [ `use tetex` ] ; then
+ if use tetex ; then
addwrite /var/lib/texmf
addwrite /usr/share/texmf
addwrite /var/cache/fonts
@@ -69,7 +69,7 @@ src_install() {
# Different format versions of the Allegro documentation
dodoc AUTHORS CHANGES THANKS readme.txt todo.txt
- [ `use tetex` ] && dodoc docs/allegro.{dvi,ps}
+ use tetex && dodoc docs/allegro.{dvi,ps}
dohtml docs/html/*
docinto txt ; dodoc docs/txt/*.txt
docinto rtf ; dodoc docs/rtf/*.rtf
diff --git a/media-libs/allegro/allegro-4.1.11.ebuild b/media-libs/allegro/allegro-4.1.11.ebuild
index 32e0b68fbeaa..c6028d400537 100644
--- a/media-libs/allegro/allegro-4.1.11.ebuild
+++ b/media-libs/allegro/allegro-4.1.11.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.1.11.ebuild,v 1.5 2004/03/19 07:56:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.1.11.ebuild,v 1.6 2004/06/03 23:54:18 vapier Exp $
inherit flag-o-matic
DESCRIPTION="cross-platform multimedia library"
-SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
HOMEPAGE="http://alleg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
LICENSE="Allegro"
SLOT="0"
@@ -25,8 +25,8 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd ${S}
- sed -i '/TARGET_ARCH=/s:=.*:=:' ${S}/configure || \
- die 'couldnt remove pentium cpu'
+ sed -i '/TARGET_ARCH=/s:=.*:=:' \
+ configure || die 'couldnt remove pentium cpu'
}
src_compile() {
@@ -56,9 +56,9 @@ src_compile() {
sed -i \
-e "/CFLAGS =.*/s:$: ${CFLAGS}:" \
makefile || die "sed makefile failed"
- make || die # emake fails
+ emake -j1 || die # parallel fails
- if [ `use tetex` ] ; then
+ if use tetex ; then
addwrite /var/lib/texmf
addwrite /usr/share/texmf
addwrite /var/cache/fonts
@@ -72,7 +72,7 @@ src_install() {
# Different format versions of the Allegro documentation
dodoc AUTHORS CHANGES THANKS readme.txt todo.txt
- [ `use tetex` ] && dodoc docs/allegro.{dvi,ps}
+ use tetex && dodoc docs/allegro.{dvi,ps}
dohtml docs/html/*
docinto txt ; dodoc docs/txt/*.txt
docinto rtf ; dodoc docs/rtf/*.rtf
diff --git a/media-libs/allegro/allegro-4.1.12.ebuild b/media-libs/allegro/allegro-4.1.12.ebuild
index c3d47516f366..7f9789339883 100644
--- a/media-libs/allegro/allegro-4.1.12.ebuild
+++ b/media-libs/allegro/allegro-4.1.12.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.1.12.ebuild,v 1.2 2004/03/19 17:47:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.1.12.ebuild,v 1.3 2004/06/03 23:54:18 vapier Exp $
inherit flag-o-matic
DESCRIPTION="cross-platform multimedia library"
-SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
HOMEPAGE="http://alleg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
LICENSE="Allegro"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~ia64"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~ia64"
IUSE="static mmx sse oss alsa esd arts X fbcon svga tetex"
RDEPEND="alsa? ( media-libs/alsa-lib )
@@ -25,8 +25,8 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd ${S}
- sed -i '/TARGET_ARCH=/s:=.*:=:' ${S}/configure || \
- die 'couldnt remove pentium cpu'
+ sed -i '/TARGET_ARCH=/s:=.*:=:' configure \
+ || die 'couldnt remove pentium cpu'
}
src_compile() {
@@ -56,9 +56,9 @@ src_compile() {
sed -i \
-e "/CFLAGS =.*/s:$: ${CFLAGS}:" \
makefile || die "sed makefile failed"
- make || die # emake fails
+ emake -j1 || die # parallel fails
- if [ `use tetex` ] ; then
+ if use tetex ; then
addwrite /var/lib/texmf
addwrite /usr/share/texmf
addwrite /var/cache/fonts
@@ -72,7 +72,7 @@ src_install() {
# Different format versions of the Allegro documentation
dodoc AUTHORS CHANGES THANKS readme.txt todo.txt
- [ `use tetex` ] && dodoc docs/allegro.{dvi,ps}
+ use tetex && dodoc docs/allegro.{dvi,ps}
dohtml docs/html/*
docinto txt ; dodoc docs/txt/*.txt
docinto rtf ; dodoc docs/rtf/*.rtf