summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-11-19 14:47:42 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-11-19 14:47:42 +0000
commit34c21d067e062c98371da4bec7753039547a961f (patch)
tree71ec7f0704f0305e35341651a42001505b22f104 /media-libs/atlas-c++
parentVersion bump, add build dep on net-misc/curl (bug #241222). (diff)
downloadgentoo-2-34c21d067e062c98371da4bec7753039547a961f.tar.gz
gentoo-2-34c21d067e062c98371da4bec7753039547a961f.tar.bz2
gentoo-2-34c21d067e062c98371da4bec7753039547a961f.zip
Fix building cyphesis with --as-needed as from bug #247463
(Portage version: 2.1.4.5)
Diffstat (limited to 'media-libs/atlas-c++')
-rw-r--r--media-libs/atlas-c++/ChangeLog9
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild49
-rw-r--r--media-libs/atlas-c++/files/atlas-c++-0.6.1-as-needed.patch11
3 files changed, 68 insertions, 1 deletions
diff --git a/media-libs/atlas-c++/ChangeLog b/media-libs/atlas-c++/ChangeLog
index 795870a3d6a1..7775270c8047 100644
--- a/media-libs/atlas-c++/ChangeLog
+++ b/media-libs/atlas-c++/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/atlas-c++
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.25 2008/08/20 18:52:45 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.26 2008/11/19 14:47:42 tupone Exp $
+
+*atlas-c++-0.6.1-r1 (19 Nov 2008)
+
+ 19 Nov 2008; <alfredo@gentoo.org> +files/atlas-c++-0.6.1-as-needed.patch,
+ +atlas-c++-0.6.1-r1.ebuild:
+ Fix building cyphesis with --as-needed as from bug #247463 by
+ <flameeyes@gentoo.org>
20 Aug 2008; Markus Meier <maekke@gentoo.org> atlas-c++-0.6.1.ebuild:
amd64/x86 stable, bug #235169
diff --git a/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild b/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..2bf8140638e5
--- /dev/null
+++ b/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild,v 1.1 2008/11/19 14:47:42 tupone Exp $
+
+inherit eutils autotools
+
+MY_PN="Atlas-C++"
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Atlas protocol, used in role playing games at worldforge."
+HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/atlas_cpp"
+SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="bzip2 doc zlib"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-strict-aliasing.patch \
+ "${FILESDIR}"/${P}-gcc-4.3.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable zlib) \
+ $(use_enable bzip2 bzlib) \
+ || die "Error: econf failed!"
+ emake || die "Error: emake failed!"
+ if use doc; then
+ emake docs || die "Error: emake failed!"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ use doc && dohtml -r doc/html/*
+ use doc && doman doc/man/*
+ dodoc AUTHORS ChangeLog HACKING NEWS README ROADMAP THANKS TODO
+}
diff --git a/media-libs/atlas-c++/files/atlas-c++-0.6.1-as-needed.patch b/media-libs/atlas-c++/files/atlas-c++-0.6.1-as-needed.patch
new file mode 100644
index 000000000000..2c7e7a180ce7
--- /dev/null
+++ b/media-libs/atlas-c++/files/atlas-c++-0.6.1-as-needed.patch
@@ -0,0 +1,11 @@
+--- Atlas/Net/Makefile.am.old 2008-11-19 15:29:19.000000000 +0100
++++ Atlas/Net/Makefile.am 2008-11-19 15:30:04.000000000 +0100
+@@ -5,6 +5,8 @@
+
+ libAtlasNet_0_6_la_LDFLAGS = $(INTERFACE_VERSION)
+
++libAtlasNet_0_6_la_LIBADD = ../Codecs/libAtlasCodecs-0.6.la
++
+ libAtlasNetincludedir = $(includedir)/Atlas-C++-0.6/Atlas/Net
+
+ libAtlasNet_0_6_la_SOURCES = \