summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-02-07 02:31:51 +0000
committerTim Harder <radhermit@gentoo.org>2013-02-07 02:31:51 +0000
commit2e9a3cd2ac37ed2fbe4b7e3d91584df3f51a4993 (patch)
treed5d0ff572dca73c73233267e022ed472e0b45770 /media-libs/audiofile/audiofile-0.3.5.ebuild
parentRemove one more unneeded locale file/directory. (diff)
downloadgentoo-2-2e9a3cd2ac37ed2fbe4b7e3d91584df3f51a4993.tar.gz
gentoo-2-2e9a3cd2ac37ed2fbe4b7e3d91584df3f51a4993.tar.bz2
gentoo-2-2e9a3cd2ac37ed2fbe4b7e3d91584df3f51a4993.zip
Version bump. Update to EAPI 5, add subslot, and use system gtest for tests.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-libs/audiofile/audiofile-0.3.5.ebuild')
-rw-r--r--media-libs/audiofile/audiofile-0.3.5.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/audiofile/audiofile-0.3.5.ebuild b/media-libs/audiofile/audiofile-0.3.5.ebuild
new file mode 100644
index 000000000000..d85add4f75e5
--- /dev/null
+++ b/media-libs/audiofile/audiofile-0.3.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/audiofile/audiofile-0.3.5.ebuild,v 1.1 2013/02/07 02:31:51 radhermit Exp $
+
+EAPI=5
+
+inherit autotools eutils gnome.org
+
+DESCRIPTION="An elegant API for accessing audio files"
+HOMEPAGE="http://www.68k.org/~michael/audiofile/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0/1" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="static-libs test"
+
+DEPEND="test? ( dev-cpp/gtest )"
+
+DOCS=( ACKNOWLEDGEMENTS AUTHORS ChangeLog NEWS NOTES README TODO )
+
+src_prepare() {
+ # don't build examples
+ sed -i "/^SRC_SUBDIRS/s: examples::" Makefile.am || die
+
+ epatch "${FILESDIR}"/${P}-system-gtest.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ --enable-largefile
+}
+
+src_test() {
+ emake -C test check
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}