summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-11-08 11:11:52 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-11-08 11:11:52 +0000
commit413194b8d52143180d6a4331f2a5d3ae8317c57e (patch)
treeeb10b9909a77b2c5293ce0b53254226921519fef /media-libs/chromaprint
parentstable ppc ppc64, bug #435116 (diff)
downloadgentoo-2-413194b8d52143180d6a4331f2a5d3ae8317c57e.tar.gz
gentoo-2-413194b8d52143180d6a4331f2a5d3ae8317c57e.tar.bz2
gentoo-2-413194b8d52143180d6a4331f2a5d3ae8317c57e.zip
Add patch from pld-linux to build with latest ffmpeg releases. bug #435856
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/chromaprint')
-rw-r--r--media-libs/chromaprint/ChangeLog6
-rw-r--r--media-libs/chromaprint/chromaprint-0.7.ebuild6
-rw-r--r--media-libs/chromaprint/files/chromaprint-0.7-ffmpeg.patch43
3 files changed, 51 insertions, 4 deletions
diff --git a/media-libs/chromaprint/ChangeLog b/media-libs/chromaprint/ChangeLog
index 8f23738a8cba..98836ec95776 100644
--- a/media-libs/chromaprint/ChangeLog
+++ b/media-libs/chromaprint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/chromaprint
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/ChangeLog,v 1.4 2012/09/21 04:51:13 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/ChangeLog,v 1.5 2012/11/08 11:11:52 aballier Exp $
+
+ 08 Nov 2012; Alexis Ballier <aballier@gentoo.org> chromaprint-0.7.ebuild,
+ +files/chromaprint-0.7-ffmpeg.patch:
+ Add patch from pld-linux to build with latest ffmpeg releases. bug #435856
*chromaprint-0.7 (21 Sep 2012)
diff --git a/media-libs/chromaprint/chromaprint-0.7.ebuild b/media-libs/chromaprint/chromaprint-0.7.ebuild
index 00ab7426ae15..d71388cd1e8a 100644
--- a/media-libs/chromaprint/chromaprint-0.7.ebuild
+++ b/media-libs/chromaprint/chromaprint-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/chromaprint-0.7.ebuild,v 1.1 2012/09/21 04:51:13 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/chromaprint-0.7.ebuild,v 1.2 2012/11/08 11:11:52 aballier Exp $
EAPI=4
inherit cmake-utils
@@ -15,7 +15,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="test tools"
# note: use ffmpeg instead of fftw because it's recommended and required for tools
-RDEPEND=">=virtual/ffmpeg-0.6
+RDEPEND=">=virtual/ffmpeg-0.10
tools? ( >=media-libs/taglib-1.6 )"
DEPEND="${RDEPEND}
test? (
@@ -26,7 +26,7 @@ DEPEND="${RDEPEND}
DOCS="NEWS.txt README.txt"
-PATCHES=( "${FILESDIR}"/${P}-boost.patch )
+PATCHES=( "${FILESDIR}"/${P}-boost.patch "${FILESDIR}"/${P}-ffmpeg.patch )
src_configure() {
local mycmakeargs=(
diff --git a/media-libs/chromaprint/files/chromaprint-0.7-ffmpeg.patch b/media-libs/chromaprint/files/chromaprint-0.7-ffmpeg.patch
new file mode 100644
index 000000000000..f51e7794b6d8
--- /dev/null
+++ b/media-libs/chromaprint/files/chromaprint-0.7-ffmpeg.patch
@@ -0,0 +1,43 @@
+https://bugs.gentoo.org/show_bug.cgi?id=435856
+https://raw.github.com/pld-linux/chromaprint/master/chromaprint-ffmpeg.patch
+
+--- chromaprint-0.7/src/ext/ffmpeg_decoder.h.orig 2012-09-05 20:05:36.000000000 +0200
++++ chromaprint-0.7/src/ext/ffmpeg_decoder.h 2012-10-10 17:59:58.632685943 +0200
+@@ -80,7 +80,7 @@
+ avcodec_close(m_codec_ctx);
+ }
+ if (m_format_ctx) {
+- av_close_input_file(m_format_ctx);
++ avformat_close_input(&m_format_ctx);
+ }
+ //av_audio_convert_free(m_convert_ctx);
+ av_free(m_buffer2);
+@@ -89,12 +89,12 @@
+
+ inline bool Decoder::Open()
+ {
+- if (av_open_input_file(&m_format_ctx, m_file_name.c_str(), NULL, 0, NULL) != 0) {
++ if (avformat_open_input(&m_format_ctx, m_file_name.c_str(), NULL, NULL) != 0) {
+ m_error = "Couldn't open the file." + m_file_name;
+ return false;
+ }
+
+- if (av_find_stream_info(m_format_ctx) < 0) {
++ if (avformat_find_stream_info(m_format_ctx, NULL) < 0) {
+ m_error = "Couldn't find stream information in the file.";
+ return false;
+ }
+@@ -129,11 +129,11 @@
+ return false;
+ }
+
+- if (m_codec_ctx->sample_fmt != SAMPLE_FMT_S16) {
++ if (m_codec_ctx->sample_fmt != AV_SAMPLE_FMT_S16) {
+ m_error = "Unsupported sample format.\n";
+ return false;
+ }
+- /*m_convert_ctx = av_audio_convert_alloc(SAMPLE_FMT_S16, 1,
++ /*m_convert_ctx = av_audio_convert_alloc(AV_SAMPLE_FMT_S16, 1,
+ m_codec_ctx->sample_fmt, 1,
+ NULL, 0);
+ if (!m_convert_ctx) {