summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2005-07-12 14:17:20 +0000
committerJonathan Smith <smithj@gentoo.org>2005-07-12 14:17:20 +0000
commit20074f8ecf61512c72ed38dbd7b63b0d3fd720c6 (patch)
treea4ff018a1888c8c1b96ba264bdb69acc8b5f5f3c /media-libs/coin/coin-2.4.3.ebuild
parentAdded ia64 on request from plasmaroo. (diff)
downloadgentoo-2-20074f8ecf61512c72ed38dbd7b63b0d3fd720c6.tar.gz
gentoo-2-20074f8ecf61512c72ed38dbd7b63b0d3fd720c6.tar.bz2
gentoo-2-20074f8ecf61512c72ed38dbd7b63b0d3fd720c6.zip
#96661: version bump. this package needs a maintainer...
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-libs/coin/coin-2.4.3.ebuild')
-rw-r--r--media-libs/coin/coin-2.4.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/coin/coin-2.4.3.ebuild b/media-libs/coin/coin-2.4.3.ebuild
new file mode 100644
index 000000000000..d341fdf7efee
--- /dev/null
+++ b/media-libs/coin/coin-2.4.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/coin/coin-2.4.3.ebuild,v 1.1 2005/07/12 14:17:20 smithj Exp $
+
+MY_P=${P/c/C}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An OpenSource implementation of SGI's OpenInventor"
+HOMEPAGE="http://www.coin3d.org/"
+SRC_URI="ftp://ftp.coin3d.org/pub/coin/src/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="X"
+
+DEPEND="virtual/x11
+ virtual/opengl"
+
+src_compile() {
+ econf $(use_with X x) || die
+ emake || die
+}
+
+src_install() {
+ # Note that this is slightly different from einstall
+ make DESTDIR=${D} \
+ prefix=/usr \
+ datadir=/usr/share \
+ infodir=/usr/share/info \
+ localstatedir=/var/lib \
+ mandir=/usr/share/man \
+ sysconfdir=/etc \
+ install || die "make install failed"
+
+ dodoc AUTHORS BUGS.txt COPYING ChangeLog HACKING LICENSE* NEWS README* RELEASE RELNOTES THANKS
+ docinto txt
+ dodoc docs/*.txt
+}