summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-01-24 06:33:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-01-24 06:33:58 +0000
commitc68459e7c33181e0a89a460e5f59cb0d2e39a24a (patch)
tree812804afb486a9672c926dd3c02fc4a70b96b699 /media-libs/ctl
parentclenup old; fixed depend to latest tntnet/cxxtools (diff)
downloadgentoo-2-c68459e7c33181e0a89a460e5f59cb0d2e39a24a.tar.gz
gentoo-2-c68459e7c33181e0a89a460e5f59cb0d2e39a24a.tar.bz2
gentoo-2-c68459e7c33181e0a89a460e5f59cb0d2e39a24a.zip
Modernize the ebuild (eapi5, prune_libtool_files, and so forth)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/ctl')
-rw-r--r--media-libs/ctl/ChangeLog8
-rw-r--r--media-libs/ctl/ctl-1.4.1.ebuild19
2 files changed, 13 insertions, 14 deletions
diff --git a/media-libs/ctl/ChangeLog b/media-libs/ctl/ChangeLog
index 6bdf6dfbc63d..311610539a59 100644
--- a/media-libs/ctl/ChangeLog
+++ b/media-libs/ctl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/ctl
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ChangeLog,v 1.19 2013/03/03 06:03:04 dirtyepic Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ChangeLog,v 1.20 2014/01/24 06:33:58 ssuominen Exp $
+
+ 24 Jan 2014; Samuli Suominen <ssuominen@gentoo.org> ctl-1.4.1.ebuild:
+ Modernize the ebuild (eapi5, prune_libtool_files, and so forth)
03 Mar 2013; Ryan Hill <dirtyepic@gentoo.org> ctl-1.4.1.ebuild,
+files/ctl-1.4.1-gcc47.patch:
@@ -68,4 +71,3 @@
+ctl-1.4.0.ebuild:
Initial import, split of media-libs/openexr, thanks to : Arfrever Frehtes
Taifersar Arahesis <Arfrever.FTA@GMail.Com> for the ebuilds, bug #189798
-
diff --git a/media-libs/ctl/ctl-1.4.1.ebuild b/media-libs/ctl/ctl-1.4.1.ebuild
index cf037dee1c05..252888593d24 100644
--- a/media-libs/ctl/ctl-1.4.1.ebuild
+++ b/media-libs/ctl/ctl-1.4.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ctl-1.4.1.ebuild,v 1.14 2013/03/03 06:03:04 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ctl-1.4.1.ebuild,v 1.15 2014/01/24 06:33:58 ssuominen Exp $
-EAPI=2
+EAPI=5
inherit eutils libtool
DESCRIPTION="AMPAS' Color Transformation Language"
@@ -14,25 +14,22 @@ SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="static-libs"
-RDEPEND="media-libs/ilmbase"
+RDEPEND="media-libs/ilmbase:="
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch
- epatch "${FILESDIR}"/${P}-gcc47.patch
+ epatch "${FILESDIR}"/${P}-gcc4{3,7}.patch
elibtoolize
}
src_configure() {
- econf \
- --disable-dependency-tracking \
- $(use_enable static-libs static)
+ econf $(use_enable static-libs static)
}
src_install() {
- emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install || die
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
dodoc AUTHORS ChangeLog NEWS README
- find "${D}" -name '*.la' -exec rm -f '{}' +
+ prune_libtool_files --all
}