summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2013-04-10 21:34:51 +0000
committerThomas Sachau <tommy@gentoo.org>2013-04-10 21:34:51 +0000
commiteb885f5549e4f36e2a86f238bce2fa832e617195 (patch)
tree40dd6863a2ed2c58dd0a21f082944a3a38325cd4 /media-libs/emotion
parentVersion bump, drop old (diff)
downloadgentoo-2-eb885f5549e4f36e2a86f238bce2fa832e617195.tar.gz
gentoo-2-eb885f5549e4f36e2a86f238bce2fa832e617195.tar.bz2
gentoo-2-eb885f5549e4f36e2a86f238bce2fa832e617195.zip
Version bump, drop old
(Portage version: 2.2.0_alpha171-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
Diffstat (limited to 'media-libs/emotion')
-rw-r--r--media-libs/emotion/ChangeLog8
-rw-r--r--media-libs/emotion/emotion-1.7.6.ebuild (renamed from media-libs/emotion/emotion-1.7.4.ebuild)28
2 files changed, 23 insertions, 13 deletions
diff --git a/media-libs/emotion/ChangeLog b/media-libs/emotion/ChangeLog
index 5d7fb3698339..b251cef336a8 100644
--- a/media-libs/emotion/ChangeLog
+++ b/media-libs/emotion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/emotion
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/emotion/ChangeLog,v 1.11 2013/04/03 17:17:16 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/emotion/ChangeLog,v 1.12 2013/04/10 21:34:51 tommy Exp $
+
+*emotion-1.7.6 (10 Apr 2013)
+
+ 10 Apr 2013; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +emotion-1.7.6.ebuild, -emotion-1.7.4.ebuild:
+ Version bump, drop old
03 Apr 2013; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+files/respect-ldflags-with-gstreamer-backend.patch, emotion-1.7.4-r1.ebuild:
diff --git a/media-libs/emotion/emotion-1.7.4.ebuild b/media-libs/emotion/emotion-1.7.6.ebuild
index 4a7779a389f1..504b31dc3d09 100644
--- a/media-libs/emotion/emotion-1.7.4.ebuild
+++ b/media-libs/emotion/emotion-1.7.6.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/emotion/emotion-1.7.4.ebuild,v 1.2 2012/12/27 16:41:19 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/emotion/emotion-1.7.6.ebuild,v 1.1 2013/04/10 21:34:51 tommy Exp $
+
+EAPI=2
inherit enlightenment
@@ -9,14 +11,15 @@ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
LICENSE="BSD-2"
KEYWORDS="~amd64 ~x86"
-IUSE="gstreamer static-libs xine"
+IUSE="gstreamer static-libs vlc xine"
-DEPEND=">=media-libs/evas-1.7.0
- >=media-libs/edje-1.7.0
- >=dev-libs/ecore-1.7.0
- >=dev-libs/eeze-1.7.0
+DEPEND=">=media-libs/evas-1.7.6
+ >=media-libs/edje-1.7.6
+ >=dev-libs/ecore-1.7.6
+ >=dev-libs/eeze-1.7.4
+ vlc? ( media-video/vlc )
xine? ( >=media-libs/xine-lib-1.1.1 )
- !gstreamer? ( !xine? ( >=media-libs/xine-lib-1.1.1 ) )
+ !gstreamer? ( !vlc? ( !xine? ( >=media-libs/xine-lib-1.1.1 ) ) )
gstreamer? (
=media-libs/gstreamer-0.10*
=media-libs/gst-plugins-good-0.10*
@@ -24,13 +27,14 @@ DEPEND=">=media-libs/evas-1.7.0
)"
RDEPEND=${DEPEND}
-src_compile() {
- if ! use xine && ! use gstreamer ; then
- export MY_ECONF="--enable-xine --disable-gstreamer"
+src_configure() {
+ if ! use vlc && ! use xine && ! use gstreamer ; then
+ export MY_ECONF="--enable-xine --disable-gstreamer --disable-generic-vlc"
else
export MY_ECONF="
$(use_enable xine) \
$(use_enable gstreamer) \
+ $(use_enable vlc generic-vlc)
"
fi
@@ -43,5 +47,5 @@ src_compile() {
addpredict "/root/.gconf"
fi
- enlightenment_src_compile
+ enlightenment_src_configure
}