summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2013-12-26 20:01:21 +0000
committerFabian Groffen <grobian@gentoo.org>2013-12-26 20:01:21 +0000
commit8b2b4a1d037518c999a138f919378110a35cb512 (patch)
treef471ff29673dac95efa23499a564923f456005eb /media-libs/fontconfig
parentForcibly commit stage2 manifest, network blip caused failure. (diff)
downloadgentoo-2-8b2b4a1d037518c999a138f919378110a35cb512.tar.gz
gentoo-2-8b2b4a1d037518c999a138f919378110a35cb512.tar.bz2
gentoo-2-8b2b4a1d037518c999a138f919378110a35cb512.zip
Replace 2.11.0-solaris.patch by upstream commit, add 2.11.0-solaris10 patch from upstream to solve compilation problem due to missing mkdtemp on Solaris 10
(Portage version: 2.2.7-prefix/cvs/SunOS sparc, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'media-libs/fontconfig')
-rw-r--r--media-libs/fontconfig/ChangeLog9
-rw-r--r--media-libs/fontconfig/files/fontconfig-2.11.0-solaris.patch60
-rw-r--r--media-libs/fontconfig/files/fontconfig-2.11.0-solaris10.patch63
-rw-r--r--media-libs/fontconfig/fontconfig-2.11.0.ebuild5
4 files changed, 119 insertions, 18 deletions
diff --git a/media-libs/fontconfig/ChangeLog b/media-libs/fontconfig/ChangeLog
index 567d4cdeecf6..423a22251770 100644
--- a/media-libs/fontconfig/ChangeLog
+++ b/media-libs/fontconfig/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/fontconfig
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.188 2013/12/01 19:19:39 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.189 2013/12/26 20:01:21 grobian Exp $
+
+ 26 Dec 2013; Fabian Groffen <grobian@gentoo.org>
+ +files/fontconfig-2.11.0-solaris10.patch,
+ files/fontconfig-2.11.0-solaris.patch, fontconfig-2.11.0.ebuild:
+ Replace 2.11.0-solaris.patch by upstream commit, add 2.11.0-solaris10 patch
+ from upstream to solve compilation problem due to missing mkdtemp on Solaris
+ 10
01 Dec 2013; Fabian Groffen <grobian@gentoo.org>
+files/fontconfig-2.11.0-solaris.patch, fontconfig-2.11.0.ebuild:
diff --git a/media-libs/fontconfig/files/fontconfig-2.11.0-solaris.patch b/media-libs/fontconfig/files/fontconfig-2.11.0-solaris.patch
index c712c6f79286..a2c7a7640c66 100644
--- a/media-libs/fontconfig/files/fontconfig-2.11.0-solaris.patch
+++ b/media-libs/fontconfig/files/fontconfig-2.11.0-solaris.patch
@@ -1,27 +1,57 @@
-continuation of 4a741e9a0ab8dbaa0c377fbfed41547645ac79af
---- test/test-migration.c
-+++ test/test-migration.c
-@@ -33,6 +33,7 @@
- {
- DIR *d = opendir (dir);
- struct dirent *e;
-+ struct stat statb;
+ test/test-migration.c | 18 ++++++++++++++++++
+ 1 file changed, 18 insertions(+)
+
+New commits:
+commit 76ea9af816a50c6bb0b3dc2960460a90fadd9cdb
+Author: Akira TAGOH <akira@tagoh.org>
+Date: Tue Oct 22 15:00:29 2013 +0900
+
+ Use stat() if there are no d_type in struct dirent
+
+ Reported by Thomas Klausner
+
+diff --git a/test/test-migration.c b/test/test-migration.c
+index a0ab839..9709651 100644
+--- a/test/test-migration.c
++++ b/test/test-migration.c
+@@ -4,6 +4,11 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <dirent.h>
++#ifndef HAVE_STRUCT_DIRENT_D_TYPE
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <unistd.h>
++#endif
+ #include <fontconfig/fontconfig.h>
+
+ FcBool
+@@ -36,6 +41,9 @@ unlink_dirs(const char *dir)
size_t len = strlen (dir);
char *n = NULL;
FcBool ret = FcTrue;
-@@ -53,7 +54,13 @@
++#ifndef HAVE_STRUCT_DIRENT_D_TYPE
++ struct stat statb;
++#endif
+
+ if (!d)
+ return FcFalse;
+@@ -53,7 +61,17 @@ unlink_dirs(const char *dir)
strcpy (n, dir);
n[len] = '/';
strcpy (&n[len + 1], e->d_name);
-- if (e->d_type == DT_DIR)
-+ if (lstat (n, &statb) < 0)
++#ifdef HAVE_STRUCT_DIRENT_D_TYPE
+ if (e->d_type == DT_DIR)
++#else
++ if (stat (n, &statb) == -1)
+ {
-+ fprintf (stderr, "E: %s\n", n);
-+ ret = FcFalse;
-+ break;
++ fprintf (stderr, "E: %s\n", n);
++ ret = FcFalse;
++ break;
+ }
-+ if (S_ISDIR(statb.st_mode))
++ if (S_ISDIR (statb.st_mode))
++#endif
{
if (!unlink_dirs (n))
{
diff --git a/media-libs/fontconfig/files/fontconfig-2.11.0-solaris10.patch b/media-libs/fontconfig/files/fontconfig-2.11.0-solaris10.patch
new file mode 100644
index 000000000000..8ea47d4c646c
--- /dev/null
+++ b/media-libs/fontconfig/files/fontconfig-2.11.0-solaris10.patch
@@ -0,0 +1,63 @@
+
+ configure.ac | 2 +-
+ test/test-migration.c | 15 ++++++++++++++-
+ 2 files changed, 15 insertions(+), 2 deletions(-)
+
+New commits:
+commit 65872e9e46d17e4461c3a891ef23abe156005e04
+Author: Akira TAGOH <akira@tagoh.org>
+Date: Thu Oct 24 19:35:26 2013 +0900
+
+ Fix a build issue on Solaris 10
+
+ Use own mkdtemp implementation if not available.
+
+ Reported by Thomas Klausner and Jörn Clausen
+
+diff --git a/configure.ac b/configure.ac
+index c3743f4..4478914 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -148,7 +148,7 @@ AC_TYPE_PID_T
+ # Checks for library functions.
+ AC_FUNC_VPRINTF
+ AC_FUNC_MMAP
+-AC_CHECK_FUNCS([link mkstemp mkostemp _mktemp_s getopt getopt_long getprogname getexecname rand random lrand48 random_r rand_r regcomp regerror regexec regfree fstatvfs fstatfs lstat])
++AC_CHECK_FUNCS([link mkstemp mkostemp _mktemp_s mkdtemp getopt getopt_long getprogname getexecname rand random lrand48 random_r rand_r regcomp regerror regexec regfree fstatvfs fstatfs lstat])
+
+ dnl AC_CHECK_FUNCS doesn't check for header files.
+ dnl posix_fadvise() may be not available in older libc.
+diff --git a/test/test-migration.c b/test/test-migration.c
+index 9709651..f127e27 100644
+--- a/test/test-migration.c
++++ b/test/test-migration.c
+@@ -11,6 +11,19 @@
+ #endif
+ #include <fontconfig/fontconfig.h>
+
++#ifdef HAVE_MKDTEMP
++#define fc_mkdtemp mkdtemp
++#else
++char *
++fc_mkdtemp (char *template)
++{
++ if (!mktemp (template) || mkdir (template, 0700))
++ return NULL;
++
++ return template;
++}
++#endif
++
+ FcBool
+ mkdir_p(const char *dir)
+ {
+@@ -107,7 +120,7 @@ int
+ main(void)
+ {
+ char template[32] = "fontconfig-XXXXXXXX";
+- char *tmp = mkdtemp (template);
++ char *tmp = fc_mkdtemp (template);
+ size_t len = strlen (tmp), xlen, dlen;
+ char xdg[256], confd[256], fn[256], nfn[256], ud[256], nud[256];
+ int ret = -1;
+
diff --git a/media-libs/fontconfig/fontconfig-2.11.0.ebuild b/media-libs/fontconfig/fontconfig-2.11.0.ebuild
index 93f79b030461..a759c10fdb0d 100644
--- a/media-libs/fontconfig/fontconfig-2.11.0.ebuild
+++ b/media-libs/fontconfig/fontconfig-2.11.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.11.0.ebuild,v 1.2 2013/12/01 19:19:39 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.11.0.ebuild,v 1.3 2013/12/26 20:01:21 grobian Exp $
EAPI=5
AUTOTOOLS_AUTORECONF=yes
@@ -34,7 +34,8 @@ PDEPEND="!x86-winnt? ( app-admin/eselect-fontconfig )
PATCHES=(
"${FILESDIR}"/${PN}-2.7.1-latin-reorder.patch # 130466
"${FILESDIR}"/${PN}-2.10.2-docbook.patch # 310157
- "${FILESDIR}"/${PN}-2.11.0-solaris.patch
+ "${FILESDIR}"/${PN}-2.11.0-solaris.patch # from fc git
+ "${FILESDIR}"/${PN}-2.11.0-solaris10.patch # from fc git
)
pkg_setup() {