summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-12-21 15:14:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-12-21 15:14:54 +0000
commitce8c1f4928d3970576c208ba4dd6b545a7469821 (patch)
tree1ff095b4355c55b2beedad9c879a7b22a84e8896 /media-libs/gexiv2
parentNew package app-crypt/dieharder wrt bug 212674. Moved from Sunrise. (diff)
downloadgentoo-2-ce8c1f4928d3970576c208ba4dd6b545a7469821.tar.gz
gentoo-2-ce8c1f4928d3970576c208ba4dd6b545a7469821.tar.bz2
gentoo-2-ce8c1f4928d3970576c208ba4dd6b545a7469821.zip
Fix compability with exiv2 >= 0.21 API wrt #349150 by Alexandre Rostovtsev. Fix install with multilib-strict. Punt useless .la files. Don't call econf for custom ./configure script. Don't use gnome2.eclass anymore, it's only bringing in unused USE flags (like "debug").
(Portage version: 2.2.0_alpha9/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gexiv2')
-rw-r--r--media-libs/gexiv2/ChangeLog9
-rw-r--r--media-libs/gexiv2/files/gexiv2-0.2.1-new-exiv2.patch36
-rw-r--r--media-libs/gexiv2/gexiv2-0.2.1.ebuild23
3 files changed, 61 insertions, 7 deletions
diff --git a/media-libs/gexiv2/ChangeLog b/media-libs/gexiv2/ChangeLog
index 73ed585f4937..5d7b4675a8e5 100644
--- a/media-libs/gexiv2/ChangeLog
+++ b/media-libs/gexiv2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/gexiv2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/ChangeLog,v 1.2 2010/09/19 08:19:57 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/ChangeLog,v 1.3 2010/12/21 15:14:54 ssuominen Exp $
+
+ 21 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> gexiv2-0.2.1.ebuild,
+ +files/gexiv2-0.2.1-new-exiv2.patch:
+ Fix compability with exiv2 >= 0.21 API wrt #349150 by Alexandre Rostovtsev.
+ Fix install with multilib-strict. Punt useless .la files. Don't call econf
+ for custom ./configure script. Don't use gnome2.eclass anymore, it's only
+ bringing in unused USE flags (like "debug").
*gexiv2-0.2.1 (19 Sep 2010)
diff --git a/media-libs/gexiv2/files/gexiv2-0.2.1-new-exiv2.patch b/media-libs/gexiv2/files/gexiv2-0.2.1-new-exiv2.patch
new file mode 100644
index 000000000000..e730ef110485
--- /dev/null
+++ b/media-libs/gexiv2/files/gexiv2-0.2.1-new-exiv2.patch
@@ -0,0 +1,36 @@
+http://bugs.gentoo.org/349150
+
+--- gexiv2/gexiv2-metadata-exif.cpp
++++ gexiv2/gexiv2-metadata-exif.cpp
+@@ -235,10 +235,13 @@
+ const gchar* gexiv2_metadata_get_exif_tag_label (const gchar* tag) {
+ g_return_val_if_fail(tag != NULL, NULL);
+
+- Exiv2::ExifKey key(tag);
+-
+ try {
++ Exiv2::ExifKey key(tag);
++#if EXIV2_TEST_VERSION(0, 21, 0)
++ return g_intern_string(key.tagLabel().c_str());
++#else
+ return Exiv2::ExifTags::tagLabel (key.tag (), key.ifdId ());
++#endif
+ } catch (Exiv2::Error& e) {
+ LOG_ERROR(e);
+ }
+@@ -249,10 +252,13 @@
+ const gchar* gexiv2_metadata_get_exif_tag_description (const gchar* tag) {
+ g_return_val_if_fail(tag != NULL, NULL);
+
+- Exiv2::ExifKey key(tag);
+-
+ try {
++ Exiv2::ExifKey key(tag);
++#if EXIV2_TEST_VERSION(0, 21, 0)
++ return g_intern_string(key.tagDesc().c_str());
++#else
+ return Exiv2::ExifTags::tagDesc (key.tag (), key.ifdId ());
++#endif
+ } catch (Exiv2::Error& e) {
+ LOG_ERROR(e);
+ }
diff --git a/media-libs/gexiv2/gexiv2-0.2.1.ebuild b/media-libs/gexiv2/gexiv2-0.2.1.ebuild
index d5bfa7810b82..55c1f4cd00a3 100644
--- a/media-libs/gexiv2/gexiv2-0.2.1.ebuild
+++ b/media-libs/gexiv2/gexiv2-0.2.1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/gexiv2-0.2.1.ebuild,v 1.1 2010/09/19 08:19:57 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/gexiv2-0.2.1.ebuild,v 1.2 2010/12/21 15:14:54 ssuominen Exp $
-EAPI="2"
-
-inherit versionator eutils gnome2
+EAPI=2
+inherit versionator eutils multilib toolchain-funcs
MY_PV=$(get_version_component_range 1-2)
@@ -22,8 +21,20 @@ RDEPEND=">=media-gfx/exiv2-0.19
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-S="${WORKDIR}/lib${P}"
+S=${WORKDIR}/lib${P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-new-exiv2.patch
+}
+
+src_configure() {
+ tc-export CXX
+ ./configure --prefix=/usr || die
+}
src_install() {
- gnome2_src_install
+ emake DESTDIR="${D}" LIB="$(get_libdir)" install || die
+ dodoc AUTHORS NEWS README THANKS
+
+ find "${D}" -name '*.la' -exec rm -f '{}' +
}