summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-12-11 01:17:57 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-12-11 01:17:57 +0000
commit301038301384d5f6380d3bcb697698d869a3cbad (patch)
treed829ed93f35d998633c65647eae72ca9f0fe0dd3 /media-libs/giflib/giflib-4.1.0-r3.ebuild
parentVersion bump. (diff)
downloadgentoo-2-301038301384d5f6380d3bcb697698d869a3cbad.tar.gz
gentoo-2-301038301384d5f6380d3bcb697698d869a3cbad.tar.bz2
gentoo-2-301038301384d5f6380d3bcb697698d869a3cbad.zip
use use_with; tidy
Diffstat (limited to 'media-libs/giflib/giflib-4.1.0-r3.ebuild')
-rw-r--r--media-libs/giflib/giflib-4.1.0-r3.ebuild42
1 files changed, 13 insertions, 29 deletions
diff --git a/media-libs/giflib/giflib-4.1.0-r3.ebuild b/media-libs/giflib/giflib-4.1.0-r3.ebuild
index 3bca5e22278e..4fa8297fa9d2 100644
--- a/media-libs/giflib/giflib-4.1.0-r3.ebuild
+++ b/media-libs/giflib/giflib-4.1.0-r3.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/giflib-4.1.0-r3.ebuild,v 1.21 2003/09/22 01:31:47 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/giflib-4.1.0-r3.ebuild,v 1.22 2003/12/11 01:17:55 mr_bones_ Exp $
inherit gnuconfig
IUSE="X gif"
-S=${WORKDIR}/${P}
DESCRIPTION="Library to handle, display and manipulate GIF images"
HOMEPAGE="http://prtr-13.ucsc.edu/~badger/software/libungif/index.shtml"
SRC_URI="ftp://metalab.unc.edu/pub/Linux/libs/giflib/${P}.tar.gz
ftp://prtr-13.ucsc.edu/pub/libungif/${P}.tar.gz"
-DEPEND="X? ( virtual/x11 )"
-
SLOT="0"
LICENSE="as-is | BSD"
KEYWORDS="x86 ppc sparc alpha hppa amd64 ia64"
+DEPEND="X? ( virtual/x11 )"
+
src_unpack() {
unpack ${A} || die
cd ${S}
@@ -28,45 +27,30 @@ src_unpack() {
}
src_compile() {
-
- local myconf
-
- use X \
- && myconf="--with-x" \
- || myconf="--without-x"
-
- econf ${myconf} || die
- emake || die
-
+ econf `use_with x` || die
+ emake || die "emake failed"
}
src_install() {
-
- make \
- prefix=${D}/usr \
- install || die
+ make prefix=${D}/usr install || die "make install failed"
# if gif is not in USE, then ungif is preferred
- use gif || rm -rf ${D}/usr/bin
-
-
- dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS ONEWS
- dodoc PATENT_PROBLEMS README TODO
- dodoc doc/*.txt
- dohtml -r doc
+ use gif || rm -rf "${D}/usr/bin"
+ dodoc AUTHORS BUGS ChangeLog NEWS ONEWS PATENT_PROBLEMS \
+ README TODO doc/*.txt || die "dodoc failed"
+ dohtml -r doc || die "dohtml failed"
}
pkg_postinst() {
-
- use gif 2>/dev/null && (
+ if use gif ; then
einfo "You had the gif USE flag set, so the binary from this library"
einfo "is your gif binary. If you would prefer to use the binary from"
einfo "the ungif library, please unset the gif USE toggle, and remerge"
einfo "both this and libungif"
- ) || (
+ else
einfo "You did not have the gif USE toggle set, so the binary from"
einfo "the libungif package is assumed to be your gif binary. Please"
einfo "make sure that you have libungif emerged."
- )
+ fi
}