summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-12-30 00:55:49 +0000
committerMike Frysinger <vapier@gentoo.org>2012-12-30 00:55:49 +0000
commitdb739e3658139b98f4b16b82b770f54c569dfc42 (patch)
tree050059eb2526dd2a02be4372133a4ea1ba9b7f6d /media-libs/giflib
parentBump to the first official release that works with gdl-3.6. (diff)
downloadgentoo-2-db739e3658139b98f4b16b82b770f54c569dfc42.tar.gz
gentoo-2-db739e3658139b98f4b16b82b770f54c569dfc42.tar.bz2
gentoo-2-db739e3658139b98f4b16b82b770f54c569dfc42.zip
Version bump -- masked until testing in the tree is finished #423393 by Peter Alfredsen.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'media-libs/giflib')
-rw-r--r--media-libs/giflib/ChangeLog8
-rw-r--r--media-libs/giflib/giflib-5.0.2.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/media-libs/giflib/ChangeLog b/media-libs/giflib/ChangeLog
index d57fe281c8c4..2a10f386d398 100644
--- a/media-libs/giflib/ChangeLog
+++ b/media-libs/giflib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/giflib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/ChangeLog,v 1.64 2012/05/09 00:23:21 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/ChangeLog,v 1.65 2012/12/30 00:55:49 vapier Exp $
+
+*giflib-5.0.2 (30 Dec 2012)
+
+ 30 Dec 2012; Mike Frysinger <vapier@gentoo.org> +giflib-5.0.2.ebuild:
+ Version bump -- masked until testing in the tree is finished #423393 by Peter
+ Alfredsen.
09 May 2012; Alexis Ballier <aballier@gentoo.org> giflib-4.1.6-r2.ebuild:
keyword ~amd64-fbsd
diff --git a/media-libs/giflib/giflib-5.0.2.ebuild b/media-libs/giflib/giflib-5.0.2.ebuild
new file mode 100644
index 000000000000..eede698d5bb7
--- /dev/null
+++ b/media-libs/giflib/giflib-5.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/giflib-5.0.2.ebuild,v 1.1 2012/12/30 00:55:49 vapier Exp $
+
+EAPI=4
+
+inherit eutils libtool
+
+DESCRIPTION="Library to handle, display and manipulate GIF images"
+HOMEPAGE="http://sourceforge.net/projects/giflib/"
+SRC_URI="mirror://sourceforge/giflib/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+# Needs testing first.
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="static-libs"
+
+src_prepare() {
+ elibtoolize
+ epunt_cxx
+}
+
+src_configure() {
+ # No need for xmlto as they ship generated files.
+ ac_cv_prog_have_xmlto=no \
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+ doman doc/*.1
+ dodoc doc/*.txt
+ dohtml -r doc
+}