summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-03-30 04:40:56 +0000
committerOlivier Crête <tester@gentoo.org>2009-03-30 04:40:56 +0000
commit8d420b0e232b4d210d3f93da5f8ae32de5589aa9 (patch)
tree81bc846e0710cbf80cafc75f4c128d8077003242 /media-libs/gst-plugins-good
parentRemove +nls to make solar happy (but you really want nls) (diff)
downloadgentoo-2-8d420b0e232b4d210d3f93da5f8ae32de5589aa9.tar.gz
gentoo-2-8d420b0e232b4d210d3f93da5f8ae32de5589aa9.tar.bz2
gentoo-2-8d420b0e232b4d210d3f93da5f8ae32de5589aa9.zip
Version bump
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/ChangeLog10
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-0.10.14.ebuild65
2 files changed, 73 insertions, 2 deletions
diff --git a/media-libs/gst-plugins-good/ChangeLog b/media-libs/gst-plugins-good/ChangeLog
index fe3342ec3687..a50ea77fff0b 100644
--- a/media-libs/gst-plugins-good/ChangeLog
+++ b/media-libs/gst-plugins-good/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/gst-plugins-good
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.58 2008/12/05 20:49:09 ssuominen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.59 2009/03/30 04:40:56 tester Exp $
+
+*gst-plugins-good-0.10.14 (30 Mar 2009)
+
+ 30 Mar 2009; Olivier Crête <tester@gentoo.org>
+ +gst-plugins-good-0.10.14.ebuild:
+ Version bump
*gst-plugins-good-0.10.11 (05 Dec 2008)
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-0.10.14.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-0.10.14.ebuild
new file mode 100644
index 000000000000..3a0ab5b8676f
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-0.10.14.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/gst-plugins-good-0.10.14.ebuild,v 1.1 2009/03/30 04:40:56 tester Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-good gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.22
+ >=media-libs/gstreamer-0.10.22
+ >=dev-libs/liboil-0.3.14"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ dev-util/pkgconfig
+ !<media-libs/gst-plugins-bad-0.10.10"
+
+# overrides the eclass
+src_unpack() {
+ unpack ${A}
+ # Required for FreeBSD sane .so versioning
+ elibtoolize
+}
+
+src_compile() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ gst-plugins-good_src_configure \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+
+ emake || die "emake failed."
+}
+
+# override eclass
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS README RELEASE"
+
+pkg_postinst () {
+ gnome2_pkg_postinst
+
+ echo
+ elog "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ elog "applications now should provide the basic plugins needed."
+ echo
+ elog "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ elog "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ elog "In most cases it shouldn't be needed though to emerge extra plugins."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}