summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-09-13 02:18:06 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-09-13 02:18:06 +0000
commit3e15dc2a1a22bca75a8cc6260534cf6d94c4f8fa (patch)
tree9030067d8b3614a249fa415adb0f73195ea219ab /media-libs/id3lib/files
parentversion bump (bug #63844) (Manifest recommit) (diff)
downloadgentoo-2-3e15dc2a1a22bca75a8cc6260534cf6d94c4f8fa.tar.gz
gentoo-2-3e15dc2a1a22bca75a8cc6260534cf6d94c4f8fa.tar.bz2
gentoo-2-3e15dc2a1a22bca75a8cc6260534cf6d94c4f8fa.zip
Revision bump to fix linking issue. Only changes in files/id3lib-3.8.3-zlib.patch were made, and it's a QA fix directly into stable. Removing old versions.
Diffstat (limited to 'media-libs/id3lib/files')
-rw-r--r--media-libs/id3lib/files/digest-id3lib-3.8.01
-rw-r--r--media-libs/id3lib/files/digest-id3lib-3.8.3-r3 (renamed from media-libs/id3lib/files/digest-id3lib-3.8.3-r1)0
-rw-r--r--media-libs/id3lib/files/id3lib-3.8.0-gcc3.patch97
-rw-r--r--media-libs/id3lib/files/id3lib-3.8.3-zlib.patch23
4 files changed, 23 insertions, 98 deletions
diff --git a/media-libs/id3lib/files/digest-id3lib-3.8.0 b/media-libs/id3lib/files/digest-id3lib-3.8.0
deleted file mode 100644
index 998cc67f8b02..000000000000
--- a/media-libs/id3lib/files/digest-id3lib-3.8.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 9d5947e2c25c846b03faadfb8c6e8601 id3lib-3.8.0.tar.gz 934333
diff --git a/media-libs/id3lib/files/digest-id3lib-3.8.3-r1 b/media-libs/id3lib/files/digest-id3lib-3.8.3-r3
index cfb850ce9d1e..cfb850ce9d1e 100644
--- a/media-libs/id3lib/files/digest-id3lib-3.8.3-r1
+++ b/media-libs/id3lib/files/digest-id3lib-3.8.3-r3
diff --git a/media-libs/id3lib/files/id3lib-3.8.0-gcc3.patch b/media-libs/id3lib/files/id3lib-3.8.0-gcc3.patch
deleted file mode 100644
index 12c8bc5ab37a..000000000000
--- a/media-libs/id3lib/files/id3lib-3.8.0-gcc3.patch
+++ /dev/null
@@ -1,97 +0,0 @@
---- include/id3/id3lib_strings.h.orig 2002-08-21 16:41:11.000000000 -0600
-+++ include/id3/id3lib_strings.h 2002-08-21 16:40:32.000000000 -0600
-@@ -30,6 +30,94 @@
-
- #include <string>
-
-+#if (defined(__GNUC__) && (__GNUC__ >= 3) || (defined(_MSC_VER) && _MSC_VER > 1000))
-+namespace std
-+{
-+ template<>
-+ struct char_traits<unsigned char>
-+ {
-+ typedef unsigned char char_type;
-+ // Unsigned as wint_t in unsigned.
-+ typedef unsigned long int_type;
-+ typedef streampos pos_type;
-+ typedef streamoff off_type;
-+ typedef mbstate_t state_type;
-+
-+ static void
-+ assign(char_type& __c1, const char_type& __c2)
-+ { __c1 = __c2; }
-+
-+ static bool
-+ eq(const char_type& __c1, const char_type& __c2)
-+ { return __c1 == __c2; }
-+
-+ static bool
-+ lt(const char_type& __c1, const char_type& __c2)
-+ { return __c1 < __c2; }
-+
-+ static int
-+ compare(const char_type* __s1, const char_type* __s2, size_t __n)
-+ {
-+ for (size_t __i = 0; __i < __n; ++__i)
-+ if (!eq(__s1[__i], __s2[__i]))
-+ return lt(__s1[__i], __s2[__i]) ? -1 : 1;
-+ return 0;
-+ }
-+
-+ static size_t
-+ length(const char_type* __s)
-+ {
-+ const char_type* __p = __s;
-+ while (__p)
-+ ++__p;
-+ return (__p - __s);
-+ }
-+
-+ static const char_type*
-+ find(const char_type* __s, size_t __n, const char_type& __a)
-+ {
-+ for (const char_type* __p = __s; size_t(__p - __s) < __n; ++__p)
-+ if (*__p == __a) return __p;
-+ return 0;
-+ }
-+
-+ static char_type*
-+ move(char_type* __s1, const char_type* __s2, size_t __n)
-+ { return (char_type*) memmove(__s1, __s2, __n * sizeof(char_type)); }
-+
-+ static char_type*
-+ copy(char_type* __s1, const char_type* __s2, size_t __n)
-+ { return (char_type*) memcpy(__s1, __s2, __n * sizeof(char_type)); }
-+
-+ static char_type*
-+ assign(char_type* __s, size_t __n, char_type __a)
-+ {
-+ for (char_type* __p = __s; __p < __s + __n; ++__p)
-+ assign(*__p, __a);
-+ return __s;
-+ }
-+
-+ static char_type
-+ to_char_type(const int_type& __c)
-+ { return char_type(); }
-+
-+ static int_type
-+ to_int_type(const char_type& __c) { return int_type(); }
-+
-+ static bool
-+ eq_int_type(const int_type& __c1, const int_type& __c2)
-+ { return __c1 == __c2; }
-+
-+ static int_type
-+ eof() { return static_cast<int_type>(-1); }
-+
-+ static int_type
-+ not_eof(const int_type& __c)
-+ { return eq_int_type(__c, eof()) ? int_type(0) : __c; }
-+ };
-+} // namespace std
-+#endif
-+
- namespace dami
- {
- typedef std::basic_string<char> String;
diff --git a/media-libs/id3lib/files/id3lib-3.8.3-zlib.patch b/media-libs/id3lib/files/id3lib-3.8.3-zlib.patch
new file mode 100644
index 000000000000..177320bc17a3
--- /dev/null
+++ b/media-libs/id3lib/files/id3lib-3.8.3-zlib.patch
@@ -0,0 +1,23 @@
+diff -Naur id3lib-3.8.3.orig/Makefile.am id3lib-3.8.3/Makefile.am
+--- id3lib-3.8.3.orig/Makefile.am 2003-03-01 16:23:00.000000000 -0800
++++ id3lib-3.8.3/Makefile.am 2004-09-12 19:05:39.564456828 -0700
+@@ -28,7 +28,7 @@
+ endif
+
+ SUBDIRS = . m4 $(zlib_subdir) doc include id3com src examples
+-DIST_SUBDIRS = . m4 zlib doc include id3com src examples prj libprj
++DIST_SUBDIRS = . m4 $(zlib_subdir) doc include id3com src examples prj libprj
+
+ INCLUDES = @ID3LIB_DEBUG_FLAGS@
+
+diff -Naur id3lib-3.8.3.orig/src/Makefile.am id3lib-3.8.3/src/Makefile.am
+--- id3lib-3.8.3.orig/src/Makefile.am 2003-03-01 16:23:00.000000000 -0800
++++ id3lib-3.8.3/src/Makefile.am 2004-09-12 19:08:30.814149521 -0700
+@@ -77,6 +77,7 @@
+ endif
+
+ libid3_la_LDFLAGS = \
++ -lz \
+ -version-info $(LT_VERSION) \
+ -release $(LT_RELEASE) \
+ -export-dynamic