summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-02-20 11:47:02 +0000
committerMike Frysinger <vapier@gentoo.org>2003-02-20 11:47:02 +0000
commit808b84c968c142a18c3cc27db0ec59dea99989cd (patch)
tree8d0a440446257fcb0ba5dd5ea186fdec8c90413f /media-libs/imlib2
parentinitial import for e17 seperation (diff)
downloadgentoo-2-808b84c968c142a18c3cc27db0ec59dea99989cd.tar.gz
gentoo-2-808b84c968c142a18c3cc27db0ec59dea99989cd.tar.bz2
gentoo-2-808b84c968c142a18c3cc27db0ec59dea99989cd.zip
initial import for e17 seperation
Diffstat (limited to 'media-libs/imlib2')
-rw-r--r--media-libs/imlib2/ChangeLog13
-rw-r--r--media-libs/imlib2/files/digest-imlib2-1.0.6.200302201
-rw-r--r--media-libs/imlib2/imlib2-1.0.6.20030220.ebuild41
3 files changed, 48 insertions, 7 deletions
diff --git a/media-libs/imlib2/ChangeLog b/media-libs/imlib2/ChangeLog
index 5f19bc249f38..b939f120ec32 100644
--- a/media-libs/imlib2/ChangeLog
+++ b/media-libs/imlib2/ChangeLog
@@ -1,37 +1,36 @@
# ChangeLog for media-libs/imlib2
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/ChangeLog,v 1.8 2003/02/12 07:08:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/ChangeLog,v 1.9 2003/02/20 11:45:31 vapier Exp $
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+*imlib2-1.0.6.20030220 (20 Feb 2003)
+
+ 20 Feb 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump (bug fixes from CVS).
*imlib2-1.0.6-r1 (26 Apr 2002)
+
26 Apr 2002; Spider <spider@gentoo.org> imlib2-1.0.6-r1.ebuild :
libtoolize
-
*imlib2-1.0.6 (26 Apr 2002)
26 Apr 2002; Seemant Kulleen <seemant@gentoo.org> imlib2-1.0.6.ebuild
files/digest-imlib2-1.0.6 :
-
Version bump
*imlib2-1.0.5 (12 Apr 2002)
12 Apr 2002; Seemant Kulleen <seemant@gentoo.org> imlib2-1.0.5-r1.ebuild :
-
Recompile against libpng-1.2.1
*imlib2-1.0.5 (27 Mar 2002)
27 Mar 2002; Seemant Kulleen <seemant@gentoo.org> imlib2-1.0.5.ebuild :
-
Ungzipped HTML docs.
*imlib2-1.0.5 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/media-libs/imlib2/files/digest-imlib2-1.0.6.20030220 b/media-libs/imlib2/files/digest-imlib2-1.0.6.20030220
new file mode 100644
index 000000000000..a3a2a14360d1
--- /dev/null
+++ b/media-libs/imlib2/files/digest-imlib2-1.0.6.20030220
@@ -0,0 +1 @@
+MD5 f8028f6ba736fa1dbacdcdb701058797 imlib2-1.0.6.20030220.tar.bz2 564221
diff --git a/media-libs/imlib2/imlib2-1.0.6.20030220.ebuild b/media-libs/imlib2/imlib2-1.0.6.20030220.ebuild
new file mode 100644
index 000000000000..ceee6712f72f
--- /dev/null
+++ b/media-libs/imlib2/imlib2-1.0.6.20030220.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.0.6.20030220.ebuild,v 1.1 2003/02/20 11:45:31 vapier Exp $
+
+DESCRIPTION="Version 2 of an advanced replacement library for libraries like libXpm"
+HOMEPAGE="http://www.enlightenment.org/pages/imlib2.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://wh0rd.tk/gentoo/distfiles/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+IUSE="mmx ungif gif png jpeg tiff static X pic"
+
+DEPEND="=media-libs/freetype-1*
+ ungif? ( media-libs/libungif )
+ gif? ( >=media-libs/giflib-4.1.0 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( >=media-libs/tiff-3.5.5 )"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ cp autogen.sh{,.old}
+ sed -e 's:.*configure.*::' autogen.sh.old > autogen.sh
+ env USER=blah WANT_AUTOCONF_2_5=1 ./autogen.sh || die "could not autogen"
+
+ local myconf="--sysconfdir=/etc/X11/imlib --with-gnu-ld"
+ myconf="${myconf} `use_with pic` `use_enable mmx` `use_with X x`"
+ econf ${myconf} || die "could not configure"
+ emake || die "could not make"
+}
+
+src_install() {
+ make prefix=${D}/usr sysconfdir=${D}/etc/X11/imlib install || die
+ dodoc AUTHORS ChangeLog README TODO
+ dohtml -r doc
+ docinto samples
+ dodoc demo/*.c
+}