summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-09-24 17:32:44 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-09-24 17:32:44 +0000
commit0d0d884f0b13f90042d9cb46a00cb8cfc9e65ec2 (patch)
treef2764380883c6240276bfe00958286f2da77d981 /media-libs/janus/janus-0.4.6.ebuild
parentVersion bumped. Closes #19654. (diff)
downloadgentoo-2-0d0d884f0b13f90042d9cb46a00cb8cfc9e65ec2.tar.gz
gentoo-2-0d0d884f0b13f90042d9cb46a00cb8cfc9e65ec2.tar.bz2
gentoo-2-0d0d884f0b13f90042d9cb46a00cb8cfc9e65ec2.zip
Version bumped. Closes #19654.
Diffstat (limited to 'media-libs/janus/janus-0.4.6.ebuild')
-rw-r--r--media-libs/janus/janus-0.4.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/janus/janus-0.4.6.ebuild b/media-libs/janus/janus-0.4.6.ebuild
new file mode 100644
index 000000000000..5bffe52861dc
--- /dev/null
+++ b/media-libs/janus/janus-0.4.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/janus/janus-0.4.6.ebuild,v 1.1 2003/09/24 17:32:39 mholzer Exp $
+
+IUSE="gtk"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A UI and widget library which employs an extensible XML like data structure and provides an abstract instance of a UI"
+SRC_URI="ftp://victor.worldforge.org/pub/worldforge/libs/janus/${P}.tar.gz"
+HOMEPAGE="http://www.worldforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-libs/libsigc++-1.2*
+ >=media-libs/libsdl-1.2.4
+ gtk? ( >=x11-libs/gtk+-1.2.8 )"
+
+src_compile() {
+ econf || die "configure died"
+ emake || die "make died"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install died"
+}