summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-07-31 10:04:15 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-07-31 10:04:15 +0000
commit8be73ab14cf9bbe77ad313ff8bb4dab83616eef4 (patch)
tree8b6d465e3189b02e8adce5cc3ce65d78cc9ad612 /media-libs/jpeg
parentupdate the multilib mask again for jpeg (diff)
downloadgentoo-2-8be73ab14cf9bbe77ad313ff8bb4dab83616eef4.tar.gz
gentoo-2-8be73ab14cf9bbe77ad313ff8bb4dab83616eef4.tar.bz2
gentoo-2-8be73ab14cf9bbe77ad313ff8bb4dab83616eef4.zip
Convert to the new multilib format.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/jpeg')
-rw-r--r--media-libs/jpeg/ChangeLog8
-rw-r--r--media-libs/jpeg/jpeg-8d-r1.ebuild73
-rw-r--r--media-libs/jpeg/jpeg-9.ebuild30
3 files changed, 98 insertions, 13 deletions
diff --git a/media-libs/jpeg/ChangeLog b/media-libs/jpeg/ChangeLog
index 249d005cd27b..78c49490038e 100644
--- a/media-libs/jpeg/ChangeLog
+++ b/media-libs/jpeg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/jpeg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.137 2013/01/14 11:00:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.138 2013/07/31 10:04:15 ssuominen Exp $
+
+*jpeg-8d-r1 (31 Jul 2013)
+
+ 31 Jul 2013; Samuli Suominen <ssuominen@gentoo.org> +jpeg-8d-r1.ebuild,
+ jpeg-9.ebuild:
+ Convert to the new multilib format.
*jpeg-9 (14 Jan 2013)
diff --git a/media-libs/jpeg/jpeg-8d-r1.ebuild b/media-libs/jpeg/jpeg-8d-r1.ebuild
new file mode 100644
index 000000000000..06d531d22f2d
--- /dev/null
+++ b/media-libs/jpeg/jpeg-8d-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-8d-r1.ebuild,v 1.1 2013/07/31 10:04:15 ssuominen Exp $
+
+EAPI=5
+inherit eutils libtool toolchain-funcs multilib-minimal
+
+MY_PN=libjpeg8
+MY_PV=1
+
+DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
+HOMEPAGE="http://jpegclub.org/ http://www.ijg.org/"
+SRC_URI="http://www.ijg.org/files/${PN}src.v${PV}.tar.gz
+ mirror://debian/pool/main/${MY_PN:0:4}/${MY_PN}/${MY_PN}_${PV}-${MY_PV}.debian.tar.gz"
+
+LICENSE="IJG"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-7-maxmem_sysconf.patch
+ elibtoolize
+}
+
+multilib_src_configure() {
+ # Fix building against this library on eg. Solaris and DragonFly BSD, see:
+ # http://mail-index.netbsd.org/pkgsrc-bugs/2010/01/18/msg035644.html
+ local ldverscript=
+ [[ ${CHOST} == *-solaris* ]] && ldverscript="--disable-ld-version-script"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ --enable-maxmem=64 \
+ ${ldverscript}
+}
+
+multilib_src_compile() {
+ emake
+
+ if [[ ${ABI} == ${DEFAULT_ABI} ]]; then
+ # Build exifautotran and jpegexiforient
+ cd ../debian/extra
+ emake CC="$(tc-getCC)" CFLAGS="${LDFLAGS} ${CFLAGS}"
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+
+ dodoc change.log example.c README *.txt
+
+ # Install exifautotran and jpegexiforient
+ newdoc ../debian/changelog changelog.debian
+ cd ../debian/extra
+ emake \
+ DESTDIR="${D}" prefix="${EPREFIX}"/usr \
+ INSTALL="install -m755" INSTALLDIR="install -d -m755" \
+ install
+}
+
+pkg_postinst() {
+ ewarn "If you are switching from media-libs/libjpeg-turbo you might need to"
+ ewarn "rebuild reverse dependencies:"
+ ewarn
+ ewarn "# emerge gentoolkit"
+ ewarn "# revdep-rebuild --library libjpeg.so.8"
+}
diff --git a/media-libs/jpeg/jpeg-9.ebuild b/media-libs/jpeg/jpeg-9.ebuild
index fcbf145ccd70..4ecfabe5caf0 100644
--- a/media-libs/jpeg/jpeg-9.ebuild
+++ b/media-libs/jpeg/jpeg-9.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-9.ebuild,v 1.1 2013/01/14 11:00:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-9.ebuild,v 1.2 2013/07/31 10:04:15 ssuominen Exp $
EAPI=5
-inherit eutils libtool toolchain-funcs
+inherit eutils libtool toolchain-funcs multilib-minimal
DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
HOMEPAGE="http://jpegclub.org/ http://www.ijg.org/"
@@ -17,37 +17,43 @@ KEYWORDS=""
#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs"
-DOCS="change.log example.c README *.txt"
-
src_prepare() {
epatch "${FILESDIR}"/${PN}-7-maxmem_sysconf.patch
elibtoolize
}
-src_configure() {
+multilib_src_configure() {
# Fix building against this library on eg. Solaris and DragonFly BSD, see:
# http://mail-index.netbsd.org/pkgsrc-bugs/2010/01/18/msg035644.html
local ldverscript=
[[ ${CHOST} == *-solaris* ]] && ldverscript="--disable-ld-version-script"
+ ECONF_SOURCE=${S} \
econf \
$(use_enable static-libs static) \
--enable-maxmem=64 \
${ldverscript}
}
-src_compile() {
- default
+multilib_src_compile() {
+ emake
- # Build exifautotran and jpegexiforient
- cd ../debian/extra
- emake CC="$(tc-getCC)" CFLAGS="${LDFLAGS} ${CFLAGS}"
+ if [[ ${ABI} == ${DEFAULT_ABI} ]]; then
+ # Build exifautotran and jpegexiforient
+ cd ../debian/extra
+ emake CC="$(tc-getCC)" CFLAGS="${LDFLAGS} ${CFLAGS}"
+ fi
}
-src_install() {
- default
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
prune_libtool_files
+ dodoc change.log example.c README *.txt
+
# Install exifautotran and jpegexiforient
newdoc ../debian/changelog changelog.debian
cd ../debian/extra