summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-05-10 19:01:31 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-05-10 19:01:31 +0000
commit36edd26973bab9885bc2b2fd088659c1c42e40e7 (patch)
tree2a9ef69080171eaa53f2988f4c7b4f66d2030098 /media-libs/lensfun
parentMarking libvpx-0.9.6 ppc64 for bug 408555 (diff)
downloadgentoo-2-36edd26973bab9885bc2b2fd088659c1c42e40e7.tar.gz
gentoo-2-36edd26973bab9885bc2b2fd088659c1c42e40e7.tar.bz2
gentoo-2-36edd26973bab9885bc2b2fd088659c1c42e40e7.zip
Install pkg-config file, bug 412813
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/lensfun')
-rw-r--r--media-libs/lensfun/ChangeLog9
-rw-r--r--media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch17
-rw-r--r--media-libs/lensfun/lensfun-0.2.5_p153-r1.ebuild (renamed from media-libs/lensfun/lensfun-0.2.5_p153.ebuild)7
3 files changed, 30 insertions, 3 deletions
diff --git a/media-libs/lensfun/ChangeLog b/media-libs/lensfun/ChangeLog
index a8fc5a856796..b82133b76c5e 100644
--- a/media-libs/lensfun/ChangeLog
+++ b/media-libs/lensfun/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/lensfun
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.41 2012/05/05 08:02:45 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.42 2012/05/10 19:01:31 dilfridge Exp $
+
+*lensfun-0.2.5_p153-r1 (10 May 2012)
+
+ 10 May 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ -lensfun-0.2.5_p153.ebuild, +lensfun-0.2.5_p153-r1.ebuild,
+ +files/lensfun-0.2.5_p153-pc.patch:
+ Install pkg-config file, bug 412813
05 May 2012; Jeff Horelick <jdhore@gentoo.org> lensfun-0.2.5-r2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch b/media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch
new file mode 100644
index 000000000000..a74acf8fe70d
--- /dev/null
+++ b/media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch
@@ -0,0 +1,17 @@
+Index: libs/lensfun/CMakeLists.txt
+===================================================================
+--- libs/lensfun/CMakeLists.txt (Revision 158)
++++ libs/lensfun/CMakeLists.txt (Arbeitskopie)
+@@ -26,3 +26,12 @@
+ RUNTIME DESTINATION ${BINDIR}
+ LIBRARY DESTINATION ${LIBDIR}
+ ARCHIVE DESTINATION ${LIBDIR})
++
++IF(UNIX AND NOT APPLE)
++ SET(CONF_VERSION "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_MICRO}.${VERSION_BUGFIX}")
++ SET(CONF_LIBDIR "${CMAKE_INSTALL_LIBDIR}/")
++ SET(CONF_INCLUDEDIR "${CMAKE_INSTALL_PREFIX}/${INCLUDEDIR}/")
++ SET(CONF_LENSFUN_STATIC "")
++ CONFIGURE_FILE("lensfun.pc.in" "lensfun.pc" @ONLY)
++ INSTALL(FILES "${CMAKE_CURRENT_BINARY_DIR}/lensfun.pc" DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
++ENDIF(UNIX AND NOT APPLE)
diff --git a/media-libs/lensfun/lensfun-0.2.5_p153.ebuild b/media-libs/lensfun/lensfun-0.2.5_p153-r1.ebuild
index e30a7c39cdf9..7c2a590bcec1 100644
--- a/media-libs/lensfun/lensfun-0.2.5_p153.ebuild
+++ b/media-libs/lensfun/lensfun-0.2.5_p153-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/lensfun-0.2.5_p153.ebuild,v 1.1 2012/04/14 16:16:37 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/lensfun-0.2.5_p153-r1.ebuild,v 1.1 2012/05/10 19:01:31 dilfridge Exp $
EAPI=4
inherit python multilib cmake-utils
@@ -19,7 +19,10 @@ RDEPEND=">=dev-libs/glib-2
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
-PATCHES=( "${FILESDIR}/${P}-build.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-pc.patch"
+)
pkg_setup() {
python_set_active_version 2